Fail2Ban not working...

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • riff-raff wrote:

      You should use OMV4 right now since OMV3 is EOL.
      There is no fail2ban plugin in OMV4 though.

      riff-raff wrote:

      You should not open SSH towards internet, prefer VPN
      If you use public key auth, disable root logins, disable password auth, and use a different port, I don't see why ssh is any less secure than vpn. This is what I do. I also change the port on my router's (pfsense) port forwarding so I can leave port 22 for internal use but port 22 isn't open to the internet (which will get attacked much more by the bots).
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I know there is no fail2ban in OMV4, but for a fresh install I would prefer the latest stable.

      I used fail2ban on my nextcloud install for the last 2 years on OMV3 and never had any incidance with one trying to get access. I still have a lot of pings and reaches which I can see in nextcloud-log.

      Still a plugin on my wish list for OMV4, next to calibre.
      Chaos is found in greatest abundance wherever order is being sought.
      It always defeats order, because it is better organized.
      Terry Pratchett
    • hey - i'm new here (first install / first install problems -.- you know)

      what i can see so far is: fail2ban will not work for http requests as long as the login page returns http code 200 for an access denied case.

      fail2ban works with error logs and wrong return codes prevent any use of it.

      its not the fault of the environment (nginx etc.) as logs only contain request urls and not the post data.

      if the omv implementation is modified, fail2ban and any other log crawler will work again

      the ssh part is a different story - and i think it's not really part of the omv service.
      you would have the same problems on any other installation