OMV extra plug-ins when upgrade from 3.x to 4.x

    • OMV 3.x
    • Resolved
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV extra plug-ins when upgrade from 3.x to 4.x

      Hi,

      I'd like to upgrade my OMV 3 (Erasmus) to 4 (Arrakis).
      I have read some useful posts, for example this and this but I still have some questions regarding the plug-ins, specially the ones related to LVM and LUKS I'm using:

      Source Code

      1. $ dpkg -l | grep openm | awk '{print $2" "$3}'
      2. openmediavault 3.0.99
      3. openmediavault-backup 3.11
      4. openmediavault-luksencryption 3.0.3
      5. openmediavault-lvm2 3.2.5
      6. openmediavault-netatalk 3.2.11
      7. openmediavault-nut 3.2.12
      8. openmediavault-omvextrasorg 3.4.30
      I couldn't find them for Arrakis, so are there any plans to package them? If yes, I'd consider to postpone the upgrade (I have no rush at all).

      If I remove them… well, that doesn't sound good in terms of my data availability.

      Apart from this, I've created a VM to simulate the upgrade process, by setting it up with plug-ins, RAID settings and so on I'm using. I upgraded it by keeping all plug-ins could find any issue (after the reboot, everything seems to work). Is this expected or could I face troubles once certain core packages are updated?


      Thanks all and sorry for another "how to upgrade" thread.
    • AnOMVuser wrote:

      so are there any plans to package them?
      What do you mean you couldn't find them for Arrakis? They are on the page you linked to. If the version is still 3.x, that means the plugin works on OMV 3.x and 4.x without modification. LVM, netatalk, and nut are core OMV plugins so they won't be on the omv-extras page.

      AnOMVuser wrote:

      If I remove them… well, that doesn't sound good in terms of my data availability.
      You don't have to remove any of those.

      AnOMVuser wrote:

      Is this expected
      Yes. The OMV 3.x -> 4.x upgrade works very well.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!