Can't get OpenVPN to work with OMV 4

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't get OpenVPN to work with OMV 4

      I previously had OpenVPN working on OMV 3 but I lost it when I upgraded to OMV 4. I recently saw that the plugin has been updated so I installed it and tried to set it up with the same settings as before, but I can't get my phone to connect to it.

      I used the settings found in this post.

      Here they are:

      Port1194
      ProtocolUDP
      Use compression
      Enabled
      PAM Authentication
      Disabled
      Address10.8.0.0
      Mask255.255.255.0
      Gateway Interface
      eth0
      Default Gateway
      Enabled
      Client to client
      Disabled
      DNS Server
      8.8.8.8,8.8.4.4
      Pubic Address
      My DDNS address

      Every time I try to connect with the OpenVPN app it just times out.
      Odroid HC-2, OMV 4.1.9 (Arrakis)
    • I haven't worked on OMV 3, but recently switched to OMV 4 on my raspberry pi.
      Sadly, OpenVPN is broken. Even, that dashboard showing 2 green dots on service, however from logs I see that OpenVPN exit with error.

      Source Code

      1. raspberrypi systemd[1]: Failed to start OpenVPN connection to server.
      2. raspberrypi systemd[1]: openvpn@server.service: Unit entered failed state.
      3. raspberrypi systemd[1]: openvpn@server.service: Failed with result 'exit-code'.


      During plugin installation all looks fine in logs

      Source Code

      1. Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' restart on user request
      2. Jul 16 06:15:54 raspberrypi monit[1140]: Monit daemon with PID 1140 awakened
      3. Jul 16 06:15:54 raspberrypi monit[1140]: Awakened by User defined signal 1
      4. Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' trying to restart
      5. Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' stop: '/bin/systemctl stop openmediavault-engined'
      6. Jul 16 06:15:54 raspberrypi systemd[1]: Stopping The OpenMediaVault engine daemon that processes the RPC request...
      7. Jul 16 06:15:54 raspberrypi systemd[1]: Stopped The OpenMediaVault engine daemon that processes the RPC request.
      8. Jul 16 06:15:54 raspberrypi monit[1140]: 'omv-engined' start: '/bin/systemctl start openmediavault-engined'
      9. Jul 16 06:15:54 raspberrypi systemd[1]: Starting The OpenMediaVault engine daemon that processes the RPC request...
      10. Jul 16 06:15:54 raspberrypi systemd[1]: Started The OpenMediaVault engine daemon that processes the RPC request.
      However not working.

      Will investigate when will have a minute.

      Also, when trying to create certificates got following error


      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf openvpn add '58f01e6b-5192-497d-834f-27caef22789a' 2>&1' with exit code '1': Easy-RSA error: EASYRSA_PKI does not exist (perhaps you need to run init-pki)? Expected to find the EASYRSA_PKI at: /etc/openvpn/pki Run easyrsa without commands for usage and command help.

      The post was edited 1 time, last by dariusz_w ().

    • Hi,

      any news on this?
      I have the same problem. Dashboard shows green lights, but openvpn is not running. I installed and configured the openvpn plugin the same way as in OMV3.
      Any help would be greatly appreciated.

      p.parker
      [IMG:https://picload.org/view/dllaplgr/dashboard-omv4.png.html]
      [IMG:https://picload.org/view/dllapioa/openvpn-plugin-omv4.png.html]

      Source Code

      1. root@Odroid-HC1:~# ps -aux | grep openvpn
      2. root 11313 0.0 0.0 3764 588 pts/0 S+ 15:15 0:00 grep openvpn
      3. root@Odroid-HC1:~#
      odroid hc1 | omv 4.1.9 (Arrakis) | 4.14.55-odroidxu4 (switched back to OMV3 because of non-functional OpenVPN Plugin)
      odroid hc1 | omv 3.0.99 (Erasmus) | 4.9.61-odroidxu4

      The post was edited 1 time, last by peterparker ().