Share with permissions

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Share with permissions

      Good morning,
      I am new to OMV. I've read the forum over and over and wathched some videos linked in the top of this sections. Tried everything there and no luck so, I am now creating the topic because of the impossibility of a solution.

      I have the OMV being deployed to a Rural community here in Brazil, in a server I've put together with donations. It is a quad core due from 2008, 6gb of ram and 1 4tb HD. The place does not have internet, so I'm going to put videos about history, portuguese, english and other stuff to help the educational o centre there. Then I'll need some share folders with passwords, to allow the users to save some of their own files, specially to backup the clients, as many of the pcs have different configs, I want to be able to reinstall them onsite (I am doing this as a volunteer job).

      Software:
      OMV-4 latest installed over debian latest. All up-to date.

      The steps so far:
      01) I need to create a simple share for the media content, where all the videos will be available;
      Got it. I did this: Created the Share and in samba I've set it like this:
      Enabled the Share;
      Public: guests allowed;
      Browseable;
      Honor ACLs;
      Permissions inheritance;
      Worked? YES!

      02) I need to create some private folders for specific users;
      Name: teste
      Permissions: Administrator read/write; user: read/write; other: no access;
      Did it like this:
      Enabled the share;
      Public: no;
      Browseable;
      Honor ACLs;
      Permissons inheritance;

      03) I need to create users (teachers, etc) to be able to allow some private storege with password protection;
      Created 2 users. Mine for start, peter.
      Created it with default, and password.

      04) Now I set the permissions on the user specific folder.
      Selected the user. Then privilegies. Selected the folder assigned to the user. Set it read/write.
      Apllied the settings.

      06) tried to acces the share. No luck.
      It asks the password for the share. I Type it and got an error. The message says: "sharename" is not eccsible. Maybe you do not have permissions to user this... contact administrator...

      Any ideas?

      I am very newbie in linux, I use ubuntu/debian and my level of proficiency is on the apt-get update/upgrade/dist-upgrade level.

      Please be gentle.
    • peterrrjr wrote:

      Update:
      I've changed the ACL to block one user to not be able to access the share. He got blocked successfully. BUT the user that is supposed to be able to access the file got blocked as well.
      Managed to get it working but with caveats. Only Linux connections are working. I cannot switch from one share to other. example: User peter (admin) connected to the server. Then I tried to access the folder owned by user Ana. I get blocked. Windows asks me to change credentials. I did so, using Ana's passowrd. No access. Maybe it is a windows related issue?