Some errors after upgrade

    • OMV 4.x
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Some errors after upgrade

      HI.

      I just did the upgrade from 3 to 4. First omv-update, all was in final stage already, then omv-release-upgrade.

      It worked quite smooth. After reboot I could log in and first started the updates again.

      Few things I have problems:

      First: I miss all the small radio buttons, for example if a plugin is installed or not, if a share (SMB for example) is active or not. All these buttons are missed everywhere.

      Second: When I want to enter raid or filesystem I get an error: Invalid RPC Response. In details it says:

      Source Code

      1. Fehler #0:
      2. OMV\Rpc\Exception: Invalid RPC response. Please check the syslog for more information. in /usr/share/php/openmediavault/rpc/rpc.inc:186
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('RaidMgmt', 'getList', Array, Array, 3)
      5. #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      6. #2 {main}
      Third: I just got an email from the system:



      Source Code

      1. PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20131226/pam.so' - /usr/lib/php5/20131226/pam.so: cannot open shared object file: No such file or directory in Unknown on line 0

      Any ideas?

      Rest seems to work.

      Regards and thanks for help!
    • Part of that seems like you need to clear your browser cache. The other part seems like a plugin or two didn't get upgraded. What is the output of: dpkg -l | grep openm
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Right, button problem was browser cache!

      Output:

      Source Code

      1. ii libopenmpt0:amd64 0.2.7386~beta20.3-3+deb9u2 amd64 module music library based on OpenMPT -- shared library
      2. ii openmediavault 4.1.7 all openmediavault - The open network attached stor age solution
      3. ii openmediavault-downloader 3.6.2 all OpenMediaVault downloader plugin
      4. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archiv e
      5. ii openmediavault-minidlna 3.3.11 all OpenMediaVault miniDLNA (DLNA server) plugin
      6. ii openmediavault-omvextrasorg 3.4.30 all OMV-Extras.org Package Repositories for OpenMed iaVault
      7. ii openmediavault-plexmediaserver 3.8.2 all OpenMediaVault Plex Media Server plugin
      8. ii openmediavault-remotemount 3.0.10 all Remote mount plugin for OpenMediaVault.
      9. ii openmediavault-resetperms 3.3 all Reset Permissions
      10. ii openmediavault-rsnapshot 3.12 all OpenMediaVault rsnapshot backup plugin.
      11. ii openmediavault-webdav 3.0.3 all OpenMediaVault WebDAV plugin.
      Display All
    • Ok. I figured it out. Problem was the omvextraorg. It was not updated and all of the plugins also not.

      So I first installed omvextraorg 4.x via the extensions. Then within extraorg I did an Apt Clean and Renew. After that I did another update of OMV. Now I have all plugins as latest versions, also I can access all the filesystem and Raid. No error anymore!

      Do you think I can leave it like that without having any problems in future?

      Two more questions:

      I had the plexmedia plugin installed. After the whole update process plex is still working fine. But in the OMV-extras the button of plexmedia repo is not green....Any idea what I can do?

      And then do you know what this process is doing always around 11%?

      2526 root 20 0 43148 3268 2684 R 11.8 0.1 0:00.04 top

      Thanks a lot for your help!
    • lulu99 wrote:

      With my solution as described above do you think all is fixed so no problems for the future?
      I would think so.

      lulu99 wrote:

      Any idea why it did not update omvextraorg directly during upgrade?
      Seems that the pre-release-upgrade script did not run to update the omv-extras repos. Not sure why. It worked on my test and production systems.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!