No raid on plex via Docker

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • You can look here :)

      Host path in the path of the folder on your host, so i suppose : "sharedfolders/Media"
      You must map Host directories in container directories like this:

      I'm a Docker Technical Sales Professional.

      1 NAS OMV 4 (Intel Pentium 4560 3.5 GHz, Asrock H110M-ITX, 24 Gb DDR4, 2*4 To Seagate Ironwolf Nas, 2*4 To WD red)
      1 RPI 3 seedbox with omv 3.X
      1 Backup Server omv 4 (core 2 quad q6600, 4 Gb DDR2, 2*4To WD blue)
    • In Volumes and Bind mounts, under the Container path, you have to have a valid entry there. Type a forward slash ( / ) in an empty box and you can select from the valid choices. For /config and /transcode you can not set those Read Only (R/O).
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • No idea what going on.

      Can't even re-add plex to docker after I deleted it.

      Source Code

      1. Error #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; docker run -d --restart=always -v /etc/localtime:/etc/localtime:ro --net=host -e PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" -e HOME="/root" -e LANGUAGE="en_US.UTF-8" -e LANG="en_US.UTF-8" -e TERM="xterm" -e DEBIAN_FRONTEND="noninteractive" -e PLEX_DOWNLOAD="https://downloads.plex.tv/plex-media-server" -e PLEX_INSTALL="https://plex.tv/downloads/latest/1?channel=8&build=linux-ubuntu-x86_64&distro=ubuntu" -e PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR="/config/Library/Application Support" -e PLEX_MEDIA_SERVER_HOME="/usr/lib/plexmediaserver" -e PLEX_MEDIA_SERVER_INFO_DEVICE="docker" -e PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS="6" -e PLEX_MEDIA_SERVER_USER="abc" -v "/" "linuxserver/plex:latest" 2>&1' with exit code '127': 7e18025ae85f6cded24d15b87705958b5594955e108c9a74853bd7f0c55581fe
      3. docker: Error response from daemon: OCI runtime create failed: container_linux.go:348: starting container process caused "open /proc/self/fd: no such file or directory": unknown. in /usr/share/php/openmediavault/system/process.inc:175
      4. Stack trace:
      5. #0 /usr/share/openmediavault/engined/rpc/docker.inc(587): OMV\System\Process->execute()
      6. #1 [internal function]: OMVRpcServiceDocker->runContainer(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      8. #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('runContainer', Array, Array)
      9. #4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'runContainer', Array, Array, 1)
      10. #5 {main}


      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; docker run -d --restart=always -v /etc/localtime:/etc/localtime:ro --net=host -e PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin" -e HOME="/root" -e LANGUAGE="en_US.UTF-8" -e LANG="en_US.UTF-8" -e TERM="xterm" -e DEBIAN_FRONTEND="noninteractive" -e PLEX_DOWNLOAD="https://downloads.plex.tv/plex-media-server" -e PLEX_INSTALL="https://plex.tv/downloads/latest/1?channel=8&build=linux-ubuntu-x86_64&distro=ubuntu" -e PLEX_MEDIA_SERVER_APPLICATION_SUPPORT_DIR="/config/Library/Application Support" -e PLEX_MEDIA_SERVER_HOME="/usr/lib/plexmediaserver" -e PLEX_MEDIA_SERVER_INFO_DEVICE="docker" -e PLEX_MEDIA_SERVER_MAX_PLUGIN_PROCS="6" -e PLEX_MEDIA_SERVER_USER="abc" -v "/" "linuxserver/plex:latest" 2>&1' with exit code '127': 7e18025ae85f6cded24d15b87705958b5594955e108c9a74853bd7f0c55581fe docker: Error response from daemon: OCI runtime create failed: container_linux.go:348: starting container process caused "open /proc/self/fd: no such file or directory": unknown.
    • okay fixed the above error got it when adding / into the volume path. Still can not use any bit of my media raid on any docker images , plex sonarr. deluge etc.. none of them connect to my raid. anyone any ideas what it could be?

      also cant seem to connect to the host (even tho docker images are set to host)

    • OpenMediaVault Docker-GUI Plugin Usage

      Fixed !! this part

      Source Code

      1. Volumes and bind mounts: If the container needs to access host resources folders, this is the place where you link folders inside the container to folders in the host. For example torrent applications need an outside folder where to place downloads. At the container side you can place a :ro (example /config:ro) to present the mount as read only for the container. To the left side you have your current host machine (OMV), to the right is the path inside the container.