My rsync job missing folders to sync

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • My rsync job missing folders to sync


      1. My RSync job, which is Remote - Pull, doesn't run on scheduled time. I don't know, if this is correct place to be looking in, but /etc/cron.d/ openmediavault-rsync shows no scheduled task.

      2. When I run task manually - from OMV web - RSync -Jobs -Run, There are differences between source and destination data. Some missing (some folders I found manually), some destination folders are actually bigger (don't know why yet).
      I'm thinking creating new Job?... BTW that sync job folder is quite big, but must means nothing to RSync.

      OK, my bad, there is task:
      10 2 * * * root /var/lib/openmediavault/cron.d/rsync-8912afd0-7f47-4f73-b4b1-c7905b25e337

      But still part 2. not solved yet. After some days, certain folders did not synced properly, and I think they should be completely synced by now.

      The post was edited 2 times, last by houndhunger ().

    • Bit more light in my situation, maybe someone will clarify something.
      Various main folders are synced and are about 100GB to 1000GB in size. Source to target folder copy differentiate in 500KB max - more - somehow but OK. Both drive systems are ext4 but different PCs - systems. Source is amd64 and destination is ARM.

      But there is sync-backup or URbackup folder (reading size with du -s *).
      1. Copies are much bigger, forexample on 11GB folder copy is 20GB. And tend to grow on running sync again and again. I managed yesterday to run two sync consecutively with no growth in size. I got ticked on RSync job - "Delete files on receiving side".
      2. I tried to traced folders difference, I found out that some and whole folders are not synced. I think it can do something with ownership?... Folders belong to root users.
      I did before, on setting up URbackup, ACL for urbackup group on URbackup folder, so It can save files in URbackup folder.
      Rsync module is set as root root.
      I use auser to access my files from windows. it is part of users, root and other groups. But it won't let me access these particular un-synced folders. I'm ok to browse them through ssh with root privileges.

      find . -type f | wc -l - I thought it gives me file count, but numbers are the same, even if some whole folders are not synced.
    • 1. Don't understand why, I have removed URbackup-s and did new. Looks much better, Only one folder is slightly bigger.

      2. The missing folders/broken folders are symlinks. Becasue I jave ticked Archive option in my Rsync Job, therefore symlinks are copied. Could be fixed if with symlink located where broken symlinks are looking for and pointing to URbackup folder, in my case. Therefore I have changed URbackup server backup folder from complicated to more simple root directory /URbackup (which is also symlink) but it should make things easier in future.

      Might be worth to allow symlinks on OMV to browse from windows. I red it is not allowed because security issues. I tried to allow it, but no success. But this is different issue
      Case closed, rsync does perfect job, no matter how big data are.