Wakealarm shenanigans

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Wakealarm shenanigans

      Hi, new user here with a fresh install of OMV 4.1.7.

      I have installed the wakealarm-plugin from omv-extras but it does not seem to work. I have scheduled wakealarms and tested them by putting the computer into standby but it does not turn on when it should. I've attached as an example one of the alarms which should have turned on the computer from standby at 11:07 but it didn't.

      Also, I noticed from Syslog that there is a weird wakealarm cron job (/etc/cron.d/wakealarm) spamming the logs:
      * * * * * root test -x /usr/sbin/wakealarm && /usr/sbin/wakealarm > /dev/null 2>&1

      Any ideas what to try next? Should I delete the cron job? Thanks!
      • Capture.PNG

        11.48 kB, 350×369, viewed 153 times
    • I had a similar problem with the wakealarm plug-in.
      Although the test of the rtcwake command by a root-terminal was positive, the scheduled wake-alarms didn’t work. Obviously it was no fault of the wakealarm plug-in, because controlling the rtc setting with cat /proc/driver/rtc showed, the alarm time and date was set according to the specified wake-alarms.

      Scheduled Jobs didn’t work either.
      The command rtcwake -m no -t $(date -d "tomorrow 03:25" +%s) via root-terminal worked fine, but not as a scheduled job.

      My solution was changing the shutdown command in the AutoShutdown Plug-in from "suspend" / "Unterbrechen" / S3 to "hibernate" / "Ruhezustand" / S4. After that 3 of 4 specified wake-alarms (for daily, weekly and monthly backups) worked properly. As yet I had no chance to test the yearly wake-alarm.

      Software Versions:
      autoshutdown plug-in 4.0.4
      wakealarm plug-in 4.0
      omv | 64 bit | omvextrasorg 4.1.7 | kernel
      used plugins: apttool 3.5 | autoshutdown 4.0.4 | wakealarm 4.0 | backup 3.11 |rsnapshot 4.1.3 | minidlna 3.3.11 | nginx 4.0.2