Samba service doesn't work (No process)

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Samba doesn't work

      Hello,

      I recently installed OMV 3 on my server.
      I have enabled Smb but it is not displayed on my network.
      From windows: The server does not appear in the browser or let me access it by executing "\\ IPSERVER"
      From linux: It appears but it gives me a timout error when trying to access.
      From Android: Neither appears nor lets me connect.

      I have configured a shared folder and then I have configured the folder in the shared screen (Attach images).

      Attached status of services smbd and nmbd:

      Source Code

      1. root@ROCAGRAGON:~# systemctl status smbd -l
      2. ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
      3. Loaded: loaded (/etc/init.d/smbd)
      4. Active: active (exited) since mar 2018-06-12 10:29:43 CEST; 6min ago
      5. Process: 2050 ExecReload=/etc/init.d/smbd reload (code=exited, status=0/SUCCES S)
      6. Process: 1460 ExecStart=/etc/init.d/smbd start (code=exited, status=0/SUCCESS)
      7. jun 12 10:29:42 ROCAGRAGON systemd[1]: Starting LSB: start Samba SMB/CIFS daemon (smbd)...
      8. jun 12 10:29:43 ROCAGRAGON smbd[1460]: Starting SMB/CIFS daemon: smbd.
      9. jun 12 10:29:43 ROCAGRAGON systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).
      10. jun 12 10:34:00 ROCAGRAGON systemd[1]: Reloading LSB: start Samba SMB/CIFS daemo n (smbd).
      11. jun 12 10:34:00 ROCAGRAGON smbd[2050]: Reloading /etc/samba/smb.conf: smbd.
      12. jun 12 10:34:00 ROCAGRAGON systemd[1]: Reloaded LSB: start Samba SMB/CIFS daemon (smbd).
      13. root@ROCAGRAGON:~# systemctl status nmbd -l
      14. ● nmbd.service - LSB: start Samba NetBIOS nameserver (nmbd)
      15. Loaded: loaded (/etc/init.d/nmbd)
      16. Active: active (exited) since mar 2018-06-12 10:29:42 CEST; 6min ago
      17. Process: 1223 ExecStart=/etc/init.d/nmbd start (code=exited, status=0/SUCCESS)
      18. jun 12 10:29:42 ROCAGRAGON nmbd[1223]: Starting NetBIOS name server: nmbd.
      19. jun 12 10:29:42 ROCAGRAGON systemd[1]: Started LSB: start Samba NetBIOS nameserv er (nmbd).
      Display All

      Also attached code with my process search, should I get some process?


      Source Code

      1. root@ROCAGRAGON:~# ps -aux | grep smb
      2. root 2959 0.0 0.0 12748 2280 pts/0 S+ 10:46 0:00 grep smb
      3. root@ROCAGRAGON:~# ps -aux | grep smmd
      4. root 2963 0.0 0.0 12748 2248 pts/0 S+ 10:47 0:00 grep smmd
      5. root@ROCAGRAGON:~# ps -aux | grep samba
      6. root 2966 0.0 0.0 12748 2108 pts/0 S+ 10:47 0:00 grep samba
      7. root@ROCAGRAGON:~# ps -aux | grep nmbd
      8. root 2985 0.0 0.0 12748 2292 pts/0 S+ 10:47 0:00 grep nmbd


      The funny thing is that I recently tested on a virtual machine and it worked correctly.

      Thanks!!

      Regards
      Images
      • omv1.png

        36.76 kB, 791×777, viewed 99 times
      • omv2.png

        5.96 kB, 496×143, viewed 98 times

      The post was edited 1 time, last by vicctoor100 ().

    • I need helpo please.

      Error Samba:

      root@openmediavault:~# samba -i
      samba version 4.2.14-Debian started.
      Copyright Andrew Tridgell and the Samba Team 1992-2014
      At this time the 'samba' binary should only be used for either:
      'server role = active directory domain controller' or to access the ntvfs file server with 'server services = +smb' or the rpc proxy with 'dcerpc endpoint servers = remote'
      You should start smbd/nmbd/winbindd instead for domain member and standalone file server tasks
      STATUS=daemon failed to start: Samba detected misconfigured 'server role' and exited. Check logs for details, error code 22