OMV system Standby via UI trigger not working

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV UI Standby not working

      Hello,

      i have done a new installation of OMV on my NAS system (own build, configuration see below) but if i use the Standby function from UI the UI is switching view to xxx.xxx.xxx.xxx\shutdown.php and i see a blue screen with a red button in my browser. But my NAS seems to do nothing and it is still accessable and using the same power. If i enter the direct command "systemctl suspend" my NAS is switching into suspend to ram mode with a power consumention of 3-4 kwh. Some updates ago if i pressed the "Standy" button on the UI, it happend the same as i entered the command. Can anyone help?

      Hardware:
      CPU: Intel Core I3-8300
      Mainboard: ASROCK B360 Pro4
      RAM: Kingston 8 GB ValueRAM Single Rank DDR4-2400 DIMM CL17-17-17 Single
      Data drives: 2x 128GB Intel 600p M.2 2280 PCIe 3.0 x4 (1x System, 1x Docker/VMs)
      3x 10000GB Seagate IronWolf ST10000VN0004 (SnapRaid)
      power: 300 Watt LC-Power LC420-12 Non-Modular 80+ Bronze

      Software:
      OMV: 4.18.2-1
      Linux Kernel: 4.16.0-0.bpo.2-amd64

      Installed Plugins
      - anacron (not in use)
      - apttool (not in use)
      - autoshutdown
      - backup (inactive)
      - clamav (inactive)
      - distkstats
      - docker-gui
      - downloader (not in use)
      - flashmemory
      - letsencrypt
      - luksencryption (not in use)
      - lvm (not in use)
      - minidlna (inactive)
      - omvextrasorg
      - remotedesktop
      - remotemount (inactive)
      - resetperms
      - shellinabox
      - snapraid
      - symlinks
      - teamviewerhost
      - unionfilesystems
      - usbbackup (inactive)
      - virtualbox (inactive)
      - wakealarm (inactive)
      - webdav (inactive)
      - WOL

      Installed Docker containers:
      - Plex media server


      Additional:
      - configured smb shares
      - WOL configured IP + MAC addresses
      - configured notifications
    • OMV uses the pm-hibernate, pm-powersave, pm-suspend-hybrid, pm-is-supported and pm-suspend CLI tools to manage the power management. Maybe they work different than systemctl. The internal scripts use pm-is-supported to check which power mode is supported, so i assume that this does not really work well on your system.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Power management is tricky. Maybe a new kernel has broken something.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Ok, i found the problem. I have installed the Flash memory plugin.
      Install instructions:
      1. Execute the following command: nano /etc/fstab
      2. Add noatime and nodiratime to root options. See before and after example lines:
        BEFORE:UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 errors=remount-ro 0 1AFTER:UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 noatime,nodiratime,errors=remount-ro 0 1
      3. Comment out the swap partition. See before and after example lines (only need to add a # to beginning of the line):
        BEFORE:UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0AFTER:#UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0
        If i just change the line mentioned in point 2, standby is working, but if i also change the line mentioned in point 3 (deactivating the swap partition) standby is not working anymore. Does anyone know this bug or have any idea how i can solve this?
    • m1l0 wrote:

      Ok, i found the problem. I have installed the Flash memory plugin.
      That is why these instructions are optional. Personally, i would not use standby with an SD card since you are going to be doing a lot of writes every time you go into standby.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi!

      Some help and advice would be welcome here!
      I use an odroid HC2 which boots from a sd card.
      What kind of suspend mode is recommanded?

      As per autoshutdown : I am the sole user of OMV. Thus, I have set only my IP to scan.
      However, the log show that autoshutdown still scans other IPs in the network..

      Thanks for your interest!
      Odroid HC2 (NAS with LMS)
    • If you have used the OMV image for HC2 the CPU will be clocked down when it has nothing to do. You can also adjust the firmware to switch off the hard drive after some time (if not already configured like that from factory). So energy consumption is really low and I decided to not use autoshutdown.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • m1l0 wrote:

      Ok, i found the problem. I have installed the Flash memory plugin.
      Install instructions:
      1. Execute the following command: nano /etc/fstab
      2. Add noatime and nodiratime to root options. See before and after example lines:
        BEFORE:UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 errors=remount-ro 0 1AFTER:UUID=ccd327d4-a1ed-4fd2-b356-3b492c6f6c34 / ext4 noatime,nodiratime,errors=remount-ro 0 1
      3. Comment out the swap partition. See before and after example lines (only need to add a # to beginning of the line):
        BEFORE:UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0AFTER:#UUID=a3c989d8-e12b-41d3-b021-098155d6b21b none swap sw 0 0
        If i just change the line mentioned in point 2, standby is working, but if i also change the line mentioned in point 3 (deactivating the swap partition) standby is not working anymore. Does anyone know this bug or have any idea how i can solve this?

      The same problem here. After fresh install, all standby/suspend operations were working just fine.
      At some point, they were not working anymore.
      Of course, autoshutdown was also not working.
      I was even try to play with rtcwake and all modes worked EXCEPT standby (mem, disk, off).

      I disabled /etc/fstab commenting out the swap partition and after reboot, suspend works...

      So, should I just leave swap uncommented? I have a SSD as a system drive and Flash Plugin installed, with noatime and nodiratime and also swapiness=1.
      Is it enough?
    • Disabling swap is optional. On a system with enough ram, it won't use it anyway. But, if you want your system to suspend, you need swap (as you have found). An SSD should be able to handle the writes without the flashmemory plugin but I use it on my systems with SSDs anyway.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I currently have Flash Plugin installed, edited fstab with "noatime" and "nodiratime" and swapiness is set to 1.
      Swap partition at /sda5 is *enabled* currently and I will eventually left it this way - if that's the cost of working suspend.

      Actually, giving that my OS is on 60GB SSD, 7GB is reserved for overprovisioning, system itself occupy ~2GB then I think, I'm still very good in terms of SSD lifetime.