Seagate HDD on Odroid HC2 spins down after 4 minutes regardless of settings

    • OMV 3.x
    • Seagate HDD on Odroid HC2 spins down after 4 minutes regardless of settings

      Setup:
      OMV 3.0.99 (Erasmus)
      Odroid HC2
      Exynos 5422 CPU 4x2.0GHz 4x1.4GHz
      Seagate Barracuda 4TB ST4000DM004

      Hi,
      I recently build a NAS using the config mentioned above, and everything is working like a charm so far, exept the hdd spins down automatically after precisely 4 minutes. If a spindown is requested before that, it spins down just fine, but it appears as if the internal shutdowntimer completely ignores any attempt to change it. The only way I have found to stop it from shutting down so far, is to manually read or write files larger than the internal cache of the drive every 2-3 minutes, wich is obviously not a great solution. This 4 minute shutdown also happens in other systems (Raspberry Pi 3B, Desktop) and every attempt to stop the shutdown has failed there too. I found one potential solution here, but it is for an older version of the drives and a windows based fix.

      Thanks in advance
      Redjard

      (replies in german are fine)
    • The HC2 can spin down the HDD by the firmware

      wiki.odroid.com/odroid-xu4/software/jms578_fw_update

      You can disable it by setting the timer "-t" to 0. Maybe it is set to 4 min on your board.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x | Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems in OMV - OMV setup videos - OMV4 Documentation :!:
    • macom wrote:

      The HC2 can spin down the HDD by the firmware

      wiki.odroid.com/odroid-xu4/software/jms578_fw_update

      You can disable it by setting the timer "-t" to 0. Maybe it is set to 4 min on your board.
      This was indeed the case and after following the procedure the hard drive now continues spinning after 4 minutes, but now I hear a click after exactly 10 minutes and the drive spins down at a random time in the following 2 minutes. I tried different settings for APM AAM and Spindown time and it again seems to have no influence. I also encountered the drive spinning down after anywhere from 10.5 minutes to 12 minutes, so there is no exact timing anymore. While trying to find a solution I encountered this, which could be the click I heard after 10 minutes, but I really don't know.

      The post was edited 1 time, last by Redjard ().

    • macom wrote:

      I would disable APM completely. To be sure run
      hdparm -B255 /dev/sda and check when the drive spins down.
      The command output was:

      redjard-media / # hdparm -B255 /dev/sda

      /dev/sda:
      setting Advanced Power Management level to disabled
      HDIO_DRIVE_CMD failed: Input/output error
      APM_level = not supported


      The drive still behaves exactly the same, so I guess hdparm simply doesn't work on this config?