phpvirtualbox: An unknown PHP error occurred. Error 404.

    • OMV 4.x
    • Resolved
    • Upgrade 3.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • phpvirtualbox: An unknown PHP error occurred. Error 404.

      Hi!

      After upgrade on my second OMV-box, I am unable to browse to the phpVirtualBox GUI. The VM guest-machines can be started, and are running just fine, it seems, but when I try to open the phpVirtualBox GUI, I get an error stating:

      Source Code

      1. An unknown PHP error occurred. This is most likely a syntax error in config.php in phpVirtualBox's folder. The most common errors are an unclosed quote or a missing semicolon in a configuration item that has been entered (e.g. location, username, or password).
      2. Depending on your PHP configuration, navigating directly to config.php in your web browser may display the PHP error message.
      3. If find that this is not the case, or have no idea what this error message means, please raise the issue at http://sourceforge.net/p/phpvirtualbox/discussion/help/
      If I browse to the suggested URL for "config.php", I get "Error 404. Sorry, the page you requested was not found."

      The service is running:

      Source Code

      1. root@x2100:~# ps -ef |grep vbox
      2. vbox 739 1 0 19:51 ? 00:00:00 /usr/lib/virtualbox/vboxwebsrv --host 127.0.0.1 --port 18083
      3. vbox 1129 1 0 19:51 ? 00:00:00 /usr/lib/virtualbox/VBoxXPCOMIPCD
      4. vbox 1268 1 0 19:51 ? 00:00:02 /usr/lib/virtualbox/VBoxSVC --auto-shutdown
      5. vbox 2199 1268 1 19:52 ? 00:00:30 /usr/lib/virtualbox/VBoxHeadless --comment Machine1 --startvm d1835859-aa07-409d-8f8e-4e73dc3992bb --vrde config
      6. vbox 2255 1268 9 19:52 ? 00:02:37 /usr/lib/virtualbox/VBoxHeadless --comment Machine2 --startvm dfd0ad57-d2cd-4c2a-9980-2e22804e4b99 --vrde config
      7. vbox 2297 1268 1 19:52 ? 00:00:23 /usr/lib/virtualbox/VBoxHeadless --comment Machine3 --startvm 1cdf706c-4d7a-4b8a-b031-ff2018fdf185 --vrde config
      8. vbox 2339 1268 1 19:53 ? 00:00:28 /usr/lib/virtualbox/VBoxHeadless --comment Machine4 --startvm f3536833-c6bc-403e-9b32-f91f2aca7481 --vrde config
      9. root 3954 2997 0 20:20 pts/1 00:00:00 grep vbox
      10. root@x2100:~#
      I cannot find any significant differences between this and another OMV-box where it works after upgrade.


      Any ideas?
    • Seeing that the "openmediavault-webgui_error.log" is throwing errors about ""/var/www/openmediavault/virtualbox/index.php" is not found (2: No such file or directory)" and ""/var/www/openmediavault/virtualbox/css/theme-all.min.css" failed (2: No such file or directory)", but then again, I see these errors on the working box, so maybe nothing.

      I also see in messages that that OMV-engined is segfaulting every time I login to the OMV-gui and the phpvirtualbox-GUI (kernel: [ 441.370153] omv-engined[1894]: segfault at 7fba703f9205 ip 0000555aa68c034f sp 00007fff3ce84760 error 4 in php7.0[555aa6653000+3aa000]), but then again, see this on both the working and non-working machine.

      Really cannot find any leads to where to look.
    • Tried to, via the OMV-GUI, remove virtualbox plugin, reboot, then re-install it via same GUI. Had to re-point the plugin to the VM folder, but after this, they showed up, and works. The PHPVirtualBox GUI now also works, go figure!

      The above mentioned errors are however still there, the segfault one seemingly the most serious one. Maybe someone should look into the cause of that one, since my google searches showed other people had also seen this!