FTP file transfer speed slower after Plex plugin added

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • FTP file transfer speed slower after Plex plugin added

      Hello,
      I'm a long time DIY tech hobbyist/enthusiast and first time forum member. I'm certainly a novice with Linux too, so please bear with me. Also please excuse my forum etiquette as I'm sure it will be far from what is expected. And forgive me if this issue is already a topic as part of another thread. I have searched to find a thread with this same issue and haven't found one yet. Please point me in the right direction if someone knows of a post/forum/thread that might help.

      I recently did a fresh install of openmediavault on an ODROID-XU4 with an external HDD connected via USB 3. Both my OMV odroid setup and PC are connected to my gigabit home network via CAT6 ethernet. my initial file transfer from my PC to the HDD on the OMV odroid server over FTP was 100 MB/s. the only thing i can think of that i did between this initial transfer and the slower transfer speeds I am getting now is adding the Plex Media Server plugin. the Plex server is working great but now my data transfer speed to the OMV odroid using FTP is about 30 MB/s using all the same variables as far as I know.

      I have tried to think of anything that I might be doing differently that has caused this performance loss. Surely adding the Plex server plugin wouldn't be the cause of a 70MB/s loss in FTP transfer speeds?! The only thing I can think of is that when I boot, the CPU temp seems a little higher and so I thought perhaps this was causing it to throttle back performance. I also noticed in my FTP client that the files from the original transfer and the files from the most recent transfer seem to have different Owner privileges (but this is starting to get into area outside my novice experience/knowledge). I just thought that this might be because the owner privileges changed after I added the Plex server access to the shared folder (??). At that point I am at a loss for the next step in how to troubleshoot.

      Despite this setback, I am having a lot of fun with openmediavault. Any advice would be greatly appreciated. Thanks!

      - Ben
    • I have had Plex installed for quite a while from OMV 2.* to OMV 4.*, haven't noticed any slowdown for file transfers, though I don't use FTP. Generally rsync.

      I don't really have a clue what could be causing your slowdown but if it were me, I'd try uninstalling Plex first and see if that makes a difference. If you have a lot of Plex metadata play it safe and rename or copy the plexmediaserver directory to ensure it isn't wiped when you reinstall, though I don't think (think! hah-hah!) it will be.

      Good luck!