Updating Plugins and Components Broke dpkg?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Updating Plugins Broke dpkg?

      Hi, I was updating some of my plugins and components yesterday when I saw this:

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. Suggested packages:
      5. cups-common
      6. The following packages will be upgraded:
      7. libcups2
      8. 1 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
      9. 2 not fully installed or removed.
      10. Need to get 0 B/283 kB of archives.
      11. After this operation, 0 B of additional disk space will be used.
      12. Setting up procps (2:3.3.9-9+deb8u1) ...
      13. /var/lib/dpkg/info/procps.postinst: 76: /var/lib/dpkg/info/procps.postinst: update-alternatives: not found
      14. dpkg: error processing package procps (--configure):
      15. subprocess installed post-installation script returned error exit status 127
      16. Errors were encountered while processing:
      17. procps
      18. >>> *************** Error ***************
      19. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-broken --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install libcups2 2>&1' with exit code '100': Reading package lists...
      20. Building dependency tree...
      21. Reading state information...
      22. Suggested packages:
      23. cups-common
      24. The following packages will be upgraded:
      25. libcups2
      26. 1 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
      27. 2 not fully installed or removed.
      28. Need to get 0 B/283 kB of archives.
      29. After this operation, 0 B of additional disk space will be used.
      30. Setting up procps (2:3.3.9-9+deb8u1) ...
      31. /var/lib/dpkg/info/procps.postinst: 76: /var/lib/dpkg/info/procps.postinst: update-alternatives: not found
      32. dpkg: error processing package procps (--configure):
      33. subprocess installed post-installation script returned error exit status 127
      34. Errors were encountered while processing:
      35. procps
      36. E: Sub-process /usr/bin/dpkg returned an error code (1)
      37. <<< *************************************
      Display All

      Right now I cannot update anything else and suspect the OMV installation may have been corrupted

      I have run apt-get clean in commandline and within omv-firstaid but this did not help. What else should I try?

      The post was edited 1 time, last by darkarn ().