openmediavault-sabnzbd Won't Install Due to Unmet Dependencies

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • openmediavault-sabnzbd Won't Install Due to Unmet Dependencies

      Hi,

      I am using OMV on an Odroid-C2 and I tried to install openmediavault-sabnzbd from the interface, but get the following error:

      Source Code

      1. The following have unmet dependencies:
      2. openmediavault-sabnzbd : Depends: python-openssl but it is not going be installed
      3. E: Unable to correct problems, you have held broken packages.

      I managed to install SABnzbd outside of OMV and can get it launched, but am unable to add a SSL connection due to a similar error:

      SSL (pyopenssl (python-ssl) not installed)

      I have tried installing this missing package, but best I can tell it is already installed:

      Source Code

      1. pip show pyOpenSSL
      2. Name: pyOpenSSL
      3. Version: 18.0.0
      4. Summary: Python wrapper module around the OpenSSL library
      Anyone have some suggestion to correct this issue?

      Thanks in Advance

      Version 3.0.99 (Erasmus)
      Processor ODROID-C2
      Kernel Linux 3.14.79-odroidc2
    • Scratchy wrote:

      Anyone have some suggestion to correct this issue?
      Upgrade to OMV 4.x or install a fresh 4.x image and run sabnzbd in a docker (link).
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!