Replaced a disk with Snapraid -> Cannot access the files afterwards?

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Replaced a disk with Snapraid -> Cannot access the files afterwards?

      Hello everyone! I really need some help. ;)

      I replaced a 3TB (data) disk with a 6tb disk using snapraid.

      -mounting the 6tb disk with a new name in omv
      -using the same name in snapraid as before
      -updated snapraid config
      -run snapraid fix

      Took about 9 hrs for ~2,2Tb - everything seems fine. Snapraid status ok. All data was restored and is correctly shown with size & timestamp.

      However I cannot access a single (recovered) file! Depending on the program that shall open the file it varies from "cannot find", "bad file descriptor "no access rights" "used by another program"....

      Any ideas or do I have to change the disks back?
    • Thanks for the fast response! And especially thx for the hint.

      I also thought that this could be somehow permission related. So I created new shares. Unfortunately with the same result.

      --> Digging a little bit deeper I found an omv extension called "resetperms" and this did the trick. After overwriting the permissions for my shares I now have access rights. :)

      Now I just have to figure out how to configure it correct again.
    • New

      The plugin "openmediavault-resetperms 3.3" also helped me a lot with some shared folder permission problems.
      E.g. When I deleted a file or folder and recovered it with snapraid. Snapraids undelete function worked fine, but the problem was that I could not modify the undeleted file.
      With resetperms I can reset the file permissions on the shared folder and after that I can modify every file.