Removing Docker plugin

    • OMV 4.x
    • Removing Docker plugin

      Hey there,
      since my Docker images did not run on the openmediavault-docker-plugin I decided to install it from official repos.
      Therefore I did not touch OMV and just installed it via apt-get an everything worked fine.

      Now I want to remove the openmediavault-docker-plugin but the remove process fails.
      I thought it could be a problem that two instances of docker are running and so I removed my installed one.
      But again, it wont work.

      Can you help please?

      The error after opening the "half-removed" plugin:

      Source Code

      1. Fehler #0:
      2. OMV\Rpc\Exception: RPC service 'Docker' not found. in /usr/share/php/openmediavault/rpc/
      3. Stack trace:
      4. #0 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'getDockerRepo', Array, Array, 1)
      5. #1 {main}
      I also took a look in /etc/openmediavault/config.xml but the plugin is not listed there anymore.

      With best regards

      I also tried subzeros trick with: rm /var/lib/dpkg/info/openmediavault-docker-gui.postrm and then purge the plugin, but it still persists.

      Edit 2:
      I'm just asking because I want to move the /var/lib/docker folder which is not possible, because /var/lib/docker/openmediavault is blocked by engined (I guess).

      The post was edited 1 time, last by LouBen3010 ().

      Post by LouBen3010 ().

      This post was deleted by the author themselves ().
    • A little bump:

      I just want to know, how to remove the plugin from the web interface.
      In some part of OMV there is still a registered extension or whatever which loads the entry at the plugins and thus tries to "bind" /var/lib/docker/openmediavault.

      When I can remove this, then my issue is solved.
    • That can't be true.. I'm searching and searching in the git for the Plugin locations and then is this problem my damn browser cache?
      By the way: I deleted it in Chrome and it still appears. Firefox and Opera indeed are workin' fine.
      I think a re-installation solves my issue completely.

    • LouBen3010 wrote:

      Do you know why /var/lib/docker/openmediavault is still busy?
      I am not able to delete this folder and therefore I think, it's still running.
      Uninstalling the plugin/docker must not kill the running containers? Reboot should help.
      omv arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9 plugins source code and issue tracker -

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!