NFS couldn't get activated on OMV4

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • NFS couldn't get activated on OMV4

      Hi,

      I try to activate the NFS service on my OMV but I get errors:

      Source Code

      1. Fehler #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'nfs-kernel-server' 2>&1' with exit code '1': A dependency job for nfs-server.service failed. See 'journalctl -xe' for details. in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false)
      6. #2 /usr/share/openmediavault/engined/module/nfs.inc(71): OMV\System\SystemCtl->enable(true)
      7. #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleNfs->startService()
      8. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusRU...', '/tmp/bgoutputp9...')
      12. #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      13. #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      14. #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      15. #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      16. #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      17. #13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      18. #14 {main}
      Display All

      Source Code

      1. Jul 12 08:33:24 TVH systemd[1]: Dependency failed for NFS server and services.
      2. -- Subject: Unit nfs-server.service has failed
      3. -- Defined-By: systemd
      4. -- Support: https://www.debian.org/support
      5. --
      6. -- Unit nfs-server.service has failed.
      7. --
      8. -- The result is dependency.
      9. Jul 12 08:33:24 TVH systemd[1]: nfs-server.service: Job nfs-server.service/start failed with result 'dependency'.
      10. Jul 12 08:33:24 TVH systemd[1]: nfs-mountd.service: Job nfs-mountd.service/start failed with result 'dependency'.
      11. Jul 12 08:33:24 TVH systemd[1]: proc-fs-nfsd.mount: Unit entered failed state.
      Display All

      Any Ideas??
    • Hi everyone,

      i'm running here into the same error when starting NFS.
      Exactly the same:


      Source Code

      1. Fehler #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'nfs-kernel-server' 2>&1' with exit code '1': A dependency job for nfs-server.service failed. See 'journalctl -xe' for details. in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false)
      6. #2 /usr/share/openmediavault/engined/module/nfs.inc(71): OMV\System\SystemCtl->enable(true)
      7. #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleNfs->startService()
      8. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatus50...', '/tmp/bgoutputnB...')
      12. #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      13. #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      14. #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      15. #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      16. #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      17. #13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      18. #14 {main}
      Display All

      My configuration: OMV 4.1.7 running on Raspberry Pi 3

      I'm not that linux expert, could anyone help?

      Thanks in advance,
      tronic
    • Perhaps this can give a hint about what is wrong:

      See 'journalctl -xe' for details. in /usr/share/php/openmediavault/system/process.inc:175

      I did some stuff to my NFS-hare, and it stopped working. I fixed it by deleting the share everywhere, reboot and adding the share again. I don't think you have the same problem, but it might help.

      You seem to miss parts of the package nfs-common. Perhaps you could reinstall it?

      Something like:

      sudo apt install --reinstall nfs-common

      (It might cause a small nuclear explosion or totally trash your install. Make sure you have a backup of the system disk and your data...)
      OMV 4.X.XX, 5 * ODROID HC2, 2 * Seagate IronWolf 12TB, 1 * 500 GB 860 EVO, Netgear GS316, ASUS Lyra
    • No, neither a nuclear explosion nor a totally trashed installation happened, just another error message:

      Source Code

      1. root@backup-pi:~# sudo apt install --reinstall nfs-common
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. 0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 22 not upgraded.
      6. Need to get 211 kB of archives.
      7. After this operation, 0 B of additional disk space will be used.
      8. Get:1 http://cdn-fastly.deb.debian.org/debian stretch/main armhf nfs-common armhf 1:1.3.4-2.1 [211 kB]
      9. Fetched 211 kB in 0s (354 kB/s)
      10. (Reading database ... 47372 files and directories currently installed.)
      11. Preparing to unpack .../nfs-common_1%3a1.3.4-2.1_armhf.deb ...
      12. Unpacking nfs-common (1:1.3.4-2.1) over (1:1.3.4-2.1) ...
      13. Setting up nfs-common (1:1.3.4-2.1) ...
      14. Processing triggers for systemd (232-25+deb9u3) ...
      15. Processing triggers for man-db (2.7.6.1-2) ...
      16. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x762cb348>
      17. Traceback (most recent call last):
      18. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      19. TypeError: 'NoneType' object is not callable
      20. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x762cb348>
      21. Traceback (most recent call last):
      22. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      23. TypeError: 'NoneType' object is not callable
      Display All

      I solved the problem with a complete new installation on the SD Card - now NFS is working perfect.

      Thanks Adoby for your hints!

      tronic