RPI dependency issues with latest php7.0 7.0.30-0+deb9u1 (and their dependent packages)

    • OMV 4.x
    • Resolved
    • Update
    • ryecoaaron wrote:

      If the 3.x image has the same pinnings as the 4.x image (don't remember), then the user will have to fix those pinnings
      Different pinnings back then: github.com/ThomasKaiser/OMV_fo…rences.d/99raspberrypiorg -- with these settings users get immediately after an OMV4 upgrade a mixture between Raspbian and Debian packages.
    • Testing the image posted earlier.

      Starting from a fresh install from Etcher:

      - Turn on Docker-CE repo from OMV-Extras
      -- Docker-gui NOT listed in plugins
      - Run update from OMV-Extras menu.
      -- Docker-gui listed in plugins but install fails.
      - Close the dialog box like an idiot without capturing the error message. Run Docker-gui install again to get the error.
      -- Docker-gui installs without errors...

      - Post this message and go to bed.
      -- Work comes early tomorrow morning.
    • tkaiser wrote:

      Thank you for the report. Since it boots everything's ok and it can replace the older variant at SF.
      I'll upload it after fixing the fallout from IBM's wonderful SAN...
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi All,

      I tried both

      Source Code

      1. other alternative by ryecoaaron: apt-get update and then apt-get install openmediavault-omvextrasorg=4.1.9
      2. other alternative by ryecoaaron: wget -O - http://omv-extras.org/install | bash

      And got the below error when installing the Docker plugin

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following additional packages will be installed:
      5. docker-ce imagemagick-6-common libfftw3-double3 liblcms2-2 liblqr-1-0
      6. libmagickcore-6.q16-3 libmagickwand-6.q16-3 libopenjp2-7 omvextras-common
      7. php-curl php-imagick php-symfony-class-loader php-symfony-polyfill-apcu
      8. php7.0-curl
      9. Suggested packages:
      10. libfftw3-bin libfftw3-dev liblcms2-utils libmagickcore-6.q16-3-extra
      11. Recommended packages:
      12. aufs-tools cgroupfs-mount | cgroup-lite pigz ghostscript gsfonts
      13. ttf-dejavu-core
      14. The following NEW packages will be installed:
      15. docker-ce imagemagick-6-common libfftw3-double3 liblcms2-2 liblqr-1-0
      16. libmagickcore-6.q16-3 libmagickwand-6.q16-3 libopenjp2-7 omvextras-common
      17. openmediavault-docker-gui php-curl php-imagick php-symfony-class-loader
      18. php-symfony-polyfill-apcu php7.0-curl
      19. 0 upgraded, 15 newly installed, 0 to remove and 1 not upgraded.
      20. Need to get 0 B/31.4 MB of archives.
      21. After this operation, 146 MB of additional disk space will be used.
      22. Selecting previously unselected package liblqr-1-0:armhf.
      23. (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 51768 files and directories currently installed.)
      24. Preparing to unpack .../00-liblqr-1-0_0.4.2-2+b2_armhf.deb ...
      25. Unpacking liblqr-1-0:armhf (0.4.2-2+b2) ...
      26. Selecting previously unselected package libfftw3-double3:armhf.
      27. Preparing to unpack .../01-libfftw3-double3_3.3.5-3_armhf.deb ...
      28. Unpacking libfftw3-double3:armhf (3.3.5-3) ...
      29. Selecting previously unselected package liblcms2-2:armhf.
      30. Preparing to unpack .../02-liblcms2-2_2.8-4_armhf.deb ...
      31. Unpacking liblcms2-2:armhf (2.8-4) ...
      32. Selecting previously unselected package libopenjp2-7:armhf.
      33. Preparing to unpack .../03-libopenjp2-7_2.1.2-1.1+deb9u2_armhf.deb ...
      34. Unpacking libopenjp2-7:armhf (2.1.2-1.1+deb9u2) ...
      35. Selecting previously unselected package imagemagick-6-common.
      36. Preparing to unpack .../04-imagemagick-6-common_8%3a6.9.7.4+dfsg-11+deb9u5_all.deb ...
      37. Unpacking imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u5) ...
      38. Selecting previously unselected package libmagickcore-6.q16-3:armhf.
      39. Preparing to unpack .../05-libmagickcore-6.q16-3_8%3a6.9.7.4+dfsg-11+deb9u5_armhf.deb ...
      40. Unpacking libmagickcore-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u5) ...
      41. Selecting previously unselected package libmagickwand-6.q16-3:armhf.
      42. Preparing to unpack .../06-libmagickwand-6.q16-3_8%3a6.9.7.4+dfsg-11+deb9u5_armhf.deb ...
      43. Unpacking libmagickwand-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u5) ...
      44. Selecting previously unselected package docker-ce.
      45. Preparing to unpack .../07-docker-ce_18.06.0~ce~3-0~debian_armhf.deb ...
      46. Unpacking docker-ce (18.06.0~ce~3-0~debian) ...
      47. Selecting previously unselected package php-symfony-polyfill-apcu.
      48. Preparing to unpack .../08-php-symfony-polyfill-apcu_1.2.0-1_all.deb ...
      49. Unpacking php-symfony-polyfill-apcu (1.2.0-1) ...
      50. Selecting previously unselected package php-symfony-class-loader.
      51. Preparing to unpack .../09-php-symfony-class-loader_2.8.7+dfsg-1.3+deb9u1_all.deb ...
      52. Unpacking php-symfony-class-loader (2.8.7+dfsg-1.3+deb9u1) ...
      53. Selecting previously unselected package omvextras-common.
      54. Preparing to unpack .../10-omvextras-common_4.0.1_all.deb ...
      55. Unpacking omvextras-common (4.0.1) ...
      56. Selecting previously unselected package php7.0-curl.
      57. Preparing to unpack .../11-php7.0-curl_7.0.30-0+deb9u1_armhf.deb ...
      58. Unpacking php7.0-curl (7.0.30-0+deb9u1) ...
      59. Selecting previously unselected package php-curl.
      60. Preparing to unpack .../12-php-curl_1%3a7.0+49_all.deb ...
      61. Unpacking php-curl (1:7.0+49) ...
      62. Selecting previously unselected package php-imagick.
      63. Preparing to unpack .../13-php-imagick_3.4.3~rc2-2_armhf.deb ...
      64. Unpacking php-imagick (3.4.3~rc2-2) ...
      65. Preparing to unpack .../14-openmediavault-docker-gui_4.0.1_all.deb ...
      66. Unpacking openmediavault-docker-gui (4.0.1) ...
      67. Setting up imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u5) ...
      68. Setting up docker-ce (18.06.0~ce~3-0~debian) ...
      69. Created symlink /etc/systemd/system/multi-user.target.wants/docker.service -> /lib/systemd/system/docker.service.
      70. Created symlink /etc/systemd/system/sockets.target.wants/docker.socket -> /lib/systemd/system/docker.socket.
      71. Job for docker.service failed because the control process exited with error code.
      72. See "systemctl status docker.service" and "journalctl -xe" for details.
      73. invoke-rc.d: initscript docker, action "start" failed.
      74. * docker.service - Docker Application Container Engine
      75. Loaded: loaded (/lib/systemd/system/docker.service; enabled; vendor preset: enabled)
      76. Active: activating (auto-restart) (Result: exit-code) since Tue 2018-08-14 22:17:16 +0530; 31ms ago
      77. Docs: https://docs.docker.com
      78. Process: 11435 ExecStart=/usr/bin/dockerd -H fd:// (code=exited, status=1/FAILURE)
      79. Main PID: 11435 (code=exited, status=1/FAILURE)
      80. Aug 14 22:17:16 ibiplex systemd[1]: Failed to start Docker Application Cont…ine.
      81. Hint: Some lines were ellipsized, use -l to show in full.
      82. dpkg: error processing package docker-ce (--configure):
      83. subprocess installed post-installation script returned error exit status 1
      84. dpkg: dependency problems prevent configuration of openmediavault-docker-gui:
      85. openmediavault-docker-gui depends on docker-ce; however:
      86. Package docker-ce is not configured yet.
      87. dpkg: error processing package openmediavault-docker-gui (--configure):
      88. dependency problems - leaving unconfigured
      89. Setting up libopenjp2-7:armhf (2.1.2-1.1+deb9u2) ...
      90. Setting up liblcms2-2:armhf (2.8-4) ...
      91. Setting up php7.0-curl (7.0.30-0+deb9u1) ...
      92. Creating config file /etc/php/7.0/mods-available/curl.ini with new version
      93. Setting up libfftw3-double3:armhf (3.3.5-3) ...
      94. >>> *************** Error ***************
      95. Bad Gateway
      96. <<< *************************************
      97. Processing triggers for php7.0-fpm (7.0.30-0+deb9u1) ...
      98. Setting up liblqr-1-0:armhf (0.4.2-2+b2) ...
      99. Processing triggers for libc-bin (2.24-11+deb9u3) ...
      100. Setting up php-symfony-polyfill-apcu (1.2.0-1) ...
      101. Processing triggers for systemd (237-3~bpo9+1) ...
      102. Processing triggers for man-db (2.7.6.1-2) ...
      103. Processing triggers for openmediavault (4.1.9) ...
      104. Restarting engine daemon ...
      105. Setting up libmagickcore-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u5) ...
      106. Setting up php-curl (1:7.0+49) ...
      107. Setting up php-symfony-class-loader (2.8.7+dfsg-1.3+deb9u1) ...
      108. Setting up libmagickwand-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u5) ...
      109. Setting up omvextras-common (4.0.1) ...
      110. Setting up php-imagick (3.4.3~rc2-2) ...
      111. Processing triggers for libc-bin (2.24-11+deb9u3) ...
      112. Processing triggers for openmediavault (4.1.9) ...
      113. Updating file permissions ...
      114. Purging internal cache ...
      115. Restarting engine daemon ...
      116. Errors were encountered while processing:
      117. docker-ce
      118. openmediavault-docker-gui
      119. >>> *************** Error ***************
      120. <<< *************************************
      121. >>> *************** Error ***************
      122. <<< *************************************
      123. >>> *************** Error ***************
      124. <<< *************************************
      125. >>> *************** Error ***************
      126. <<< *************************************
      127. >>> *************** Error ***************
      128. <<< *************************************
      129. >>> *************** Error ***************
      Display All

      Tried searching for the error and could not find anything.
      Hope someone could let me know what to do.

      Thanks