Failed to execute command BitTorrent (transmissionbt 4.0)

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Failed to execute command BitTorrent (transmissionbt 4.0)

      Hi folks! I have been searching for like 2 days and cant find any helpfull content on my problem. Pretty new to linux so be nice ;)

      Running this on my Raspberry 3 b+.
      Created a sheared folder
      Installed the transmission plugin
      When i go to the "BitTorrent" menu and want to add a download folder i get this error

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf transmissionbt 2>&1' with exit code '2': /usr/share/openmediavault/mkconf/transmissionbt: 60: local: EXT/Filmer: bad variable name


      Source Code

      1. Fel #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf transmissionbt 2>&1' with exit code '2': /usr/share/openmediavault/mkconf/transmissionbt: 60: local: EXT/Filmer: bad variable name in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/openmediavault/engined/module/transmissionbt.inc(119): OMV\System\Process->execute()
      5. #1 /usr/share/openmediavault/engined/rpc/config.inc(168): OMV\Engined\Module\TransmissionBt->applyConfig()
      6. #2 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      7. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      8. #4 /usr/share/php/openmediavault/rpc/serviceabstract.inc(149): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(565): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusJW...', '/tmp/bgoutput0y...')
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(159): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      11. #7 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      12. #8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      13. #9 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      14. #10 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      15. #11 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      16. #12 {main}
      Display All
      Have a NTFS USB HDD connected so i dont have the "ACL" options... thats right ah? :D

      Hope someone can help me out!
    • You need a ext4 disk. NTFS Is only supported to copy to a ext4 disk.
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • yes. use dockers, and configure it in dockers.

      and please consider to use non NTFS disk on linux (debian) you only have problems.
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • i found solution ! ;]

      i have two servers:
      1. server on OMV3 - with "diskOne" is USB NTFS disk - transmission work excellently
      2. server on OMV4 - with "diskOne" is USB NTFS disk - transmission when set download folder, get error:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf transmissionbt 2>&1' with exit code '2': /usr/share/openmediavault/mkconf/transmissionbt: 60: local: EXT/Filmer: bad variable name
      But, with new disk "diskTwo":
      2. server on OMV4 - with "diskTwo" is USB NTFS disk - transmission set download folder ! - work ! - all work excellently

      what was the problem ? let's check:

      "diskOne":

      Source Code

      1. root@omv-t5550:~# fdisk -l
      2. Disk /dev/sdc: 4,6 TiB, 5000981077504 bytes, 9767541167 sectors
      3. Units: sectors of 1 * 512 = 512 bytes
      4. Sector size (logical/physical): 512 bytes / 4096 bytes
      5. I/O size (minimum/optimal): 4096 bytes / 33553920 bytes
      6. Disklabel type: gpt
      7. Disk identifier: A3DC3A2E-1511-476B-9993-4BFBD1E0D270
      8. Device Start End Sectors Size Type
      9. /dev/sdc1 34 262177 262144 128M Microsoft reserved
      10. /dev/sdc2 264192 9767540735 9767276544 4,6T Microsoft basic data
      11. Partition 1 does not start on physical sector boundary.
      Display All
      "diskTwo":

      Source Code

      1. root@omv-t5550:~# fdisk -l
      2. Disk /dev/sdc: 4,6 TiB, 5000981073920 bytes, 1220942645 sectors
      3. Units: sectors of 1 * 4096 = 4096 bytes
      4. Sector size (logical/physical): 4096 bytes / 4096 bytes
      5. I/O size (minimum/optimal): 4096 bytes / 4096 bytes
      6. Disklabel type: dos
      7. Disk identifier: 0x568b01a5
      8. Device Boot Start End Sectors Size Id Type
      9. /dev/sdc1 * 64 1220940063 1220940000 4,6T 7 HPFS/NTFS/exFAT
      Display All
      and now the question:
      Why transmission with "DiskOne" work only in OMV3 ?

      The post was edited 2 times, last by jaca ().