How to set OMV to boot Clonezilla once via Shell?

    • OMV 3.x
    • How to set OMV to boot Clonezilla once via Shell?

      I have been using Clonezilla for Backups quite frequently (following this guide), whenever there was a bigger change to the system.
      Yesterday I installed a bunch of updates with the result that after a reboot (which I did for another reason) nginx won't start and thus I can't access the GUI. I can access the server via SSH though.
      So I was wondering how to set GRUB to boot to Clonezilla once, just as I do using the GUI usually (see pic1 in the above linked thread). I'd like to use my last backup obviously before trying to fix the errors (which is possibly a lot more time consuming).

      I've been googling a little already but seem to find only references to permanently boot to Clonezilla (and not OMV specific)

      My OMV should be 3.0.99 afaik if that matters at all.

      Thanks for any help in advance!


      ---
      edit
      On a side note: I just realized, OMV 4 has been released as a stable a couple of months ago. Awesome! I'll see when I find time to set that up... (after I have successfully repaired my 3.x)

      The post was edited 1 time, last by KOENICH ().

    • If you install clonezilla from the kernel tab of omv-extras, you can set it to boot once.
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thanks for the reply. :)

      Anyhow, I am very much aware of that option as I used that to create the Clonezilla Backups. But as stated, I do not have access to the GUI of OMV anymore, nginx won't start. Thus I am unable to use that setting - this is why I'm asking specifically how to boot to Clonezilla via shell, that's the only access I have to the system anymore.
    • KOENICH wrote:

      I have been using Clonezilla for Backups quite frequently (following this guide), whenever there was a bigger change to the system.
      Yesterday I installed a bunch of updates with the result that after a reboot (which I did for another reason) nginx won't start and thus I can't access the GUI. I can access the server via SSH though.
      So I was wondering how to set GRUB to boot to Clonezilla once, just as I do using the GUI usually (see pic1 in the above linked thread). I'd like to use my last backup obviously before trying to fix the errors (which is possibly a lot more time consuming).

      I've been googling a little already but seem to find only references to permanently boot to Clonezilla (and not OMV specific)

      My OMV should be 3.0.99 afaik if that matters at all.

      Thanks for any help in advance!


      ---
      edit
      On a side note: I just realized, OMV 4 has been released as a stable a couple of months ago. Awesome! I'll see when I find time to set that up... (after I have successfully repaired my 3.x)
      Could you please post the result of "systemctl status" of the nginx service?
    • Falco wrote:

      Could you please post the result of "systemctl status" of the nginx service?
      Sure, here it is:

      Source Code

      1. ● nginx.service - A high performance web server and a reverse proxy server
      2. Loaded: loaded (/lib/systemd/system/nginx.service; enabled)
      3. Active: failed (Result: exit-code) since Fr 2018-08-17 08:46:35 CEST; 29s ago
      4. Process: 10029 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)
      5. Aug 17 08:46:35 Serverlein systemd[1]: Starting A high performance web server and a reverse proxy server...
      6. Aug 17 08:46:35 Serverlein nginx[10029]: nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/ssl/private/openmediavault-7e8983e2-40c5-4535-a0f7-59bd77b9d4f2.key") failed (SSL: error:0B080074:x509 certificate routin...values mismatch)
      7. Aug 17 08:46:35 Serverlein nginx[10029]: nginx: configuration file /etc/nginx/nginx.conf test failed
      8. Aug 17 08:46:35 Serverlein systemd[1]: nginx.service: control process exited, code=exited status=1
      9. Aug 17 08:46:35 Serverlein systemd[1]: Failed to start A high performance web server and a reverse proxy server.
      10. Aug 17 08:46:35 Serverlein systemd[1]: Unit nginx.service entered failed state.
      11. Hint: Some lines were ellipsized, use -l to show in full.
      Display All
      Looks to me as if there was a certificate problem - in addition to updating OMV I used the Let's Encrypt plugin to renew the certificate. Maybe that is was ultimately failed or led to the problem?!


      ryecoaaron wrote:

      KOENICH wrote:

      how to boot to Clonezilla via shell
      omv-grubiso rebootcz
      Thank ryecoaaron, that sounds like the exact syntax I needed - but unfortunately, omv-grubiso does not sem to exist on my OMV installation. ;(
      Images
      • 2018-08-17_085344.png

        2.65 kB, 468×64, viewed 52 times
    • KOENICH wrote:

      omv-grubiso does not sem to exist on my OMV installation
      I didn't notice you were using OMV 3.x. omv-mkconf omvextras rebootcz
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!