omv-engined segfault error 4 in php7.0

    • OMV 4.x
    • omv-engined segfault error 4 in php7.0

      Hi OMV enthusiasts,

      I upgrade to OMV 4 some weeks ago (fresh installation since I came from OMV 2) and while trying to remove all the nasty little quirks, I'm still struggling with one remaining issue. I noticed the problem when I was looking at the syslog:

      Source Code

      1. kernel: [340459.633054] omv-engined[16216]: segfault at 7faddedfd8c5 ip 00005568810133af sp 00007fff3c080c70 error 4 in php7.0[556880da6000+3aa000]

      I did some searching in the forum and I found various other people having the same message, e.g.
      VirtualBox causing omv-engined[10089]: segfault
      Omv-engined segfault at webui login
      But I didn't find any solution or idea how to track down the problem.

      I performed some tests and I can confirm the observations in the above mentioned forum threads: the issue is definitely connected to the VirtualBox plugin. In addition, I noticed that the syslog entry can be reproduced reliably by the following events:
      • Logging into the OMV Web GUI
      • Clicking on tab "Virtual Machines" in the Services/VirtualBox configuration page
      I tried to use strace to find the root cause of the segfault, but this is the point where I would need some help from more experience hackers. I connected strace to all running php-fpm instances and tried to correlate the output with the occurrence of the syslog message. However, I was not able to clearly identify any problematic kernel calls. So either I connected to the wrong processes or I'm not experienced enough with this kind of analysis (most likely both :rolleyes: ).

      For example, this is the entry in the syslog:

      Source Code

      1. Aug 10 17:43:49 hp-microserver kernel: [331988.455725] omv-engined[28852]: segfault at 7f1f797fd865 ip 0000561f514a33af sp 00007ffcfb84b4a0 error 4 in php7.0[561f51236000+3aa000]

      And this is what the strace output of the php-fpm processes looks like: strace.txt

      At time stamp 17:43:49.178916, I can see that the system reacts on my click on tab "Virtual Machines" in the Services/VirtualBox configuration page. But I'm not able to identify any failing kernel calls in this context.

      I would be very glad if someone with more experience would be able to have a look at this trace. I would be available for performing additional traces if necessary.

      In addition, I was wondering if it would be an option to instrument the respective PHP code to locate the origin of the issue. I would assume that this file is somewhat part of the process:
      /usr/share/openmediavault/engined/rpc/virtualbox.inc

      But I'm neither familiar with the OMV internals (omv-engined) nor PHP scripting. So help in this direction is also very welcome.

      Regards,

      André
    • I only see that error once when logging into the web interface for the first time. Because the plugin's tabs are loaded at that time, it is possible that code does not have access to info that it needs. If something wasn't working, I would be more concerned but I just don't have time to track this down.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Users Online 1

      1 Guest