omv-engined segfault error 4 in php7.0

    • OMV 4.x
    • omv-engined segfault error 4 in php7.0

      Hi OMV enthusiasts,

      I upgrade to OMV 4 some weeks ago (fresh installation since I came from OMV 2) and while trying to remove all the nasty little quirks, I'm still struggling with one remaining issue. I noticed the problem when I was looking at the syslog:

      Source Code

      1. kernel: [340459.633054] omv-engined[16216]: segfault at 7faddedfd8c5 ip 00005568810133af sp 00007fff3c080c70 error 4 in php7.0[556880da6000+3aa000]

      I did some searching in the forum and I found various other people having the same message, e.g.
      VirtualBox causing omv-engined[10089]: segfault
      Omv-engined segfault at webui login
      But I didn't find any solution or idea how to track down the problem.

      I performed some tests and I can confirm the observations in the above mentioned forum threads: the issue is definitely connected to the VirtualBox plugin. In addition, I noticed that the syslog entry can be reproduced reliably by the following events:
      • Logging into the OMV Web GUI
      • Clicking on tab "Virtual Machines" in the Services/VirtualBox configuration page
      I tried to use strace to find the root cause of the segfault, but this is the point where I would need some help from more experience hackers. I connected strace to all running php-fpm instances and tried to correlate the output with the occurrence of the syslog message. However, I was not able to clearly identify any problematic kernel calls. So either I connected to the wrong processes or I'm not experienced enough with this kind of analysis (most likely both :rolleyes: ).

      For example, this is the entry in the syslog:

      Source Code

      1. Aug 10 17:43:49 hp-microserver kernel: [331988.455725] omv-engined[28852]: segfault at 7f1f797fd865 ip 0000561f514a33af sp 00007ffcfb84b4a0 error 4 in php7.0[561f51236000+3aa000]

      And this is what the strace output of the php-fpm processes looks like: strace.txt

      At time stamp 17:43:49.178916, I can see that the system reacts on my click on tab "Virtual Machines" in the Services/VirtualBox configuration page. But I'm not able to identify any failing kernel calls in this context.

      I would be very glad if someone with more experience would be able to have a look at this trace. I would be available for performing additional traces if necessary.

      In addition, I was wondering if it would be an option to instrument the respective PHP code to locate the origin of the issue. I would assume that this file is somewhat part of the process:
      /usr/share/openmediavault/engined/rpc/virtualbox.inc

      But I'm neither familiar with the OMV internals (omv-engined) nor PHP scripting. So help in this direction is also very welcome.

      Regards,

      André
    • I only see that error once when logging into the web interface for the first time. Because the plugin's tabs are loaded at that time, it is possible that code does not have access to info that it needs. If something wasn't working, I would be more concerned but I just don't have time to track this down.
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • i have got same problem

      segfault at 7f9fc582f205 ip 000055d7822ff3af sp 00007ffe6a3120b0 error 4 in php7.0[55d782092000+3aa000]

      after this error

      [11720.161056] perf: interrupt took too long (2518 > 2500), lowering kernel.perf_event_max_sample_rate to 79250
      [17992.531497] perf: interrupt took too long (3157 > 3147), lowering kernel.perf_event_max_sample_rate to 63250
      [26021.303590] perf: interrupt took too long (3951 > 3946), lowering kernel.perf_event_max_sample_rate to 50500
      [50051.330942] perf: interrupt took too long (4940 > 4938), lowering kernel.perf_event_max_sample_rate to 40250
      [161518.448728] perf: interrupt took too long (6200 > 6175), lowering kernel.perf_event_max_sample_rate to 32250
      [267330.224079] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen
      [267330.226232] ata2.00: failed command: FLUSH CACHE EXT
      [267330.228420] ata2.00: cmd ea/00:00:00:00:00/00:00:00:00:00/a0 tag 26
      res 40/00:01:06:4f:c2/00:00:00:00:00/00 Emask 0x4 (timeout)
      [267330.232688] ata2.00: status: { DRDY }
      [267330.234603] ata2: hard resetting link
      [267330.547440] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
      [267330.564774] ata2.00: configured for UDMA/133
      [267330.564782] ata2.00: retrying FLUSH 0xea Emask 0x4
      [267330.564918] ata2: EH complete

      and virtual machines are crashing.


      my mother board supermicro X10SDV-4C-TLN2F
    • Some poking around led me to believe that this is a problem with systemd that is resolved with a later version.

      I don't know where the error was arising, but here's how I got a later version.

      Update (15 hours later). I am still seeing the segfault upon gui login.

      Source Code

      1. dpkg -l systemd
      2. Desired=Unknown/Install/Remove/Purge/Hold
      3. | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
      4. |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
      5. ||/ Name Version Architecture Description
      6. +++-========================-=================-=================-=====================================================
      7. ii systemd 232-25+deb9u6 amd64 system and service manager
      8. # apt policy systemd
      9. systemd:
      10. Installed: 232-25+deb9u6
      11. Candidate: 232-25+deb9u6
      12. Version table:
      13. 239-12~bpo9+1 100
      14. 100 http://httpredir.debian.org/debian stretch-backports/main amd64 Packages
      15. *** 232-25+deb9u6 500
      16. 500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
      17. 100 /var/lib/dpkg/status
      18. # echo deb http://ftp.debian.org/debian stretch-backports main > /etc/apt/sources.list.d/custom.backports.list
      19. # apt-get update
      20. # apt-get -t stretch-backports install systemd
      21. # apt policy systemd systemd:
      22. Installed: 239-12~bpo9+1
      23. Candidate: 239-12~bpo9+1
      24. Version table:
      25. *** 239-12~bpo9+1 100
      26. 100 http://ftp.debian.org/debian stretch-backports/main amd64 Packages
      27. 100 http://httpredir.debian.org/debian stretch-backports/main amd64 Packages
      28. 100 /var/lib/dpkg/status
      29. 232-25+deb9u6 500
      30. 500 http://ftp.us.debian.org/debian stretch/main amd64 Packages
      Display All

      The post was edited 1 time, last by ala.frosty ().

    • Users Online 1

      1 Guest