Unable to install remotedesktop because newer xrdp require

    • OMV 4.x
    • Unable to install remotedesktop because newer xrdp require

      Hello,

      OVM4.1.9
      I wanted to install the plugin remotedesktop but I get :

      The following packages have unmet dependencies:
      openmediavault-remotedesktop : Depends: xrdp (>= 0.9.4) but 0.9.1-9+deb9u3 is to be installed
      E: Unable to correct problems, you have held broken packages.

      How to install xrdp 0.9.4 please ?

      Thanks.
    • You must not have backports enabled. There is a button to enable backports in the Repos tab of omv-extras.
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • peter007 wrote:

      I tried to activate the backports at omv-extras. But that returns an error.
      Installation is still not possible.
      If activating backports returns an error, it makes sense that installation wouldn't work. But, to help, posting the error would really help. My system shows that the package is still available but the pinning is wrong. omv-extras 4.1.10 is in the repo now.

      Source Code

      1. $ sudo apt-cache policy xrdp
      2. xrdp:
      3. Installed: 0.9.6-1~bpo9+1
      4. Candidate: 0.9.6-1~bpo9+1
      5. Version table:
      6. *** 0.9.6-1~bpo9+1 100
      7. 100 http://httpredir.debian.org/debian stretch-backports/main amd64 Packages
      8. 100 /var/lib/dpkg/status
      9. 0.9.1-9+deb9u3 500
      10. 500 http://debian.mirrors.tds.net/debian stretch/main amd64 Packages
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!

      The post was edited 1 time, last by ryecoaaron ().

    • Hello,

      I got it :)

      sudo apt-get -t stretch-backports install xrdp

      For checking :
      sudo apt-cache policy xrdp

      Installed: 0.9.6-1~bpo9+1
      Candidate: 0.9.6-1~bpo9+1
      Version table:
      *** 0.9.6-1~bpo9+1 100
      100 httpredir.debian.org/debian stretch-backports/main armhf Packages
      100 /var/lib/dpkg/status
      0.9.1-9+deb9u3 900
      900 httpredir.debian.org/debian stretch/main armhf Packages


      and then... now, remotedesktop installed :)
      Thanks for help.
    • Hi,

      I have the same problem, when trying to install xrdp

      waca wrote:

      Hello,

      I got it :)

      sudo apt-get -t stretch-backports install xrdp

      For checking :
      sudo apt-cache policy xrdp

      Installed: 0.9.6-1~bpo9+1
      Candidate: 0.9.6-1~bpo9+1
      Version table:
      *** 0.9.6-1~bpo9+1 100
      100 httpredir.debian.org/debian stretch-backports/main armhf Packages
      100 /var/lib/dpkg/status
      0.9.1-9+deb9u3 900
      900 httpredir.debian.org/debian stretch/main armhf Packages


      and then... now, remotedesktop installed :)
      Thanks for help.

      I tried this and gives this message:

      sudo apt-get -t stretch-backports install xrdp
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      xrdp is already the newest version (0.9.1-9+deb9u3).

      For checking:


      sudo apt-cache policy xrdp
      xrdp:
      Installed: 0.9.1-9+deb9u3
      Candidate: 0.9.1-9+deb9u3
      Version table:
      0.9.6-1~bpo9+1 500
      100 httpredir.debian.org/debian stretch-backports/main armhf Packages
      *** 0.9.1-9+deb9u3 900
      900 httpredir.debian.org/debian stretch/main armhf Packages
      100 /var/lib/dpkg/status
    • ryecoaaron wrote:

      What is the output of: cat /etc/apt/preferences.d/omv-extras-org
      cat /etc/apt/preferences.d/omv-extras-org
      Package: virtualbox*
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: zfs*
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: spl
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: spl-dkms
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: libnvpair1linux
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: libzfs2linux
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: libzpool2linux
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: libuutil1linux
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: linux-compiler-gcc-6-x86
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: xrdp
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: certbot python3-acme python3-certbot python3-cffi-backend python3-configargparse python3-configobj
      python3-cryptography python3-future python3-idna python3-josepy python3-mock python3-openssl python3-parsedatetime
      python3-pbr python3-pyasn1 python3-requests python3-rfc3339 python3-urllib3 python3-zope.component
      python3-zope.event python3-zope.hookable python3-zope.interface
      Pin: release a=stretch-backports
      Pin-Priority: 500

      Package: *
      Pin: release n=arrakis, origin dl.bintray.com
      Pin-Priority: 995

      Package: *
      Pin: release n=arrakis-testing, origin dl.bintray.com
      Pin-Priority: 996

      Package: *
      Pin: release n=arrakis-plex, origin dl.bintray.com
      Pin-Priority: 995
    • I just realized this is an arm board and it has the regular repo pinned at 900. I'm guessing it is an RPi? If so, what is the output of: cat /etc/apt/preferences.d/99raspberrypiorg
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      I just realized this is an arm board and it has the regular repo pinned at 900. I'm guessing it is an RPi? If so, what is the output of: cat /etc/apt/preferences.d/99raspberrypiorg
      sorry i didnt say it is raspiberry pi 3 b+ using omv 4.1.10

      cat /etc/apt/preferences.d/99raspberrypiorg
      Package: firmware-brcm80211 libraspberrypi-bin libraspberrypi0 raspberrypi-bootloader raspberrypi-kernel
      Pin: release o=Raspberry Pi Foundation,a=stable,n=stretch, origin archive.raspberrypi.org
      Pin-Priority: 1000

      Package: *
      Pin: release o=Raspberry Pi Foundation,a=stable,n=stretch, origin archive.raspberrypi.org
      Pin-Priority: 10

      Package: *
      Pin: release n=stretch, origin httpredir.debian.org
      Pin-Priority: 900
    • Catorze wrote:

      sorry i didnt say it is raspiberry pi 3 b+ using omv 4.1.10
      I'm not surprised. It is a pain in the ass. I don't have an rpi running but temporarily change the xrdp pinning in /etc/apt/preferences.d/omv-extras-org to Pin-Priority: 996 and then apt-get update
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Catorze wrote:

      sorry i didnt say it is raspiberry pi 3 b+ using omv 4.1.10
      I'm not surprised. It is a pain in the ass. I don't have an rpi running but temporarily change the xrdp pinning in /etc/apt/preferences.d/omv-extras-org to Pin-Priority: 996 and then apt-get update
      Sorry,

      but how I do that? I new on this.


      edit:

      When I try to use this code receive this:

      omv@raspberrypi:~$ /etc/apt/preferences.d/omv-extras-org
      -bash: /etc/apt/preferences.d/omv-extras-org: Permission denied

      The post was edited 1 time, last by Catorze ().

    • sudo nano /etc/apt/preferences.d/omv-extras-org
      edit the line
      ctrl-o to save
      ctrl-x to exit
      sudo apt-get update
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!