disk unmounted alone

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • disk unmounted alone

      I am new to OMV but I succeed in installing and make it work properly.

      then I have installed and mounted a first HDD with no issue.
      after a week, I decided to mount a second HDD and succeed. I have transfered datas on it with no issue.

      a few days later, I discovered an issue with second HDD. my computer could browse the content but when I launch an AVI file, windows told me that the file was missing (on all AVI or MKV of the harddrive).

      so I reboot my OMV machine and then I see in the GUI that the hard drive is not mounted anymore.
      HDD is visible in the disk list but the status is "missing" in the file system.
      If I go on the command line and type "fdisk _l" the hdd is here under /dev/sdc

      it is like the mounted disk dismounted itself and I can't get back.

      please help me, I have done many search but could not find the solution
    • I have experienced similar problems with my HC2s and Seagate IronWolf HDDs.

      I figured out that if I modified any the physical disk properties: (Edit on the Disk).

      Advanced Power Management
      Automatic Acoustic Management
      Spindown Time
      Write Cache

      ...then the HDDs would unmount themselves after a short while, and fail to mount on reboot. And a backup system drive SD-card had to be used to recover. I couldn't figure out how to repair the configuration. But I didn't work on it very long.

      Some research seems to indicate that some Seagate HDDs are incompatible with hdparm, which I assume OMV uses? Instead you are supposed to use SeaChest Power Control tools, made by Seagate. Other HDDs may also be incompatible.

      I have not investigated further, my HDDs work fine on default settings, even if they spin down a little too fast for my taste. Less than a minute when idle. I would prefer 10 minutes or so.

      I might try the SeaChest in the future.

      Try reinstalling and don't touch the edit button on the hdd. It might help?
      OMV 4, 5 x ODROID HC2, 2 x 12TB, 2 x 8 TB, 1 x 500 GB SSD, GbE, WiFi mesh
    • Mr.Grape wrote:

      Hmm this is quite fast, at least for me. My hdd is set to 300 minutes.
      Have you tried setting time(-t 10) in JMS578 firmware? It works in HC1, it may work in HC2..
      No, I haven't. But I might try it. Thanks for that!

      Is this the best description of the process: wiki.odroid.com/odroid-xu4/software/jms578_fw_update
      OMV 4, 5 x ODROID HC2, 2 x 12TB, 2 x 8 TB, 1 x 500 GB SSD, GbE, WiFi mesh
    • I ended up using a backup SD card with a known good config. I couldn't fix it. But then I didn't bother trying very hard, since I had the backup.

      If you don't have a backup SD card, then you may have to reinstall from scratch. When you have done that often enough, like me, you start creating backup SD cards whenever you got something working fine. Before you try something new.

      OMV 4, 5 x ODROID HC2, 2 x 12TB, 2 x 8 TB, 1 x 500 GB SSD, GbE, WiFi mesh
    • Hi

      Well i was in the process of making a SD card backup. I tried to edit a shared folder in settings, put a comment in, saving, and folder content is back again.

      Problem is that next time i reboot the issue with missing disk and unmounted disk will be back.
      I will make a new install without touching "physical disk properties and see if it reboot as it should.

      Best regards
    • FWIW -

      My setup: Odroid HC2 with WD 4TB red plugged right into the HC2. Running OMV 4.1.12 with kernel Linux 4.4.69-odroidxu4. This single-drive HC2 is used as a basic plex server, using the isioarmhf/plex docker.

      I can confirm that in both of my instances, I had attempted changing the physical disk properties in an attempt to stop the disk from spinning down after what seems like just a couple of minutes of no activity. How would a typical user know to not do this? The second time, however, my HC2 ran fine for about a week after I had made those changes, but the problem may not have revealed itself until I rebooted it at that time as a preventive measure.

      I know little about OMV internals and Linux in general. But at least part of what is happening is the "by-label" symbolic link to the named drive is removed from the system when this problem occurs. The /dev/disk/by-label directory where that link would be is even removed from the file system. Unfortunately, I didn't think to see if the references to the disk remain in by-id, by-partuuid, by-path, and by-uuid before I rebuilt the SD card.

      Again, I'm not a Linux guy and I don't know if removal of the by-label directory is *the* problem or just a symptom of a larger issue. I opted not to try manually recreating the directory and link, but that might be something someone could try as a recovery attempt.

      I didn't lose any of the hard disk data in either instance. All I had to do is rebuild the OMV SD card and set up shared folders and SMB shares just as they were before. I did lose plex configuration data that was on the SD card, but my latest rebuild has /config for the plex docker set to space on the hard drive where it probably should have been in the first place . Just a minor detail that none of the plex docker tutorials happen to mention for those running off an SD card...
      OMV 4.1.12 on Odroid HC2 with Plex docker
    • SBC:s can be seen as development tools. That is, tools that are intended for developers and tinkerers rather than normal consumers. So if you decide to use a SBC you must expect having to experiment and search for solutions. Even a ready to use NAS requires some tinkering when adding drives and configuring.

      In this case the problem was that a tool that OMV use, to set HDD-parameters, is incompatible with some HDD:s and/or SATA hardware on the HC2.

      I fixed the very quick default spindown by updating the SATA firmware:


      I set the spindown for my HC2 drives to 30 minutes.

      Regarwding SD-card and Plex (and all other software): Make sure that the data for Plex also is stored on the HDD and not on the SD-card. The flash plugin reduces the amount of writes to the SD-card and makes it last much longer. But if you store the Plex database on the SD-card, then there will be a lot of writes to the SD-cards, reducing the life of the card.
      OMV 4, 5 x ODROID HC2, 2 x 12TB, 2 x 8 TB, 1 x 500 GB SSD, GbE, WiFi mesh