Install of OMV 4.1.3 generates Kernel Panic on post install boot

    • OMV 4.x
    • Upgrade 2.x -> 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Install of OMV 4.1.3 generates Kernel Panic on post install boot

      Had been running OMV 2.2. Win 10 SMB v1 change prompted me to finally upgrade. Install of OMV 4.1.3 from USB uneventful until the first post-installation reboot. Receive:
      Display Spoiler

      [ 0.028000] ..MP-BIOS bug: 8254 timer not connected to IO-APIC
      [ 0.036000] Kernel panic - not syncing: IO-APIC + timer doesn't work! Boot w
      ith apic=debug and send a report. Then try booting with the 'noapic' option.
      [ 0.036000]
      [ 0.036000] CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.14.0-0.bpo.3-amd64 #1
      Debian 4.14.13-1~bpo9+1
      [ 0.036000] Hardware name: System manufacturer System Product Name/A8N-SLI Pr
      emium, BIOS ASUS A8N-SLI Premium ACPI BIOS Revision 1303 08/10/2006
      [ 0.036000] Call Trace:

      ...


      Edited the boot line as instructed with noapic but still no joy.

      Tried installing OMV 3.0.94. That installs and boots fine but, as it is now EOL, can't update it nor do an in-line upgrade, so this isn't a path forward.

      Found a reference to this scenario on the Debian.org site: bugs.debian.org/cgi-bin/bugreport.cgi?bug=883294
      They have the same motherboard and also experience the same symptoms.
      They tried booting with "no_timer_check" as advised and that doesn't work either.

      They recommend installing the 4.16 or later kernel and that was verified by the user.

      So, is there an OMV 4.x build using a 4.16 or later kernel I can use? I'm dead in the water until I can rebuild the system to reaccess my stuff on the data drive.
      :/
      -Ron
    • I've been working my way through that path as prompted by the formal OMV docs. So far, it looks like I should do the following:



      I'll update with where I've gotten to and any further questions. Thanks
    • Working through this on a virtual machine first (Oracle VM VirtualBox)...

      • Booted from Debian 9.5 amd64 ISO and installed the OS
        • Took all the defaults

        • Had to note which disk (sda..sdd) was my boot disk as the grub installer's prompt is not helpful
        • Only installed the system utilities, skipped the printer and desktop
      • Executed the manual install steps from the OMV docs (skipped the comment lines as this was manually typed in) from root

        • export LANG=C
          export DEBIAN_FRONTEND=noninteractive
          export APT_LISTCHANGES_FRONTEND=none
          apt-get update
          apt-get --allow-unauthenticated install openmediavault-keyring
          apt-get update
          apt-get --yes --auto-remove --show-upgraded \
          --allow-downgrades --allow-change-held-packages \
          --no-install-recommends \
          --option Dpkg::Options::="--force-confdef" \
          --option DPkg::Options::="--force-confold" \
          install postfix openmediavault
          omv-initsystem

      • Successfully connected to the OMV web front-end
      • Received an error message on the Update Management and Plugins screens:
        • Error
          The index of upgradeable packages does not exist. Please re-synchronize the package index files from their sources.
          OK Show Details
        • Details are:
        • Error #0:
          OMV\Exception: The index of upgradeable packages does not exist. Please re-synchronize the package index files from their sources. in /usr/share/openmediavault/engined/rpc/apt.inc:114
          Stack trace:
          #0 [internal function]: OMVRpcServiceApt->enumerateUpgraded(Array, Array)
          #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
          #2 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('enumerateUpgrad...', Array, Array)
          #3 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Apt', 'enumerateUpgrad...', Array, Array, 1)
          #4 {main}
      I restarted the virtual machine (reboot) but that did not correct the issue. How does one re-synchronize the package index files from their sources so I can apply updates?
    • OK, searching the OMV forums I see that manually installing omv extras from the command line fixes this error.

      I was then able to install the updates through to 4.17 kernel and everything was working in the VM

      So, I proceeded to do a live build on my problem machine.

      Built and booted from the Debian 9.5 ISO (boots the 4.9 Kernel)
      Keyboard wasn't recognized but a warm boot got me past that.
      Proceeded with same install steps without issue.
      On reboot, the 4.9 Kernel also fails but doesn't trigger a panic:

      Display Spoiler

      Spectre V2 : Spectre mitigation: LFENCE not serializing to generic retpoline
      ..MP-BIOS bug: 8254 timer not connected to IO-APIC

      (then there was a long wait)

      Gave up waiting for root file system device. Common problems:
      - Boot args (cat /proc/cmdline)
      - Check rootdelay= (did the system wait long enough?)
      - Missing modules (cat /proc/modules; ls /dev)
      ALERT! /dev/sdb1 does not exist. Dropping to a shell!

      BusyBox v1.22.1 (Debian 1:1.22.0-19+b3) built-in shell (ash)
      Enter 'help' for a list of built-in commands.
      (initramfs)


      So, I need to figure out how to upgrade from 4.9 to at least 4.16 for the kernel to successfully boot. Any ideas on an alternate built to install or a way to upgrade this one after the install but before rebooting the first time?

      -Ron
    • That is exactly what I used. Debian 9 netinst ISO boots from a generic kernel and installs the 4.9 amd64 kernel. What I’m now looking for is one of these paths forward:
      • Find a Debian 9 netinst ISO that installs a 4.16 or later kernel
      • Find a way to upgrade the kernel at the conclusion of the netinst process prior to reboot
      • Find a utility that I can boot into to do the kernel upgrade after the installation completes
      Any ideas?
    • I landed on the following sequence:
      1. Netinst Debian 8.11 ISO for amd64
      2. At conclusion of install, reboot and log in as root
      3. Do an in-place Debian 8 to 9 upgrade per Debian instructions
      4. At conclusion I have a 3.16 kernel and a newly installed 4.9 kernel
        1. I know that I can’t successfully boot from the 4.9 kernel
      5. Prior to rebooting, I add the stretch backports to sources and install the 4.17 kernel
      6. At conclusion, I reboot and have to add “noacpi” to the 4.17 kernel for it to find the boot drive
      7. Now I install OMV 4 on Debian 9 stretch per the instructions including this command:
      Display Spoiler

      apt-get —yes —auto-remove —show-upgraded \
      —allow-downgrades —allow-change-held-packages \
      —no-install-recommends \
      —option Dpkg::Options::=“—force-confdef” \
      —option Dpkg::Options::=“—force-confold” \
      install postfix openmediavault


      Fails due to —allow-downgrades and —allow-change-held-packages not being recognized. I ran w/out those but expect there are issues. OMV starts up but the net stats portion of the dashboard generates a script failure pop up.
    • After running all the OMV updates, I appear to be in a good place.

      I do get warnings against the stretch backports source and the weak references error.

      I’m looking into whether or not the backports source is still needed as normal maintenance should have taken me to 4.17 (in which case I can comment that out from the sources file - I think).

      I’m also sitting tight awaiting a maintenance fix for the weak references script error.

      So, I’m mostly back in business with SMB and backups working.