Failed to execute - on one file system

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Failed to execute - on one file system

      Hello. Sorry I dont know how to describe the issue. I have two drives set up as raid zero. I have been having issues with this raid, I have four in total the other 3 are fine.

      According to smart the drives are 100% all green.

      Yet if I try and copy data from them, it is crashing out every time, goes for a while then windows says 'interupted action' and the copy has failed.

      Back in the gui of OMV, I can see the raid is there but if I try and go into files systems I get this:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; df -PT '/srv/dev-disk-by-id-md-name-optimusprime-workbackup' 2>&1' with exit code '1': df: '/srv/dev-disk-by-id-md-name-optimusprime-workbackup': Input/output error
      2. Error #0:
      3. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; df -PT '/srv/dev-disk-by-id-md-name-optimusprime-workbackup' 2>&1' with exit code '1': df: '/srv/dev-disk-by-id-md-name-optimusprime-workbackup': Input/output error' in /usr/share/php/openmediavault/system/process.inc:175
      4. Stack trace:
      5. #0 /usr/share/php/openmediavault/system/filesystem/filesystem.inc(620): OMV\System\Process->execute(Array)
      6. #1 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(132): OMV\System\Filesystem\Filesystem->getStatistics()
      7. #2 [internal function]: OMVRpcServiceFileSystemMgmt->enumerateFilesystems(NULL, Array)
      8. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      9. #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(288): OMV\Rpc\ServiceAbstract->callMethod('enumerateFilesy...', NULL, Array)
      10. #5 [internal function]: OMVRpcServiceFileSystemMgmt->getList(Array, Array)
      11. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      12. #7 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getList', Array, Array)
      13. #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('FileSystemMgmt', 'getList', Array, Array, 1)
      14. #9 {main}
      Display All

      If I restart the server then is all back hunkey dory as if nothing had happened.

      I thought it might be physical I have checked the sata and power cables and they appear fine. I will swap out the sata see what that does but could this be the issue?

      Cheers