OMV 4 Wake on LAN lässt sich nicht einschalten.

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV 4 Wake on LAN lässt sich nicht einschalten.

      Guten Tag,

      ich habe OMV immer aktuell, das letzte Update gestern Abend.
      Angefangen habe ich mit OMV 3.0.86.
      Dort hat das Aufwecken per LAN einwandfrei funktioniert.
      Die ganze Zeit war das NAS an einem leicht zugänglichen Ort und es ist mir bis vor ein paar Wochen nicht aufgefallen,
      dass es sich nicht mehr per WOL starten lässt. Ich hatte noch einen alten Stick zum Booten mit dem alten OMV3.0.86.
      Von dort bootet problemlos per WOL.

      Nun unter OMV4 gibt es Probleme.
      Unter OMV und im BIOS ist WOL aktiviert.
      Ich habe mit ethtool bereits versucht herauszufinden wie das ganze konfiguriert ist.

      Die Netzwerkkarte (Intel i210) ist WOL fähig laut Intel. siehe hier

      Mit ethtool bekomme ich angezeigt, dass die Karte die Modi
      pumbg
      unterstützt.
      aktiv ist laut ethtool zur Zeit Modus:
      g

      Nach etlichen Versuchen Wake on Lan hinzubekommen habe ich die Karte mittels ethtool umkonfiguriert, so dass diese auf Modus u oder m steht.

      Leider ist nach dem reboot immer wieder Modus g aktiv.

      Ich habe auch mit Wireshark schon geschaut ob die Pakete am NAS ankommen. Dies funktioniert.

      Also 2 Fragen:

      1. In welcher Datei muss ich einstellen welcher wake up Modus benutzt wird?

      Versucht habe ich in /etc/network/interfaces

      2. Wie bekomme ich es hin, dass Wake on Lan wieder funktioniert?


      Ich hoffe ich habe keine Infos vergessen.
      Besten Dank schon mal.
      OMV 4.1.10 with Flash Plugin, bootet von 128GB Sandisk SSD
      Fujitsu DS3231, Intel i5 - 4570S, 8Gb Ram
      3x8TB WD Red HDD mit SnapRAID und mergerfs
      Aufgebaut in Tecus N8800 Gehäuse mit redundantem Netzteil
    • Hast WOL in der Konfiguration der Netzerkschnittstelle aktiviert (im GUI von OMV)?

      Falls nein, vielleicht hilft es
      /usr/bin/ethtool -s <interface> wol g
      als scheduled job bei reboot auszuführen.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • Guten Morgen,

      also es funktioniert nun.
      Das Board hat Dual GbE und ich hatte es über LAN 2 versucht. Auf LAN 1 funktioniert es nun.
      Laut Intel Spezifikation der Karten können es aber beide und es sind auch beide im Bios enabled.

      Allerdings sind MAC und IP vertauscht.
      Heißt: Schaue ich in OMV mit ifconfig sehe ich ja IP und MAC.
      Schaue ich dann von extern drauf (zB mit einem Wake on LAN Tool) dann sind die beiden IPs
      genau anderherum den MAC Adressen zugeordnet als ich es in OMV in der Console sehe...

      Aber naja... es funktioniert...
      OMV 4.1.10 with Flash Plugin, bootet von 128GB Sandisk SSD
      Fujitsu DS3231, Intel i5 - 4570S, 8Gb Ram
      3x8TB WD Red HDD mit SnapRAID und mergerfs
      Aufgebaut in Tecus N8800 Gehäuse mit redundantem Netzteil
    • Ich habe letzte Woche von OMV 3 auf die 4 upgedatet (Neuinstallation) und seit dem funktioniert mein WOL auch nicht mehr. Ich habe auch nur eine Netzwerkkarte Onboard.

      Source Code

      1. root@Server:~# ethtool enp2s0
      2. Settings for enp2s0:
      3. Supported ports: [ TP MII ]
      4. Supported link modes: 10baseT/Half 10baseT/Full
      5. 100baseT/Half 100baseT/Full
      6. 1000baseT/Half 1000baseT/Full
      7. Supported pause frame use: No
      8. Supports auto-negotiation: Yes
      9. Advertised link modes: 10baseT/Half 10baseT/Full
      10. 100baseT/Half 100baseT/Full
      11. 1000baseT/Half 1000baseT/Full
      12. Advertised pause frame use: Symmetric Receive-only
      13. Advertised auto-negotiation: Yes
      14. Link partner advertised link modes: 10baseT/Half 10baseT/Full
      15. 100baseT/Half 100baseT/Full
      16. 1000baseT/Full
      17. Link partner advertised pause frame use: Symmetric
      18. Link partner advertised auto-negotiation: Yes
      19. Speed: 1000Mb/s
      20. Duplex: Full
      21. Port: MII
      22. PHYAD: 0
      23. Transceiver: internal
      24. Auto-negotiation: on
      25. Supports Wake-on: pumbg
      26. Wake-on: g
      27. Current message level: 0x00000033 (51)
      28. drv probe ifdown ifup
      29. Link detected: yes
      30. root@Server:~#
      Display All


      Source Code

      1. root@Server:~# ifconfig -a
      2. enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
      3. inet 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255
      4. ether 00:24:1d:df:1d:f7 txqueuelen 1000 (Ethernet)
      5. RX packets 111580041 bytes 168078978121 (156.5 GiB)
      6. RX errors 0 dropped 113920 overruns 0 frame 0
      7. TX packets 24393946 bytes 2527272551 (2.3 GiB)
      8. TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
      9. lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
      10. inet 127.0.0.1 netmask 255.0.0.0
      11. inet6 ::1 prefixlen 128 scopeid 0x10<host>
      12. loop txqueuelen 1000 (Lokale Schleife)
      13. RX packets 73873 bytes 8367310 (7.9 MiB)
      14. RX errors 0 dropped 0 overruns 0 frame 0
      15. TX packets 73873 bytes 8367310 (7.9 MiB)
      16. TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
      17. root@Server:~#
      Display All
      Mac Adresse und IP haben sich nicht verändert. Auch über die Fritzbox lässt sich der Server nicht mehr aufwecken.
      Jemand eine Idee?

      Post by Schnuffer ().

      This post was deleted by the author themselves: Doppelpost ().