Upgrading to 4.0 - Disk Compatibility

    • OMV 3.x
    • Upgrade 3.x -> 4.x
    • Upgrading to 4.0 - Disk Compatibility

      Good day all,

      Firstly love the product I've been using 3 for quite a while (and 2 before that!)

      I'm looking to make the jump to 4.0 and would be happy to do a fresh install, my only concern is the data stored on my "storage" disks, will I be able to add the disks and create new shares on them using the existing data - without wiping them all? I have several terrabytes of data and don't really want the time to copy it all back. Currently all my drives are formatted EXT4, and there is no RAID configured.

      Also is there a list somewhere I can check my plug ins against? I'd like to make sure they are all compatible before making the upgrade.

      Thank you.
    • Yonge wrote:

      will I be able to add the disks and create new shares on them using the existing data - without wiping them all?
      Yes. You might have to fix some permissions if the new users you create have a different user ID than your previous installs. The resetperms plugin can help with that.

      Yonge wrote:

      Also is there a list somewhere I can check my plug ins against?
      All of the core OMV 4.x plugins have been ported. You can find a list of omv-extras plugins at omv-extras.org
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!