Difficulty mounting HDD in updated OMV

    • OMV 4.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Difficulty mounting HDD in updated OMV

      Hi everyone, having a bit of a fun time with OMV. Needing some help.

      I updated OMV(bad idea, but I was trying to address an issue unrelated to the HDD) and my ext4 hard drive failed to show up after update. I tried a clean/new install of OMV(4.1.10) and have the same issue.
      I tried a manual mount in CLI, got the following error message:

      Source Code

      1. mount: /dev/sdb1: more filesystems detected. This should not happen,
      2. use -t <type> to explicitly specify the filesystem type or
      3. use wipefs(8) to clean up the device.
      I did some digging. I apparently have a ZFS entry on the ext4 hdd signature, though the drive is formatted as ext4. I can force it to mount as ext4 in CLI and everything "works". However, this doesn't work for OMV. OMV apparently requires all HDDs to be mounted in the web-interface if you want to use them for anything.

      I found some discussion on my HDD issue. However, I haven't been able to find a suitable resolution(FSTYPE discussion). My problem is nearly identical to the issues discussed in that archlinux forum thread.
      Their discussion of using the zpool command seems like it would work, but ZFS doesn't work on 4.1.10 and I am having problems getting ZFS to work on any live linux distribution for my PC. (If someone has a good recommendation for getting ZFS to load up in either OMV 4.1.10 w/ kernel 4.17 or some alternative, I am ALL EARS)
      As I understand it, the only solution seems to be wipe the HDD and start over. That seems a bit extreme for a bad entry.

      I understand that most of you are probably wiser than I could ever be on this issue, so does anyone have any suggestions?
    • May be it is possible to remove the ZFS signature using the --offset option of wipefs


      In any case: be careful. Make sure you have backup of your data.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!: