apt-get install, wants to massacre my OMV installation

    • OMV 4.x
    • apt-get install, wants to massacre my OMV installation

      Hi.

      I have no idea what has happened, but when I wanted to install vsftpd today, apt-get has gone crazy. It wants to massacre and delete my whole system.

      The last "big" change i have done to my system was to install docker-ce. thats about it.

      Please see what apt-get wants to do if i want to install vsftpd.

      Can someone please assist me. I have not been able to figure out how to solve this one.

      Shell-Script

      1. root@odroidxu4:~# apt-get install vsftpd
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. The following packages were automatically installed and are no longer required:
      6. acpid avahi-daemon avahi-utils beep certbot collectd collectd-core cron-apt dbconfig-common dmeventd docker-ce easy-rsa fontconfig gdisk imagemagick-6-common jfsutils jq libavahi-core7 libdatrie1
      7. libdbi1 libdevmapper-event1.02.1 libffi-dev libfftw3-double3 libfile-copy-recursive-perl libfile-slurp-perl libgpgme11 libgraphite2-3 libharfbuzz0b libjavascript-minifier-xs-perl libjq1
      8. libjs-extjs6 libjs-jquery libjs-sphinxdoc libjs-underscore libjson-perl libldb1 liblocale-po-perl liblqr-1-0 libltdl7 liblvm2app2.2 liblvm2cmd2.02 libmagic-mgc libmagic1 libmagickcore-6.q16-3
      9. libmagickwand-6.q16-3 libminiupnpc10 libnatpmp1 libnginx-mod-http-auth-pam libnginx-mod-http-dav-ext libnginx-mod-http-echo libnginx-mod-http-geoip libnginx-mod-http-image-filter
      10. libnginx-mod-http-subs-filter libnginx-mod-http-upstream-fair libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnss-mdns libonig4 libopenjp2-7 libossp-uuid16 libpango-1.0-0
      11. libpangocairo-1.0-0 libpangoft2-1.0-0 libpkcs11-helper1 libpq5 librrd8 libsnmp-base libsnmp30 libtalloc2 libtdb1 libtevent0 libthai-data libthai0 libwbclient0 libxslt1.1 lvm2 mdadm monit
      12. mysql-server mywebsql nfs-kernel-server nginx nginx-common nginx-full openvpn php php-bcmath php-cgi php-cli php-fpm php-imagick php-mbstring php-pam php-sabre-dav php-sabre-vobject
      13. php-symfony-class-loader php-symfony-polyfill-apcu php-xml php7.0 php7.0-bcmath php7.0-cgi php7.0-cli php7.0-fpm php7.0-json php7.0-mbstring php7.0-mysql php7.0-opcache php7.0-pgsql
      14. php7.0-readline php7.0-sqlite3 php7.0-xml pm-utils python-cffi python-cheetah python-crypto python-dnspython python-html5lib python-ldb python-lxml python-ply python-pycparser python-samba
      15. python-software-properties python-talloc python-tdb python-webencodings python3-acme python3-certbot python3-cffi-backend python3-chardet python3-configargparse python3-configobj
      16. python3-cryptography python3-dialog python3-future python3-idna python3-josepy python3-lxml python3-mock python3-natsort python3-netifaces python3-openssl python3-parsedatetime python3-pbr
      17. python3-pkg-resources python3-pyasn1 python3-pyudev python3-requests python3-requests-toolbelt python3-rfc3339 python3-setuptools python3-six python3-tz python3-urllib3 python3-zope.component
      18. python3-zope.event python3-zope.hookable python3-zope.interface quota quotatool rrdcached rrdtool samba samba-common samba-common-bin samba-dsdb-modules samba-libs samba-vfs-modules sdparm
      19. smartmontools tdb-tools transmission-cli transmission-common transmission-daemon update-inetd uuid xfsprogs xmlstarlet
      20. Use 'apt autoremove' to remove them.
      21. The following packages will be REMOVED:
      22. omvextras-common openmediavault openmediavault-couchpotato openmediavault-docker-gui openmediavault-letsencrypt openmediavault-mysql openmediavault-nginx openmediavault-omvextrasorg
      23. openmediavault-plexmediaserver openmediavault-radarr openmediavault-sickbeard openmediavault-symlinks openmediavault-transmissionbt openmediavault-webdav proftpd-basic proftpd-mod-vroot
      24. The following NEW packages will be installed:
      25. vsftpd
      26. 0 upgraded, 1 newly installed, 16 to remove and 0 not upgraded.
      27. Need to get 143 kB of archives.
      28. After this operation, 17.4 MB disk space will be freed.
      29. Do you want to continue? [Y/n]
      Display All
    • Why do you want to install another ftp server? OMV already installs proftpd. Undo the vsftpd Installation to fix your issue.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • I wanted to install vsftpd because I need multiple chroot enviroments. Not sure it can be done with proftpd.

      But to come back to the questions. Is this expected behaviour on apt-get in openmediavault???
      Why does this package want to remove openmediavault, and all the other packages?
    • mcmanuf wrote:

      I wanted to install vsftpd because I need multiple chroot enviroments. Not sure it can be done with proftpd.
      use docker. there is a plugin.

      mcmanuf wrote:

      But to come back to the questions. Is this expected behaviour on apt-get in openmediavault???
      Why does this package want to remove openmediavault, and all the other packages?
      Yes, you are trying to install a package that conflicts with a dependency of OMV. You are telling it to install the new package and if you answer yes that you want to install it, it will remove the conflicting packages. Because OMV depends on proftpd, it will remove the OMV package as well.
      omv 4.1.12 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • mcmanuf wrote:

      I wanted to install vsftpd because I need multiple chroot enviroments. Not sure it can be done with proftpd.
      OMV uses proftpd-vroot to separate each user.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Users Online 1

      1 Guest