crash omv-mkconf and omv-update

    • OMV 4.x
    • crash omv-mkconf and omv-update

      Hi,

      I have got a problem with omv-mkconf and omv-update.
      When I try to update this occurs:

      Source Code

      1. [root@NAS: ~] omv-update
      2. Ign:1 http://ftp.de.debian.org/debian stretch InRelease
      3. Hit:3 http://packages.openmediavault.org/public arrakis InRelease
      4. Hit:4 http://security.debian.org/debian-security stretch/updates InRelease
      5. Get:5 http://ftp.de.debian.org/debian stretch-updates InRelease [91.0 kB]
      6. Hit:6 http://ftp.de.debian.org/debian stretch Release
      7. Hit:7 https://openmediavault.github.io/packages arrakis InRelease
      8. Ign:8 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stretch InRelease
      9. Get:2 http://cdn-fastly.deb.debian.org/debian stretch-backports InRelease [91.8 kB]
      10. Hit:9 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stretch Release
      11. Fetched 183 kB in 0s (212 kB/s)
      12. Traceback (most recent call last):
      13. File "/usr/sbin/omv-mkaptidx", line 35, in <module>
      14. import apt
      15. File "/usr/lib/python3/dist-packages/apt/__init__.py", line 26, in <module>
      16. from apt.package import Package
      17. File "/usr/lib/python3/dist-packages/apt/package.py", line 28, in <module>
      18. import socket
      19. File "/usr/lib/python3.5/socket.py", line 53, in <module>
      20. from enum import IntEnum
      21. File "/usr/lib/python3.5/enum.py", line 3, in <module>
      22. from types import MappingProxyType, DynamicClassAttribute
      23. File "/usr/lib/python3.5/types.py", line 166, in <module>
      24. import functools as _functools
      25. File "/usr/lib/python3.5/functools.py", line 23, in <module>
      26. from weakref import WeakKeyDictionary
      27. File "/usr/lib/python3.5/weakref.py", line 109
      28. def remove(wr, selfref=ref(self)
      29. ^
      30. TabError: inconsistent use of tabs and spaces in indentation
      31. Reading package lists... Done
      32. Reading package lists... Done
      33. Building dependency tree
      34. Reading state information... Done
      35. Calculating upgrade... Done
      36. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      37. 2 not fully installed or removed.
      38. Need to get 0 B/192 kB of archives.
      39. After this operation, 0 B of additional disk space will be used.
      40. dpkg: error processing package python3 (--configure):
      41. package is in a very bad inconsistent state; you should
      42. reinstall it before attempting configuration
      43. dpkg: dependency problems prevent configuration of python3-apt:
      44. python3-apt depends on python3 (<< 3.6); however:
      45. Package python3 is not configured yet.
      46. python3-apt depends on python3 (>= 3.5~); however:
      47. Package python3 is not configured yet.
      48. python3-apt depends on python3:any (>= 3.3.2-2~); however:
      49. Package python3 is not configured yet.
      50. dpkg: error processing package python3-apt (--configure):
      51. dependency problems - leaving unconfigured
      52. Errors were encountered while processing:
      53. python3
      54. python3-apt
      55. Traceback (most recent call last):
      56. File "/usr/sbin/omv-mkaptidx", line 35, in <module>
      57. import apt
      58. File "/usr/lib/python3/dist-packages/apt/__init__.py", line 26, in <module>
      59. from apt.package import Package
      60. File "/usr/lib/python3/dist-packages/apt/package.py", line 28, in <module>
      61. import socket
      62. File "/usr/lib/python3.5/socket.py", line 53, in <module>
      63. from enum import IntEnum
      64. File "/usr/lib/python3.5/enum.py", line 3, in <module>
      65. from types import MappingProxyType, DynamicClassAttribute
      66. File "/usr/lib/python3.5/types.py", line 166, in <module>
      67. import functools as _functools
      68. File "/usr/lib/python3.5/functools.py", line 23, in <module>
      69. from weakref import WeakKeyDictionary
      70. File "/usr/lib/python3.5/weakref.py", line 109
      71. def remove(wr, selfref=ref(self)
      72. ^
      73. TabError: inconsistent use of tabs and spaces in indentation
      74. E: Sub-process /usr/bin/dpkg returned an error code (1)
      Display All


      I have got the Version: 4.1.11
      Is there somebody who can help?


      Editing via the gui is not working anymore. Nothing works.
      I do not want to reinstall.


      cu
    • You’ve tried to fix the Python error issue yourself. Really, this was no good idea because it seems you did not have known what you have done. Undo all your changes to get it working again. And for the future, don’t touch everything you don’t know about.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • foresthus wrote:

      And your anwser to the sutuation is not very helpful.
      In Volker's defense, the errors you are getting are very unusual for a system that has not been tampered with.

      What is the output of the following:
      dpkg -l | grep -v ^ii
      dpkg -l | grep openm

      Also, why were you using omv-update? Was something not working in the web interface?
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi,

      thnx 4 the hint. Here is the answer:

      Source Code

      1. [root@NAS: ~] dpkg -l | grep -v ^ii
      2. Desired=Unknown/Install/Remove/Purge/Hold
      3. | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
      4. |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
      5. ||/ Name Version Architecture Description
      6. +++-===================================-==============================-============-=====================================================================================
      7. rc linux-image-4.14.0-0.bpo.3-amd64 4.14.13-1~bpo9+1 amd64 Linux 4.14 for 64-bit PCs
      8. rc linux-image-4.16.0-0.bpo.1-amd64 4.16.5-1~bpo9+1 amd64 Linux 4.16 for 64-bit PCs
      9. ri python2.7 2.7.13-2+deb9u2 amd64 Interactive high-level object-oriented language (version 2.7)
      10. rFR python3 3.5.3-1 amd64 interactive high-level object-oriented language (default python3 version)
      11. iFR python3-apt 1.4.0~beta3 amd64 Python 3 interface to libapt-pkg
      12. iF python3.5 3.5.3-1 amd64 Interactive high-level object-oriented language (version 3.5)
      13. [root@NAS: ~] dpkg -l | grep openm
      14. ii libopenmpt0:amd64 0.2.7386~beta20.3-3+deb9u2 amd64 module music library based on OpenMPT -- shared library
      15. ii openmediavault 4.1.11 all openmediavault - The open network attached storage solution
      16. ii openmediavault-anacron 3.0 all anacron plugin for OpenMediaVault.
      17. ii openmediavault-apttool 3.5 all apt tool plugin for OpenMediaVault.
      18. ii openmediavault-backup 4.0.3 all backup plugin for OpenMediaVault.
      19. ii openmediavault-clamav 4.1.7-1 all OpenMediaVault ClamAV plugin
      20. ii openmediavault-cups 3.1.2 all OpenMediaVault CUPS (network printer server) plugin.
      21. ii openmediavault-diskstats 4.0.2-1 all OpenMediaVault disk monitoring plugin
      22. ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      23. ii openmediavault-locate 3.4 all locate plugin for OpenMediaVault.
      24. ii openmediavault-minidlna 3.3.11 all OpenMediaVault miniDLNA (DLNA server) plugin
      25. ii openmediavault-netatalk 4.0.7-1 all OpenMediaVault netatalk (AppleTalk Protocol Suite) plugin
      26. ii openmediavault-omvextrasorg 4.1.11 all OMV-Extras.org Package Repositories for OpenMediaVault
      27. ii openmediavault-resetperms 3.3 all Reset Permissions
      28. ii openmediavault-route 4.0.4-1 all OpenMediaVault IP routing table plugin
      29. ii openmediavault-snmp 4.0.4-1 all OpenMediaVault SNMP (Simple Network Management Protocol) plugin
      30. ii openmediavault-symlinks 3.1.4 all OpenMediaVault symlinks plugin
      31. ii openmediavault-usbbackup 4.0.7-1 all OpenMediaVault USB/eSATA backup plugin
      Display All
    • Answering all of my questions will only help you.

      What is the output of: apt-get -f install
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • foresthus wrote:

      By the way, trying to edit anything using the gui, these tries are failing aswell.
      That is because python is in a bad state. No need to use the gui until the packages are fixed.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • here is the output:

      Source Code

      1. [root@NAS: ~] apt-get -f install
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. The following packages were automatically installed and are no longer required:
      6. acl acpid anacron apt-transport-https arp-scan arping avahi-daemon avahi-discover avahi-utils bc beep bind9-host bsd-mailx btrfs-progs ca-certificates clamav-base clamav-daemon
      7. clamav-freshclam clamdscan collectd collectd-core colordiff cpufrequtils cron cron-apt cups cups-client cups-common cups-core-drivers cups-daemon cups-filters
      8. cups-filters-core-drivers cups-pdf cups-ppdc cups-server-common dc ddclient debsums dh-python distro-info-data dmeventd dmidecode docutils-common e2fslibs ethtool figlet
      9. firmware-atheros firmware-bnx2 firmware-bnx2x firmware-brcm80211 firmware-cavium firmware-intel-sound firmware-intelwimax firmware-ipw2x00 firmware-ivtv firmware-iwlwifi
      10. firmware-libertas firmware-myricom firmware-netxen firmware-qlogic firmware-realtek firmware-samsung firmware-siano firmware-ti-connectivity fontconfig fontconfig-config
      11. fonts-dejavu-core foomatic-db foomatic-db-engine fping fsarchiver gdisk ghostscript gnome-icon-theme gtk-update-icon-cache hdmi2usb-fx2-firmware hdparm hicolor-icon-theme hp-ppd
      12. hpijs-ppds htop hwinfo ieee-data ifenslave ifupdown imagemagick imagemagick-6-common imagemagick-6.q16 iproute iproute2 iptables iputils-ping isc-dhcp-client isc-dhcp-common
      13. ixo-usb-jtag jfsutils jq libaio1 libatalk17 libatk1.0-0 libatk1.0-data libavahi-client3 libavahi-common-data libavahi-common3 libavahi-core7 libavcodec57 libavformat57 libavutil55
      14. libbind9-140 libblas-common libblas3 libbluray1 libbz2-dev libcairo2 libcap2-bin libchromaprint1 libclamav7 libcpufreq0 libcrack2 libcroco3 libcrystalhd3 libcups2 libcupscgi1
      15. libcupsfilters1 libcupsimage2 libcupsmime1 libcupsppdc1 libcurl3 libcurl3-gnutls libdaemon0 libdatrie1 libdbi1 libdbus-glib-1-2 libdevmapper-event1.02.1 libdns-export162 libdns162
      16. libdrm2 libedit2 libestr0 libexif12 libexpat1-dev libfastjson4 libfftw3-double3 libfile-copy-recursive-perl libfile-fnmatch-perl libfile-slurp-perl libflac8 libfontconfig1
      17. libfontconfig1-dev libfontembed1 libfreetype6-dev libgd3 libgdbm-dev libgdk-pixbuf2.0-0 libgdk-pixbuf2.0-common libgeoip1 libgfortran3 libglade2-0 libglib2.0-0 libgme0 libgraphite2-3
      18. libgs9 libgs9-common libgsm1 libgtk2.0-0 libgtk2.0-common libgutenprint2 libharfbuzz0b libhd21 libhpmud0 libice-dev libice6 libicu57 libid3tag0 libidn2-0 libijs-0.35 libip6tc0
      19. libiptc0 libisc-export160 libisc160 libisccc140 libisccfg140 libjavascript-minifier-xs-perl libjbig0 libjbig2dec0 libjpeg62-turbo libjq1 libjs-extjs6 libjs-jquery libjs-sphinxdoc
      20. libjs-underscore libjson-c3 libjson-perl liblapack3 liblcms2-2 liblcms2-utils libldb1 liblinear3 libllvm3.8 liblocale-po-perl liblockfile-bin liblockfile1 liblogging-stdlog0
      21. liblognorm5 liblqr-1-0 libltdl7 liblua5.3-0 liblvm2app2.2 liblvm2cmd2.02 liblwres141 liblzo2-2 libmagic-mgc libmagic1 libmagickcore-6.q16-3 libmagickwand-6.q16-3 libmemcached11
      22. libmemcachedutil2 libmnl0 libmp3lame0 libmpdec2 libmpg123-0 libmspack0 libncursesw5-dev libnet1 libnetfilter-conntrack3 libnfnetlink0 libnghttp2-14 libnginx-mod-http-auth-pam
      23. libnginx-mod-http-dav-ext libnginx-mod-http-echo libnginx-mod-http-geoip libnginx-mod-http-image-filter libnginx-mod-http-subs-filter libnginx-mod-http-upstream-fair
      24. libnginx-mod-http-xslt-filter libnginx-mod-mail libnginx-mod-stream libnl-3-200 libnl-genl-3-200 libnspr4 libnss-mdns libnss3 libntfs-3g871 libnuma1 libogg0 libonig4 libopenjp2-7
      25. libopenmpt0 libopts25 libopus0 libossp-uuid16 libpango-1.0-0 libpangocairo-1.0-0 libpangoft2-1.0-0 libpaper-utils libpaper1 libpcap0.8 libpci3 libpcsclite1 libpipeline1 libpixman-1-0
      26. libpng-dev libpoppler64 libpsl5 libpthread-stubs0-dev libpython2.7 libpython3-stdlib libpython3.5-minimal libpython3.5-stdlib libqpdf17 libreadline-gplv2-dev libreadline5 librrd8
      27. librsvg2-2 librsvg2-common librtmp1 libsensors4 libshine3 libsm-dev libsm6 libsnappy1v5 libsnmp-base libsnmp30 libsoxr0 libspeex1 libsqlite3-dev libssh-gcrypt-4 libssh2-1 libssl-dev
      28. libssl1.0.2 libswresample2 libtalloc2 libtcl8.6 libtdb1 libtevent0 libtfm1 libthai-data libthai0 libtheora0 libtiff5 libtinfo-dev libtk8.6 libtwolame0 libunistring0 libusb-1.0-0
      29. libva-drm1 libva-x11-1 libva1 libvdpau1 libvorbis0a libvorbisenc2 libvorbisfile3 libvpx4 libwavpack1 libwbclient0 libwebp6 libwebpmux2 libx11-6 libx11-data libx11-dev libx264-148
      30. libx265-95 libx86emu1 libxau-dev libxau6 libxcb-render0 libxcb-shm0 libxcb1 libxcb1-dev libxcomposite1 libxcursor1 libxdamage1 libxdmcp-dev libxdmcp6 libxext-dev libxext6 libxfixes3
      31. libxft-dev libxft2 libxi6 libxinerama1 libxml2 libxpm4 libxrandr2 libxrender-dev libxrender1 libxslt1.1 libxss-dev libxss1 libxt-dev libxt6 libxtables12 libxvidcore4 libzvbi-common
      32. libzvbi0 linux-image-amd64 lm-sensors logrotate lsb-release lsof lvm2 mc mc-data mdadm minidlna monit nano netatalk nfs-kernel-server nginx nginx-common nginx-full nmap nmon ntfs-3g
      33. ntp omvextras-common openmediavault openmediavault-anacron openmediavault-apttool openmediavault-backup openmediavault-clamav openmediavault-cups openmediavault-diskstats
      34. openmediavault-keyring openmediavault-locate openmediavault-minidlna openmediavault-netatalk openmediavault-omvextrasorg openmediavault-resetperms openmediavault-route
      35. openmediavault-snmp openmediavault-symlinks openmediavault-usbbackup openprinting-ppds openssh-client openssh-server openssh-sftp-server openssl pciutils php-bcmath php-cgi
      36. php-common php-fpm php-http php-mbstring php-pam php-pecl-http php-propro php-raphf php-symfony-class-loader php-symfony-polyfill-apcu php-xml php7.0-bcmath php7.0-cgi php7.0-cli
      37. php7.0-common php7.0-fpm php7.0-json php7.0-mbstring php7.0-opcache php7.0-readline php7.0-xml pkg-config pm-utils poppler-data poppler-utils postfix postfix-sqlite
      38. printer-driver-cups-pdf printer-driver-foo2zjs printer-driver-foo2zjs-common printer-driver-gutenprint printer-driver-hpcups printer-driver-hpijs printer-driver-splix proftpd-basic
      39. proftpd-mod-vroot python-apt-common python-avahi python-cairo python-crypto python-cups python-daemon python-dbus python-dnspython python-docutils python-gdbm python-glade2
      40. python-gobject-2 python-gtk2 python-ldb python-lockfile python-lxml python-numpy python-pkg-resources python-roman python-samba python-talloc python-tdb python3 python3-apt
      41. python3-dbus python3-dialog python3-lxml python3-minimal python3-natsort python3-netifaces python3-pyudev python3-six python3.5 python3.5-minimal quota quotatool resolvconf rrdcached
      42. rrdtool rsync rsyslog samba samba-common samba-common-bin samba-libs samba-vfs-modules screen sdparm sgml-base shared-mime-info smartmontools snmpd socat ssl-cert sudo tcl tcl-dev
      43. tcl8.6 tcl8.6-dev tdb-tools tk tk-dev tk8.6 tk8.6-dev tree update-inetd usbutils uuid vim vim-common vim-runtime vim-tiny wget wpasupplicant x11-common x11proto-core-dev
      44. x11proto-input-dev x11proto-kb-dev x11proto-render-dev x11proto-scrnsaver-dev x11proto-xext-dev xfsprogs xml-core xmlstarlet xorg-sgml-doctools xtrans-dev xxd zabbix-agent zlib1g-dev
      45. Use 'apt autoremove' to remove them.
      46. ...
      Display All
    • ...
      Use 'apt autoremove' to remove them.
      0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      3 not fully installed or removed.
      Need to get 192 kB of archives.
      After this operation, 0 B of additional disk space will be used.
      Get:1 ftp.de.debian.org/debian stretch/main amd64 python3 amd64 3.5.3-1 [21,6 kB]
      Get:2 ftp.de.debian.org/debian stretch/main amd64 python3-apt amd64 1.4.0~beta3 [170 kB]
      Fetched 192 kB in 0s (5.223 kB/s)
      Setting up python3.5 (3.5.3-1) ...
      Traceback (most recent call last):
      File "/usr/lib/python3.5/py_compile.py", line 6, in <module>
      import importlib._bootstrap_external
      File "/usr/lib/python3.5/importlib/__init__.py", line 57, in <module>
      import types
      File "/usr/lib/python3.5/types.py", line 166, in <module>
      import functools as _functools
      File "/usr/lib/python3.5/functools.py", line 23, in <module>
      from weakref import WeakKeyDictionary
      File "/usr/lib/python3.5/weakref.py", line 109
      def remove(wr, selfref=ref(self)
      ^
      TabError: inconsistent use of tabs and spaces in indentation
      dpkg: error processing package python3.5 (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of python3:
      python3 depends on python3.5 (>= 3.5.3-1~); however:
      Package python3.5 is not configured yet.


      dpkg: error processing package python3 (--configure):
      dependency problems - leaving unconfigured
      dpkg: dependency problems prevent configuration of python3-apt:
      python3-apt depends on python3 (<< 3.6); however:
      Package python3 is not configured yet.
      python3-apt depends on python3 (>= 3.5~); however:
      Package python3 is not configured yet.
      python3-apt depends on python3:any (>= 3.3.2-2~); however:
      Package python3 is not configured yet.


      dpkg: error processing package python3-apt (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      python3.5
      python3
      python3-apt
      Traceback (most recent call last):
      File "/usr/sbin/omv-mkaptidx", line 35, in <module>
      import apt
      File "/usr/lib/python3/dist-packages/apt/__init__.py", line 26, in <module>
      from apt.package import Package
      File "/usr/lib/python3/dist-packages/apt/package.py", line 28, in <module>
      import socket
      File "/usr/lib/python3.5/socket.py", line 53, in <module>
      from enum import IntEnum
      File "/usr/lib/python3.5/enum.py", line 3, in <module>
      from types import MappingProxyType, DynamicClassAttribute
      File "/usr/lib/python3.5/types.py", line 166, in <module>
      import functools as _functools
      File "/usr/lib/python3.5/functools.py", line 23, in <module>
      from weakref import WeakKeyDictionary
      File "/usr/lib/python3.5/weakref.py", line 109
      def remove(wr, selfref=ref(self)
      ^
      TabError: inconsistent use of tabs and spaces in indentation
      E: Sub-process /usr/bin/dpkg returned an error code (1)
    • I hope you didn't say yes to removing all of those packages.

      I would try:

      apt-get install --reinstall python3.5 python3 python3-apt
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • foresthus wrote:

      File "/usr/lib/python3.5/weakref.py", line 109
      def remove(wr, selfref=ref(self)
      ^
      TabError: inconsistent use of tabs and spaces in indentation
      This error message clearly tells everyone that the file /usr/lib/python3.5/weakref.py is modified manually by someone who does not know that Python does not like incorrect indention. You'll find many posts in this forum about how to fix the Python weakref issue, because of this you simply have to count 1 and 1 together to get to my assumption. The Debian Python package would never be shipped with such an error.
      I am annoyed by such posts because the problems are self-inflicted and cost us only time.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Hi there,

      after the try mentioned by ryecoaaron, I had to install my nas again. Nothing was working after that. It was not that much work to do.

      After the new installation I had following things after startuíng omv-aptclean:


      Source Code

      1. ...
      2. Fetched 21.4 MB in 8s (2620 kB/s)
      3. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f6fbf3e6950>
      4. Traceback (most recent call last):
      5. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      6. TypeError: 'NoneType' object is not callable
      7. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7f6fbf3e6950>
      8. Traceback (most recent call last):
      9. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      10. TypeError: 'NoneType' object is not callable
      11. Reading package lists... Done
      12. 8. Saving current package list...
      Display All
      Therefor there is still someting not ok with python3.5.

      Next ideas?



      8. Saving current package list...
    • foresthus wrote:

      after the try mentioned by ryecoaaron, I had to install my nas again. Nothing was working after that. It was not that much work to do.
      The command I gave you should not have done anything wrong. Your system was borked already.

      foresthus wrote:

      Therefor there is still someting not ok with python3.5.
      As posted many times on this forum, this is a bug in the python package but it doesn't affect anything other than that message. The following will fix it:

      wget -O /usr/lib/python3.5/weakref.py https://raw.githubusercontent.com/python/cpython/9cd7e17640a49635d1c1f8c2989578a8fc2c1de6/Lib/weakref.py
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      foresthus wrote:

      after the try mentioned by ryecoaaron, I had to install my nas again. Nothing was working after that. It was not that much work to do.
      The command I gave you should not have done anything wrong. Your system was borked already.

      foresthus wrote:

      Therefor there is still someting not ok with python3.5.
      As posted many times on this forum, this is a bug in the python package but it doesn't affect anything other than that message. The following will fix it:
      wget -O /usr/lib/python3.5/weakref.py https://raw.githubusercontent.com/python/cpython/9cd7e17640a49635d1c1f8c2989578a8fc2c1de6/Lib/weakref.py
      To your first answer:

      Everything is OK. I did want to say, that your info was wrong.
      The python package has a bug. OK, when will this be fixed by a package? I can try your advice, but I would prefer the way of getting an update. But ... thnx 4 your help,

      The post was edited 1 time, last by tkaiser: Fixed formatting ().

    • Report it here: https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=libpython3.5-minimal;dist=unstable

      There is already an error report: bugs.debian.org/cgi-bin/bugreport.cgi?bug=909521
      Due the fact that this is reported 24 Sep 2018 it seems the Debian maintainer do not be in a hurry. If you comment the report it might increase the possibility that this bug gets more attention by the Debian project.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • crash omv-mkconf and omv-update

      votdev wrote:

      Report it here: https://bugs.debian.org/cgi-bin/pkgreport.cgi?pkg=libpython3.5-minimal;dist=unstable

      There is already an error report: bugs.debian.org/cgi-bin/bugreport.cgi?bug=909521
      Due the fact that this is reported 24 Sep 2018 it seems the Debian maintainer do not be in a hurry. If you comment the report it might increase the possibility that this bug gets more attention by the Debian project.


      What do I have to do at the debian bug tracker? How does it work? Do I have to write an email?

      Sorry, I never reported a debian bug. All issues I ever reported were reported at github.

      Regards Hoppel
      ---------------------------------------------------------------------------------------------------------------
      frontend software - tvos | android tv | libreelec | win10 | kodi krypton
      frontend hardware - appletv 4k | nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2
      -------------------------------------------
      backend software - debian | openmediavault | latest backport kernel | zfs raid-z2 | docker | emby | unifi | vdr | tvheadend | fhem
      backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x10tb wd red | digital devices max s8
      ---------------------------------------------------------------------------------------------------------------------------------------
    • Users Online 1

      1 Guest