Error with static ip on rock64

    • tkaiser wrote:

      I would start from scratch, do not fiddle around somewhere in the filesystem and simply assign a static DHCP lease on your router as already suggested to you in another thread.
      If you want to fiddle around on Linux boxes to configure stuff there you need at least some knowledge how it's done. Hint: editing /etc/network/interfaces (Debian's ifupdown mechanism) is something from the past. This for example is a good tutorial how to deal with stuff on Debian: linuxconfig.org/how-to-setup-a…p-address-on-debian-linux

      With ayufan's OS images the config files are sourced from subdirectories as it's common today, when you work with the Armbian based ARM images you have to deal with network-manager and there simply call nmtui to switch between DHCP and static addressing.
      Not even this.
      Well I am sorry but I need to "fiddle" because I do need a real static IP to use pi_hole witch cannot work with an assigned DHCP address, and since you are familiar with Rockpro board I am sure being a master it would be nice and easy to give me at least a hint.
      I tried to increase my knowledge by going to the link above and apply the the change to interfaces. d but no joy
      Files
    • Nefertiti wrote:

      I tried to increase my knowledge by going to the link above and apply the the change to interfaces. d but no joy
      I thought you had this sorted?

      But I'll try and explain it as I understand it, the Rockpro image uses network-manager to configure networking, hence the reference to nmtui, this Debian manpage explains.

      The link to linux config explains how to set up a static ip, but first you have to stop, then disable the network daemon for any changes to work.

      To make any changes you must first stop any networking services.
      Raid is not a backup! Would you go skydiving without a parachute?
    • My rockpro has a static ip after removing the eth0 file in /etc/network/interfaces.d and then configuring from the web interface (or omv-firstaid if you can't access the web interface).
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • geaves wrote:

      Nefertiti wrote:

      I tried to increase my knowledge by going to the link above and apply the the change to interfaces. d but no joy
      I thought you had this sorted?
      But I'll try and explain it as I understand it, the Rockpro image uses network-manager to configure networking, hence the reference to nmtui, this Debian manpage explains.

      The link to linux config explains how to set up a static ip, but first you have to stop, then disable the network daemon for any changes to work.

      To make any changes you must first stop any networking services.
      Well reboot should be the same I think

      ryecoaaron wrote:

      My rockpro has a static ip after removing the eth0 file in /etc/network/interfaces.d and then configuring from the web interface (or omv-firstaid if you can't access the web interface).
      This is my problem, OK the web interfaces says now I have a static IP @ 192.168 .2.30 but after rebooting router and OMV and removing assigned DHCP I can only access it @ 192.168.2.248 and by the way omv-first aid is broken on ayufan-releases

      Source Code

      1. Linux rockpro64 4.4.154-1124-rockchip-ayufan-ged3ce4d15ec1 #1 SMP Mon Oct 22 20: 59:41 UTC 2018 aarch64
      2. The programs included with the Debian GNU/Linux system are free software;
      3. the exact distribution terms for each program are described in the
      4. individual files in /usr/share/doc/*/copyright.
      5. Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
      6. permitted by applicable law.
      7. Last login: Sat Nov 10 23:02:22 2018 from 192.168.2.101
      8. root@rockpro64:~# ip addr
      9. 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group defaul t qlen 1
      10. link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      11. inet 127.0.0.1/8 scope host lo
      12. valid_lft forever preferred_lft forever
      13. inet6 ::1/128 scope host
      14. valid_lft forever preferred_lft forever
      15. 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNO WN group default qlen 1000
      16. link/ether 5e:e1:3a:df:8f:59 brd ff:ff:ff:ff:ff:ff
      17. inet 192.168.2.248/24 brd 192.168.2.255 scope global eth0
      18. valid_lft forever preferred_lft forever
      19. 3: br-12416cbc4d22: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue sta te UP group default
      20. link/ether 02:42:88:be:a2:95 brd ff:ff:ff:ff:ff:ff
      21. inet 172.18.0.1/16 brd 172.18.255.255 scope global br-12416cbc4d22
      22. valid_lft forever preferred_lft forever
      23. inet 169.254.93.8/16 brd 169.254.255.255 scope global br-12416cbc4d22
      24. valid_lft forever preferred_lft forever
      25. 4: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP gr oup default
      26. link/ether 02:42:60:c5:18:bd brd ff:ff:ff:ff:ff:ff
      27. inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
      28. valid_lft forever preferred_lft forever
      29. inet 169.254.63.137/16 brd 169.254.255.255 scope global docker0
      30. valid_lft forever preferred_lft forever
      31. 8: veth7cf7a69@if7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue mas ter br-12416cbc4d22 state UP group default
      32. link/ether 3e:3f:84:2b:f1:e3 brd ff:ff:ff:ff:ff:ff link-netnsid 3
      33. inet 169.254.230.57/16 brd 169.254.255.255 scope global veth7cf7a69
      34. valid_lft forever preferred_lft forever
      35. 10: veth2ddd9fa@if9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue ma ster br-12416cbc4d22 state UP group default
      36. link/ether 2e:f0:47:9c:32:29 brd ff:ff:ff:ff:ff:ff link-netnsid 2
      37. inet 169.254.5.232/16 brd 169.254.255.255 scope global veth2ddd9fa
      38. valid_lft forever preferred_lft forever
      39. 12: vethc9d34df@if11: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue m aster docker0 state UP group default
      40. link/ether 1e:db:e0:3c:7c:06 brd ff:ff:ff:ff:ff:ff link-netnsid 1
      41. inet 169.254.4.157/16 brd 169.254.255.255 scope global vethc9d34df
      42. valid_lft forever preferred_lft forever
      43. 44: veth96ebef6@if43: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue m aster docker0 state UP group default
      44. link/ether 66:1a:b1:0c:e6:18 brd ff:ff:ff:ff:ff:ff link-netnsid 0
      Display All
      Images
      • 2018-11-11_085315.jpg

        92.77 kB, 1,429×367, viewed 22 times
    • Did you remove the file in /etc/network/interfaces.d/? I am using ayufan's image too.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Did you remove the file in /etc/network/interfaces.d/? I am using ayufan's image too.
      Absolutely!

      Update
      Even on a brand new install, removing interface.d putting static in the GUI same issue. Is there a solution?

      Source Code

      1. root@rockpro64:~# ip addr
      2. 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
      3. link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      4. inet 127.0.0.1/8 scope host lo
      5. valid_lft forever preferred_lft forever
      6. inet6 ::1/128 scope host
      7. valid_lft forever preferred_lft forever
      8. 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
      9. link/ether 5e:e1:3a:df:8f:59 brd ff:ff:ff:ff:ff:ff
      10. inet 192.168.2.248/24 brd 192.168.2.255 scope global eth0
      11. valid_lft forever preferred_lft forever
      12. root@rockpro64:~# ^C
      13. root@rockpro64:~#
      Display All
      Images
      • 2018-11-11_091647.jpg

        32.65 kB, 823×204, viewed 30 times

      The post was edited 3 times, last by Nefertiti ().

    • Nefertiti wrote:

      How can I resolve this issue?
      I saw something about etc/NetPlan but I do not know if it can apply to OMV?
      Netplan is only on Ubuntu right now. So, this isn't the problem. For me, all I had to do was remove the interfaces.d file and configure the adapter from the OMV web interface.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Nefertiti wrote:

      How can I resolve this issue?
      I saw something about etc/NetPlan but I do not know if it can apply to OMV?
      Netplan is only on Ubuntu right now. So, this isn't the problem. For me, all I had to do was remove the interfaces.d file and configure the adapter from the OMV web interface.
      Since it is not working for me is there a way to resolve it thru CLI?

      Source Code

      1. # Include additional interface stanzas.
      2. source-directory interfaces.d
      3. # The loopback network interface
      4. auto lo
      5. iface lo inet loopback
      6. # eth0 network interface
      7. auto eth0
      8. allow-hotplug eth0
      9. iface eth0 inet static
      10. address 192.168.2.30
      11. gateway 192.168.2.1
      12. netmask 255.255.255.0
      13. broadcast 192.168.2.255
      14. network 192.168.2.0
      15. dns-nameservers 8.8.8.8 8.8.4.4.
      16. iface eth0 inet6 manual
      17. pre-down ip -6 addr flush dev $IFACE
      Display All

      The post was edited 1 time, last by Nefertiti ().

    • Nefertiti wrote:

      Since it is not working for me is there a way to resolve it thru CLI?
      If the interfaces.d file is gone and /etc/network/interfaces is correct, then I don't know how to fix it. What does your /etc/network/interfaces look like?
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Nefertiti wrote:

      dns-nameservers 8.8.8.8 8.8.4.4.
      The dot after the last four might actually be causing this but I haven't tested. The rest looks fine.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I had basically the same issues on latest ayufan stable image (0.7.9. release) -rock64.
      In short, tried configuring through interfaces.d , deleting that and configuring directly in /etc/interfaces, no luck. Web GUI even with fresh installation , no luck. OMV first aid didn't work for that with same error as OP.

      In the "end", I've left a messy configuration due to lack of time and will at the time, DHCP assigned address plus a static one configured through CLI (interfaces.d) (needed for Pi-Hole).

      As I've bumped into this thread, it "forced" me to play with it again. I downloaded "regular" OMV image from sourceforge, and everything was fine.
      Configured Static IP through WebGUI with no errors. Even managed to install Plex plugin through GUI, didn't work before, also had to use CLI. Icing on the cake, solved my VPN problems as well. (That one I still installed through terminal because I found it more straightforward.)

      Given how easy it is to setup OMV through WebGUI, it didn't take all that much time I thought it would.
    • Error with static ip on rock64

      schetz wrote:

      I had basically the same issues on latest ayufan stable image (0.7.9. release) -rock64.
      In short, tried configuring through interfaces.d , deleting that and configuring directly in /etc/interfaces, no luck. Web GUI even with fresh installation , no luck. OMV first aid didn't work for that with same error as OP.

      In the "end", I've left a messy configuration due to lack of time and will at the time, DHCP assigned address plus a static one configured through CLI (interfaces.d) (needed for Pi-Hole).

      As I've bumped into this thread, it "forced" me to play with it again. I downloaded "regular" OMV image from sourceforge, and everything was fine.
      Configured Static IP through WebGUI with no errors. Even managed to install Plex plugin through GUI, didn't work before, also had to use CLI. Icing on the cake, solved my VPN problems as well. (That one I still installed through terminal because I found it more straightforward.)

      Given how easy it is to setup OMV through WebGUI, it didn't take all that much time I thought it would.


      schetz wrote:

      I had basically the same issues on latest ayufan stable image (0.7.9. release) -rock64.
      In short, tried configuring through interfaces.d , deleting that and configuring directly in /etc/interfaces, no luck. Web GUI even with fresh installation , no luck. OMV first aid didn't work for that with same error as OP.

      In the "end", I've left a messy configuration due to lack of time and will at the time, DHCP assigned address plus a static one configured through CLI (interfaces.d) (needed for Pi-Hole).

      As I've bumped into this thread, it "forced" me to play with it again. I downloaded "regular" OMV image from sourceforge, and everything was fine.
      Configured Static IP through WebGUI with no errors. Even managed to install Plex plugin through GUI, didn't work before, also had to use CLI. Icing on the cake, solved my VPN problems as well. (That one I still installed through terminal because I found it more straightforward.)

      Given how easy it is to setup OMV through WebGUI, it didn't take all that much time I thought it would.


      Good to know. What is the exact link for the image working for you since @ SourceForge if I remember they have only images for rock64 witch is different from the rockpro64?

      Sent from my PH-1 using Tapatalk
    • Source Code

      1. root@rockpro64:~# ip addr
      2. 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
      3. link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      4. inet 127.0.0.1/8 scope host lo
      5. valid_lft forever preferred_lft forever
      6. inet6 ::1/128 scope host
      7. valid_lft forever preferred_lft forever
      8. 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
      9. link/ether 5e:e1:3a:df:8f:59 brd ff:ff:ff:ff:ff:ff
      10. inet 192.168.2.30/24 brd 192.168.2.255 scope global eth0
      11. valid_lft forever preferred_lft forever
      12. 3: br-12416cbc4d22: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
      13. link/ether 02:42:98:df:e3:84 brd ff:ff:ff:ff:ff:ff
      14. inet 172.18.0.1/16 brd 172.18.255.255 scope global br-12416cbc4d22
      15. valid_lft forever preferred_lft forever
      16. 4: docker0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default
      17. link/ether 02:42:90:3f:26:36 brd ff:ff:ff:ff:ff:ff
      18. inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
      19. valid_lft forever preferred_lft forever
      20. 6: vethb242fd5@if5: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-12416cbc4d22 state UP group default
      21. link/ether d2:de:92:2e:0c:ad brd ff:ff:ff:ff:ff:ff link-netnsid 2
      22. 8: veth1f299f1@if7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master docker0 state UP group default
      23. link/ether 6a:0b:28:b6:9f:73 brd ff:ff:ff:ff:ff:ff link-netnsid 0
      24. 10: veth58e5416@if9: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-12416cbc4d22 state UP group default
      25. link/ether 8a:98:82:38:08:07 brd ff:ff:ff:ff:ff:ff link-netnsid 3
      26. 23: vethdd2148f@veth892b8c0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default
      27. link/ether 46:6c:1f:41:c9:dc brd ff:ff:ff:ff:ff:ff
      28. 24: veth892b8c0@vethdd2148f: <NO-CARRIER,BROADCAST,MULTICAST,UP,M-DOWN> mtu 1500 qdisc noqueue master docker0 state LOWERLAYERDOWN group default
      29. link/ether 6e:3b:54:e3:18:cd brd ff:ff:ff:ff:ff:ff
      30. root@rockpro64:~# ^C
      31. root@rockpro64:~# sudo service dhcpd status
      32. Unit dhcpd.service could not be found.
      33. root@rockpro64:~#
      Display All
      I think I found a possible solution at least I got only one ip only although my router still flag it as DHCP
      I found it there:
      askubuntu.com/questions/914700…ve-a-secondary-ip-address
      systemctl stop dhcpcd
      systemctl disable dhcpcd
      reboot
      The Sources Code are after and before the fix.
      Update after removing the MAC addr from manually assigned IP list even it was marked are not able made it flag static
      so far so good only one mac addr listed for the board but stiil got " DNS resolution is currently unavailable" in pi hole container

      Source Code

      1. root@rockpro64:~# ip addr
      2. 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
      3. link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      4. inet 127.0.0.1/8 scope host lo
      5. valid_lft forever preferred_lft forever
      6. inet6 ::1/128 scope host
      7. valid_lft forever preferred_lft forever
      8. 2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 1000
      9. link/ether 5e:e1:3a:df:8f:59 brd ff:ff:ff:ff:ff:ff
      10. inet 192.168.2.30/24 brd 192.168.2.255 scope global eth0
      11. valid_lft forever preferred_lft forever
      12. inet 192.168.2.248/24 brd 192.168.2.255 scope global secondary eth0
      13. valid_lft forever preferred_lft forever
      14. 3: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
      15. link/ether 02:42:a3:b6:6f:2f brd ff:ff:ff:ff:ff:ff
      16. inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
      17. valid_lft forever preferred_lft forever
      18. root@rockpro64:~# ^C
      19. root@rockpro64:~# systemctl stop dhcpcd
      20. root@rockpro64:~# systemctl disable dhcpcd
      21. dhcpcd.service is not a native service, redirecting to systemd-sysv-install.
      22. Executing: /lib/systemd/systemd-sysv-install disable dhcpcd
      23. root@rockpro64:~# reboot
      Display All
      Images
      • 2018-11-15_001715.jpg

        42.24 kB, 816×251, viewed 7 times
      • 2018-11-15_001619.jpg

        32.86 kB, 1,018×91, viewed 7 times
      • 2018-11-15_000050.jpg

        15.12 kB, 980×64, viewed 8 times

      The post was edited 3 times, last by Nefertiti ().

    • SOLUTION.
      To make it short so you don't need to read the whole thread.

      Go in OMV GUI configure network as static do not do apply on "The configuration has been changed...." or you will get an an error.


      remove file in etc/network/interface d
      and while you are still in CLI write

      systemctl stop dhcpcd
      systemctl disable dhcpcd
      reboot
      login with your new IP apply the yellow banderole
      and you are done
      will work 100%
    • Users Online 1

      1 Guest