Need help with docker plex using @'TechnoDadLife' tutorial, "A server could not be found"

    • OMV 4.x
    • Need help with docker plex using @'TechnoDadLife' tutorial, "A server could not be found"

      Hi,

      Been busting my brains for the past 24 hours and it is 1AM for me when I write this but had no luck to make this plex server work, so far I have been following @TechnoDadLife tutorial using the linuxserver/plex docker image, but no luck so far the web interface starts, I created an account and logged in, and from here it is stuck in "looking for servers..." "A server could not be found. Download and install Plex Media Server, and it will appear here.", I have deleted this image multiple times, I accessed this server from my local IP and still nothing, created the image manually with docker, created it with the WEB UI interface, nothing.


      Any suggestions ?

      // edit

      Openmediavault v4.1.11
      Hostname openmediavault.local
      Kernel 4.17.0-0.bpo.3-amd64


      Info after docker logs -f plex

      Shell-Script

      1. [s6-init] ensuring user provided files have correct perms...exited 0.
      2. [fix-attrs.d] applying ownership & permissions fixes...
      3. [fix-attrs.d] done.
      4. [cont-init.d] executing container initialization scripts...
      5. [cont-init.d] 10-adduser: executing...
      6. -------------------------------------
      7. _ ()
      8. | | ___ _ __
      9. | | / __| | | / \
      10. | | \__ \ | | | () |
      11. |_| |___/ |_| \__/
      12. Brought to you by linuxserver.io
      13. We gratefully accept donations at:
      14. https://www.linuxserver.io/donate/
      15. -------------------------------------
      16. GID/UID
      17. -------------------------------------
      18. User uid: 998
      19. User gid: 100
      20. -------------------------------------
      21. [cont-init.d] 10-adduser: exited 0.
      22. [cont-init.d] 30-dbus: executing...
      23. [cont-init.d] 30-dbus: exited 0.
      24. [cont-init.d] 40-chown-files: executing...
      25. [cont-init.d] 40-chown-files: exited 0.
      26. [cont-init.d] 50-plex-update: executing...
      27. #####################################################
      28. # Login via the webui at http://<ip>:32400/web #
      29. # and restart the docker, because there was no #
      30. # preference file found, possibly first startup. #
      31. #####################################################
      32. [cont-init.d] 50-plex-update: exited 0.
      33. [cont-init.d] done.
      34. [services.d] starting services
      35. Starting Plex Media Server.
      36. Starting dbus-daemon
      37. [services.d] done.
      38. Starting Avahi daemon
      39. Found user 'avahi' (UID 102) and group 'avahi' (GID 103).
      40. Successfully dropped root privileges.
      41. avahi-daemon 0.7 starting up.
      42. No service file found in /etc/avahi/services.
      43. *** WARNING: Detected another IPv4 mDNS stack running on this host. This makes mDNS unreliable and is thus not recommended. ***
      44. *** WARNING: Detected another IPv6 mDNS stack running on this host. This makes mDNS unreliable and is thus not recommended. ***
      45. Joining mDNS multicast group on interface br-ab01bcac912d.IPv4 with address 172.18.0.1.
      46. New relevant interface br-ab01bcac912d.IPv4 for mDNS.
      47. Joining mDNS multicast group on interface docker0.IPv4 with address 172.17.0.1.
      48. New relevant interface docker0.IPv4 for mDNS.
      49. Joining mDNS multicast group on interface ens5.IPv4 with address 192.168.0.50.
      50. New relevant interface ens5.IPv4 for mDNS.
      51. Joining mDNS multicast group on interface lo.IPv6 with address ::1.
      52. New relevant interface lo.IPv6 for mDNS.
      53. Joining mDNS multicast group on interface lo.IPv4 with address 127.0.0.1.
      54. New relevant interface lo.IPv4 for mDNS.
      55. Network interface enumeration completed.
      56. Registering new address record for 172.18.0.1 on br-ab01bcac912d.IPv4.
      57. Registering new address record for 172.17.0.1 on docker0.IPv4.
      58. Registering new address record for 192.168.0.50 on ens5.IPv4.
      59. Registering new address record for ::1 on lo.*.
      60. Registering new address record for 127.0.0.1 on lo.IPv4.
      61. Server startup complete. Host name is openmediavault.local. Local service cookie is 2869860880.
      62. Error in command line:the argument for option '--serverUuid' should follow immediately after the equal sign
      63. Crash Uploader options (all are required):
      64. --directory arg Directory to scan for crash reports
      65. --serverUuid arg UUID of the server that crashed
      66. --userId arg User that owns this product
      67. --platform arg Platform string
      68. --url arg URL to upload to
      69. --help show help message
      70. --version arg Version of the product
      71. Got SIGTERM, quitting.
      72. Leaving mDNS multicast group on interface br-ab01bcac912d.IPv4 with address 172.18.0.1.
      73. Leaving mDNS multicast group on interface docker0.IPv4 with address 172.17.0.1.
      74. Leaving mDNS multicast group on interface ens5.IPv4 with address 192.168.0.50.
      75. Leaving mDNS multicast group on interface lo.IPv6 with address ::1.
      76. Leaving mDNS multicast group on interface lo.IPv4 with address 127.0.0.1.
      77. avahi-daemon 0.7 exiting.
      78. [cont-finish.d] executing container finish scripts...
      79. [cont-finish.d] done.
      80. [s6-finish] syncing disks.
      81. [s6-finish] sending all processes the TERM signal.
      82. Critical: libusb_init failed
      83. [s6-finish] sending all processes the KILL signal and exiting.
      84. [s6-init] making user provided files available at /var/run/s6/etc...exited 0.
      85. [s6-init] ensuring user provided files have correct perms...exited 0.
      86. [fix-attrs.d] applying ownership & permissions fixes...
      87. [fix-attrs.d] done.
      88. [cont-init.d] executing container initialization scripts...
      89. [cont-init.d] 10-adduser: executing...
      90. usermod: no changes
      91. -------------------------------------
      92. _ ()
      93. | | ___ _ __
      94. | | / __| | | / \
      95. | | \__ \ | | | () |
      96. |_| |___/ |_| \__/
      97. Brought to you by linuxserver.io
      98. We gratefully accept donations at:
      99. https://www.linuxserver.io/donate/
      100. -------------------------------------
      101. GID/UID
      102. -------------------------------------
      103. User uid: 998
      104. User gid: 100
      105. -------------------------------------
      106. [cont-init.d] 10-adduser: exited 0.
      107. [cont-init.d] 30-dbus: executing...
      108. [cont-init.d] 30-dbus: exited 0.
      109. [cont-init.d] 40-chown-files: executing...
      110. [cont-init.d] 40-chown-files: exited 0.
      111. [cont-init.d] 50-plex-update: executing...
      112. #####################################################
      113. # Login via the webui at http://<ip>:32400/web #
      114. # and restart the docker, because there was no #
      115. # plex token found in the preference file #
      116. #####################################################
      117. [cont-init.d] 50-plex-update: exited 0.
      118. [cont-init.d] done.
      119. [services.d] starting services
      120. Starting dbus-daemon
      121. Starting Plex Media Server.
      122. [services.d] done.
      123. Starting Avahi daemon
      124. Found user 'avahi' (UID 102) and group 'avahi' (GID 103).
      125. Successfully dropped root privileges.
      126. avahi-daemon 0.7 starting up.
      127. No service file found in /etc/avahi/services.
      128. *** WARNING: Detected another IPv4 mDNS stack running on this host. This makes mDNS unreliable and is thus not recommended. ***
      129. *** WARNING: Detected another IPv6 mDNS stack running on this host. This makes mDNS unreliable and is thus not recommended. ***
      130. Joining mDNS multicast group on interface br-ab01bcac912d.IPv4 with address 172.18.0.1.
      131. New relevant interface br-ab01bcac912d.IPv4 for mDNS.
      132. Joining mDNS multicast group on interface docker0.IPv4 with address 172.17.0.1.
      133. New relevant interface docker0.IPv4 for mDNS.
      134. Joining mDNS multicast group on interface ens5.IPv4 with address 192.168.0.50.
      135. New relevant interface ens5.IPv4 for mDNS.
      136. Joining mDNS multicast group on interface lo.IPv6 with address ::1.
      137. New relevant interface lo.IPv6 for mDNS.
      138. Joining mDNS multicast group on interface lo.IPv4 with address 127.0.0.1.
      139. New relevant interface lo.IPv4 for mDNS.
      140. Network interface enumeration completed.
      141. Registering new address record for 172.18.0.1 on br-ab01bcac912d.IPv4.
      142. Registering new address record for 172.17.0.1 on docker0.IPv4.
      143. Registering new address record for 192.168.0.50 on ens5.IPv4.
      144. Registering new address record for ::1 on lo.*.
      145. Registering new address record for 127.0.0.1 on lo.IPv4.
      146. Server startup complete. Host name is openmediavault.local. Local service cookie is 330391505.
      Display All


      Preferences.xml

      XML Source Code

      1. <?xml version="1.0" encoding="utf-8"?>
      2. <Preferences OldestPreviousVersion="1.13.5.5332-21ab172de" MachineIdentifier="2311f4a9-a8f8-4055-b64d-c8dbfa82e7a4" ProcessedMachineIdentifier="4242f1a1018796d53048015e47b1d50b840a8d07" AnonymousMachineIdentifier="41d1d161-2405-4a69-9977-40e5efd3aabd" GracenoteUser="WEcxA7Y7UFCBF7Z9sfAGjYoRwDluWy+MMow5U52RZZWNEAsvc4+slEcjs3XWfi3eehs1BYGzZD7gl/O8UeJ3p7KzB+zWcrYmBGDULxdNgpW9PRgN6WGNkjzDsGgPFlwOv8UiIEoTxZTo7xyBP9tu/xhVyBkju/2TOV8V1hdBxVCboJpRYT3KkG98nWuaHkCpPnYg==" MetricsEpoch="1"/>

      The post was edited 1 time, last by syrusstk ().

    • After hours upon hours of trying to make linuxserver/plex working, I just deleted the thing and installed the official docker from plex and that one worked like a charm, not sure what is happening with the linuxserver docker images, few days ago I set up letsencrypt with no problem at all, now after the clean install did the same steps as in @TechnoDadLife tutorial, as I previously did but for some reason I get 502 bad gateway, seen multiple people reporting on this.