Nextcloud, your personal cloud server, GNU nano blank page

    • The only thing I found was same issue like in the first part of the video where the redirection of the port did not stick in the container nextcloud .

      For letsencrypt this time I even had to change the container’s name probably a bug in the Docker services, so I changed from letsencrypt to lets-encrypt in container name I can get a certificate with docker logs -f lets-encrypt if I keep the original config.php and nextcloud subdomain.conf, I can login in next cloud locally at 192.168.2.150:444
      but unfortunately it is not working remotely or locally if I change those like in the second video
      Images
      • 2018-10-09_114112.jpg

        63.34 kB, 1,126×180, viewed 41 times
      • 2018-10-10_174320.jpg

        104.91 kB, 1,312×272, viewed 40 times

      The post was edited 1 time, last by Nefertiti ().

    • TechnoDadLife wrote:

      So you can login locally after you have letsencrypt connected to Nextcloud?

      Then please post your phone files that you modified.
      I do not understand phone files but I am on the way since in fact the big issue I believe and I am not an expert,is the DH file is probably too big for the the arm, PI and alike so I had to reduce to 1024 same in nextcloud subdomain .conf line 28 this why I got this error before

      nginx: [emerg] "proxy_max_temp_file_size" directive invalid value in /config/nginx/proxy-confs/nextcloud.subdomain.conf:28

      Now I had to do again the letsencrypt container since the port forwarding disappear again!
      But I am kind of skeptical about my router instalation at home since I got the one from ATT real peace of !@#$ of course I put iit DMZ pin hole for My asus router I do not have double nat on it but not sure if the pace router free up the ports according to canyouseeme.org/
      Images
      • 2018-10-13_115230.jpg

        35.42 kB, 539×376, viewed 40 times
      • 2018-10-13_115442.jpg

        81.56 kB, 679×415, viewed 39 times
    • UPDATE
      Now when I use 192.168.2.150:444/ I am redirected to lefouvolant.duckdns.org/index.php/login
      but with a generic welcome page!


      Welcome to our server


      The website is currently being setup under this address.


      For help and support, please contact: me@example.com
      Images
      • 2018-10-13_142201.jpg

        43.96 kB, 742×545, viewed 35 times

      The post was edited 1 time, last by Nefertiti ().

    • THIS IS IT FINALLY CONNECTED
      After more than a week and a lot of sweat I succeed to login from outside my LAN ye!
      what i did beside lowering the DH to 1024, was to change to in the config.php to change' my domain.duckdns.org' by 'nextcloud.my domain.duckdns.org' in nextcloud.subdomain.conf but actually I do not think it is necessary but since I did a lot of try and error, I left it this way when I got connection to nextcloud, to make it short with this mod. or no I was getting the generic page to the server so both way are ok.

      The main issue what I found out, since I had to do the letsencrypt container again so many time because I forgot to type a line or typo or whatever, I noticed the function ONLY_subdomain is hard coded in the container with "false" I thought to put an other one with true was kind of strange so I did not, and changed the original one to true and BINGO was the solution at least for me .
      .Sometime I am getting stubborn until I find a solution even if I have no idea what I am doing.
      I cannot praise enough TechnoDadLife to make this great video in order to get nextxcloud in our OMV in a such easy and simple way.
      Images
      • 2018-10-13_220657.jpg

        151.52 kB, 1,316×774, viewed 52 times
      • 2018-10-13_220738.jpg

        111.48 kB, 1,901×615, viewed 51 times
      • 2018-10-13_220819.jpg

        184.86 kB, 1,366×613, viewed 53 times
    • Thank you but , I think I need your help again try to upgrade nextcloud got stuck at parsing response failed
      and also I want to add an external share folder so I am trying this
      How to share folders with Nextcloud
      but now since I add the extra volume and bind mounts I am getting 502 bad gateway even after removing it!

      Update
      The 502 gateway error is fixed I Have to add in the extra argument --network my-net of Nextcloud container
      Images
      • 2018-10-14_104702.jpg

        76.22 kB, 585×627, viewed 50 times
      • 2018-10-14_105912.jpg

        117.61 kB, 822×659, viewed 45 times

      The post was edited 1 time, last by Nefertiti ().

    • @TechnoDadLife I have a question: About 10:40 into the video on remote Nextcloud, you insert an EMAIL line in the letsencrypt container. I signed up with duckdns with my twitter account so my account doesn't have an email address associated with it, just a twitter account, so that my account is
      <astring-of-numbers>@twitter
      what should I do with this line?

      On the Letsencrypt info page for the container, under Optional settings it reads "-e EMAIL - your e-mail address for cert registration and notifications" so can I just use any email I have?
      Retired. Love to garden and mess with computers. The more I mess with both the less I know about either.
    • I decided to delete my subdomains in my twitter sign up to Duckdns and sign up using my gmail, and reclaim the subdomains. Problem solved.

      At the creation of the certificates (docker logs -f letsencrypt) after the long pause I get the following error:

      "- The following errors were reported by the server:

      Domain: pwh.duckdns.org
      Type: connection
      Detail: Fetching
      pwh.duckdns.org/.well-known/ac…BvsUD7r76a_U896T-ypjeu-c:
      Timeout during connect (likely firewall problem)

      To fix these errors, please make sure that your domain name was
      entered correctly and the DNS A/AAAA record(s) for that domain
      contain(s) the right IP address. Additionally, please check that
      your computer has a publicly routable IP address and that no
      firewalls are preventing the server from communicating with the
      client. If you're using the webroot plugin, you should also verify
      that you are serving files from the webroot path you provided.
      - Your account credentials have been saved in your Certbot
      configuration directory at /etc/letsencrypt. You should make a
      secure backup of this folder now. This configuration directory will
      also contain certificates and private keys obtained by Certbot so
      making regular backups of this folder is ideal.
      ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fi
      x your settings and recreate the container"

      My internet provider is through AT&T DSL and I have a Netgear modem in pass-through mode with a Netgear R7000 router with Tomato firmware (yes, I did too.)

      So what is my next step? I am looking into "likely firewall problem" but am not sure what I am looking for.
      Retired. Love to garden and mess with computers. The more I mess with both the less I know about either.
    • Agricola wrote:

      I decided to delete my subdomains in my twitter sign up to Duckdns and sign up using my gmail, and reclaim the subdomains. Problem solved.

      At the creation of the certificates (docker logs -f letsencrypt) after the long pause I get the following error:

      "- The following errors were reported by the server:

      Domain: pwh.duckdns.org
      Type: connection
      Detail: Fetching
      pwh.duckdns.org/.well-known/ac…BvsUD7r76a_U896T-ypjeu-c:
      Timeout during connect (likely firewall problem)

      To fix these errors, please make sure that your domain name was
      entered correctly and the DNS A/AAAA record(s) for that domain
      contain(s) the right IP address. Additionally, please check that
      your computer has a publicly routable IP address and that no
      firewalls are preventing the server from communicating with the
      client. If you're using the webroot plugin, you should also verify
      that you are serving files from the webroot path you provided.
      - Your account credentials have been saved in your Certbot
      configuration directory at /etc/letsencrypt. You should make a
      secure backup of this folder now. This configuration directory will
      also contain certificates and private keys obtained by Certbot so
      making regular backups of this folder is ideal.
      ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fi
      x your settings and recreate the container"

      My internet provider is through AT&T DSL and I have a Netgear modem in pass-through mode with a Netgear R7000 router with Tomato firmware (yes, I did too.)

      So what is my next step? I am looking into "likely firewall problem" but am not sure what I am looking for.




      How did you do port forwarding on you router (PIC)?
    • Agricola wrote:

      I decided to delete my subdomains in my twitter sign up to Duckdns and sign up using my gmail, and reclaim the subdomains. Problem solved.

      At the creation of the certificates (docker logs -f letsencrypt) after the long pause I get the following error:

      "- The following errors were reported by the server:

      Domain: pwh.duckdns.org
      Type: connection
      Detail: Fetching
      pwh.duckdns.org/.well-known/ac…BvsUD7r76a_U896T-ypjeu-c:
      Timeout during connect (likely firewall problem)

      To fix these errors, please make sure that your domain name was
      entered correctly and the DNS A/AAAA record(s) for that domain
      contain(s) the right IP address. Additionally, please check that
      your computer has a publicly routable IP address and that no
      firewalls are preventing the server from communicating with the
      client. If you're using the webroot plugin, you should also verify
      that you are serving files from the webroot path you provided.
      - Your account credentials have been saved in your Certbot
      configuration directory at /etc/letsencrypt. You should make a
      secure backup of this folder now. This configuration directory will
      also contain certificates and private keys obtained by Certbot so
      making regular backups of this folder is ideal.
      ERROR: Cert does not exist! Please see the validation error above. The issue may be due to incorrect dns or port forwarding settings. Please fi
      x your settings and recreate the container"

      My internet provider is through AT&T DSL and I have a Netgear modem in pass-through mode with a Netgear R7000 router with Tomato firmware (yes, I did too.)

      So what is my next step? I am looking into "likely firewall problem" but am not sure what I am looking for.




      How did you do port forwarding on you router (PIC)?
      I assume 10.0.1.70 is the address of your login into OMV . Just wondering if you did make a static IP as recommended in the user guide anyway I had to do it to configure pihole so maybe you want to look at that. also do not forget to reboot router and Probably OMV when you are making this changes.

      I do not know your equipment but you mentioned you ' ve got your ATT in pass-through mode, you have to be sure of it, do you see the external (public) IP in your router home page the one from whatismyip.com/ otherwise you are in double NAT and need to be fixed.

      The post was edited 1 time, last by Nefertiti ().

    • @Nefertiti The same 70.xxx.xxx.xxx on whatismyip.com does show up in my router. I don't know what you mean about making a static IP. Which user guide are you speaking about. This morning I rechecked my router and rebooted, then I went to my server and rechecked my letsencrypt container and then rebooted OMV. I then ran the docker logs -f letsencrypt command. I still got the same error message.
      Retired. Love to garden and mess with computers. The more I mess with both the less I know about either.
    • Agricola wrote:

      @Nefertiti The same 70.xxx.xxx.xxx on whatismyip.com does show up in my router. I don't know what you mean about making a static IP. Which user guide are you speaking about. This morning I rechecked my router and rebooted, then I went to my server and rechecked my letsencrypt container and then rebooted OMV. I then ran the docker logs -f letsencrypt command. I still got the same error message.
      New User Guide - Getting Started with Openmediavault Page 37 also make sure nextcloud is working locally part 1 of the guide
      Images
      • 2018-10-22_103833.jpg

        251.51 kB, 1,002×1,370, viewed 40 times

      The post was edited 1 time, last by Nefertiti ().

    • Agricola wrote:

      I just tried, and it seems to connect but all I see is a pure white page with nothing at all on it.
      My feeling there is no point to try to connect remotely until you got nextcloud working. Just stick to the guide (first video) eventually you will succeed
      From my experience also do not try to modify an already made container because you will get more errors and problems or/and the mods wont stick anyway, just stop them, delete them and make them again I have done it countless time so I know what I am talking about!
      For the second video since you got an ARM I think you need to reduce the DH to 1024 at two places if I remember and change the part about ONLY_subdomain like in my previous post, but this worked for me I am not an expert YMMV.