Disable OMV Quota System Entirely

    • OMV 4.x
    • Disable OMV Quota System Entirely

      Hi All,

      In regards to quotas, I have seen @ryecoaaron write in this forum recently:

      "I agree they should be disabled by default (or have a place to disable them). The arm images I create have the quota service disabled by default."

      What's the best and cleanest way to completely disable the quota service?

      I've searched the forum but failed to turn up the definitive answer.

      And before I disable quota's completely... Is there any benefit to leaving them on? I'm the only user accessing the OMV NAS, and I can't think of a reason to use quotas. Course one thing I love about OMV and the OMV developer community is how you don't let users do stupid things easily. So I'm curious if there's a benefit to enabling the quota service that I haven't groked.

      Cheers,
      Steve
    • sholyer@gmailcom wrote:

      What's the best and cleanest way to completely disable the quota service?
      That post is outdated. Quotas are now only enabled when you use them. I don't use quotas and I can't think of any reason to do enable them if you are the only user of the NAS>
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • sholyer@gmailcom wrote:

      When did that happen?
      I honestly don't remember. OMV 2.x maybe?
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I want to reopen my question.

      I was just transferring a lot of data to a new drive in my OMV system. And after a bit the client gave me an error that the server (OMV) sent the message "insufficient_quota....".

      There are no user quota's set for that filesystem (or any filesystem). I *am* running 4.0 (never ran any other versions), but it seems to be doing some quota checking. I've looked around and don't find a place to disable this.

      Can you give me some new help?
    • zurcherart wrote:

      I was just transferring a lot of data to a new drive in my OMV system. And after a bit the client gave me an error that the server (OMV) sent the message "insufficient_quota....".
      What client? I have never seen that.

      zurcherart wrote:

      There are no user quota's set for that filesystem (or any filesystem). I *am* running 4.0 (never ran any other versions), but it seems to be doing some quota checking. I've looked around and don't find a place to disable this.
      Even if the service was running, there would still be no enforcement because there is no limit IF you didn't set a limit.

      Even though it is a new install, were the data disks ever part of system that had a quota set?
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I thought I had answered this, but I don't see my reply.

      To close the loop the drive is pretty new, but it was used in a synology 1512+ . My buddy got larger drives and gave me his old drives.

      However, the real issue seems to be invalid user at keyboard. When I thought this through my scenario was that I was using Transmit (which if you are not aware) is a macos ftp client that also interacts with Dropbox. What I was doing was using my macbook to download files form Dropbox and save them to a Samba share that was being served my local OMV NAS.

      So the client was transmit, and almost certainly the quota error was coming form the api on the dropbox "server".

      Anyway thanks for the help, wanted to close the loop. That leads me to a new question which I'll ask in a new thread.