Disk disconnects after exchanging data

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Disk disconnects after exchanging data

      Hi, I'm kindly asking some suggestion to find out the root of my issue. I'm not sure if it's related to OMV.
      I'm running OMV on a Debian machine (embedded PC) with an external USB/SATA hard-disk.
      The USB enclosure and the HD works fine under Windows and Linux desktop machine.

      When connected to this embedded PC w/ OMV, it happens that after exchanging (a lot of) data it disconnects. For example if I read or write large files (several hundreds of MB) OMV doesn't see it anymore.
      I found this in the dmesg, but I'm not sure if there's a problem in the configuration of OMV or it's something related to my hardware.

      <quote>
      [504699.197953] usb 1-2.2: reset high-speed USB device number 3 using xhci_hcd
      [504699.277816] usb 1-2.2: device descriptor read/64, error -71
      [504699.465874] usb 1-2.2: device descriptor read/64, error -71
      [504699.655456] usb 1-2.2: reset high-speed USB device number 3 using xhci_hcd
      [504699.735015] usb 1-2.2: device descriptor read/64, error -71
      [504699.926043] usb 1-2.2: device descriptor read/64, error -71
      [504700.114119] usb 1-2.2: reset high-speed USB device number 3 using xhci_hcd
      [504700.114309] usb 1-2.2: Device not responding to setup address.
      [504700.321905] usb 1-2.2: Device not responding to setup address.
      [504700.533918] usb 1-2.2: device not accepting address 3, error -71
      [504700.614297] usb 1-2.2: reset high-speed USB device number 3 using xhci_hcd
      [504700.614487] usb 1-2.2: Device not responding to setup address.
      [504700.822532] usb 1-2.2: Device not responding to setup address.
      [504701.030419] usb 1-2.2: device not accepting address 3, error -71
      [504701.031018] scsi host0: uas_eh_bus_reset_handler FAILED err -19
      [504701.031035] sd 0:0:0:0: Device offlined - not ready after error recovery
      [504701.031046] sd 0:0:0:0: Device offlined - not ready after error recovery
      [504701.031091] sd 0:0:0:0: [sda] tag#1 FAILED Result: hostbyte=DID_TIME_OUT dri verbyte=DRIVER_OK
      [504701.031109] sd 0:0:0:0: [sda] tag#1 CDB: Write(10) 2a 00 3a 04 1a 30 00 01 3 0 00
      [504701.031120] blk_update_request: I/O error, dev sda, sector 973347376
      [504701.031666] sd 0:0:0:0: [sda] tag#0 FAILED Result: hostbyte=DID_OK driverbyt e=DRIVER_TIMEOUT
      [504701.031674] Aborting journal on device sda1-8.
      [504701.031721] sd 0:0:0:0: rejecting I/O to offline device
      [504701.031749] JBD2: Error -5 detected when updating journal superblock for sda 1-8.
      [504701.032782] sd 0:0:0:0: [sda] tag#0 CDB: Read(10) 28 00 6f 84 50 40 00 00 08 00
      [504701.032793] blk_update_request: I/O error, dev sda, sector 1870942272
      [504701.033379] usb 1-2.2: USB disconnect, device number 3
      [504701.033391] sd 0:0:0:0: rejecting I/O to offline device
      [504701.033889] EXT4-fs error (device sda1): ext4_journal_check_start:56: Detect ed aborted journal
      [504701.034491] EXT4-fs (sda1): Remounting filesystem read-only
      [504701.034892] EXT4-fs (sda1): previous I/O error to superblock detected
      [504701.070642] sd 0:0:0:0: [sda] Synchronizing SCSI cache
      [504701.310280] sd 0:0:0:0: [sda] Synchronize Cache(10) failed: Result: hostbyte =DID_ERROR driverbyte=DRIVER_OK
      [504701.438815] usb 1-2.2: new high-speed USB device number 5 using xhci_hcd
      [504701.518690] usb 1-2.2: device descriptor read/64, error -71
      [504701.706939] usb 1-2.2: device descriptor read/64, error -71
      [504701.894978] usb 1-2.2: new high-speed USB device number 6 using xhci_hcd
      [504701.975036] usb 1-2.2: device descriptor read/64, error -71
      [504702.163685] usb 1-2.2: device descriptor read/64, error -71
      [504702.271251] usb 1-2-port2: attempt power cycle
      [504702.874833] usb 1-2.2: new high-speed USB device number 7 using xhci_hcd
      [504702.875093] usb 1-2.2: Device not responding to setup address.
      [504703.083455] usb 1-2.2: Device not responding to setup address.
      [504703.291024] usb 1-2.2: device not accepting address 7, error -71
      [504703.371513] usb 1-2.2: new high-speed USB device number 8 using xhci_hcd
      [504703.371688] usb 1-2.2: Device not responding to setup address.
      [504703.579348] usb 1-2.2: Device not responding to setup address.
      [504703.787653] usb 1-2.2: device not accepting address 8, error -71
      [504703.788225] usb 1-2-port2: unable to enumerate USB device
      </quote>
    • I assume bad cable or contacts, but this is only a guess based on the kernel messages of the USB driver.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit