Can not install virtualbox

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can not install virtualbox

      Good morning,
      we are running an openvpn server and want to install Virtualbox for some VMs. We ran into in installation problem, and installed virtualbox manually via console. As some stuff was not working we removed it. Now we wanted to reinstall Virtualbox via the OMV-Gui but recieve this message while reinstalling.

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. >>> *************** Error ***************
      5. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-virtualbox 2>&1' with exit code '100': Reading package lists...
      6. Building dependency tree...
      7. Reading state information...
      8. Some packages could not be installed. This may mean that you have
      9. requested an impossible situation or if you are using the unstable
      10. distribution that some required packages have not yet been created
      11. or been moved out of Incoming.
      12. The following information may help to resolve the situation:
      13. The following packages have unmet dependencies:
      14. openmediavault-virtualbox : Depends: openmediavault (>= 4.1.4) but 3.0.99 is to be installed
      15. Depends: php7.0-soap but it is not installable
      16. Depends: phpvirtualbox (>= 5.2-0-1) but it is not going to be installed
      17. Depends: virtualbox (>= 5.2.8) but 5.1.26-dfsg-2 is to be installed
      18. E: Unable to correct problems, you have held broken packages.
      19. <<< *************************************
      Display All

      I tried to remove the packages, but phpvirtualbox and virtualbox are not installed. Am i right that it has something to do with
      " : openmediavault (>= 4.1.4) but 3.0.99 is to be installed "?
    • You have the wrong version of omv-extras installed. You install the 4.x version on OMV 3.x.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!