[SOLVED] rsync extra options

    • OMV 4.x
    • Resolved
    • rsync extra options

      I can't seem to get OMV 4's rsync plugin to push a backup to a server on the same network.

      If I run the command manually in a shell it works just fine.
      I have had to use the --protocol=29 for backwards compatability of the rsync daemon running on an iomega storcenter ix2-200 running on the same network. The iomega is eol so I can't expect an update.

      running rsync --version on both reveals the following:
      OMV 4 = rsync version 3.1.2 protocol version 31
      IOMEGA = rsync version 2.6.9 protocol version 29

      As I said previously, I can ssh into OMV and run:
      rsync -avz --protocol=29 /srv/dev-disk-by-label-somelabel/someshare/ user@host::module and it works just fine.


      I can't seem to get this to work in the plugin to work accordingly.

      Under extra options I have tried putting in both --protocol=29 which didn't work. Tried --protocol='29' which didn't work.


      I could set up a cron job via webmin to run it manually but would really like to use the convenience of the plugin.


      Can anyone point me in the right direction?


      Thanks in advance.
    • Ok....my bad.

      I had to many of the boxes checked.
      If I leave it just as archive mode it works without the protocol option.

      I had to turn off extended attributes and preserve acls and modification times.

      Considering archive mode provides that anyway no biggie.

      Consider this pebkac issue solved.

      Just in case it's unfamiliar, pebkac = problem exists between keyboard and chair.
    • Users Online 1

      1 Guest