RAID 6: GPT table is corrupt

    • RAID 6: GPT table is corrupt

      Hello All,

      I have two disks in my RAID 6 array showing: the GPT table is corrupt, but the backup appears OK, so that will be used (/dev/sdd and /dev/sde). The RAID is clean and active at the moment. The doc I read on how to restore the GPT table made me hesistant as one of the steps said it may cause strange things to happen to a RAID array. Can anyone assist with steps to correct this? Thank you.

      I'm running OMV 4.1.12 from a flash drive. I have 5 3TB WD greens in a RAID 6 array.

      fdisk

      Source Code

      1. root@omv:~# fdisk -l | grep "Disk "
      2. The primary GPT table is corrupt, but the backup appears OK, so that will be used.
      3. Disk /dev/sda: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
      4. Disk /dev/sdc: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
      5. Disk /dev/sdb: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
      6. The primary GPT table is corrupt, but the backup appears OK, so that will be used.
      7. Disk /dev/sdd: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
      8. Disk identifier: 47158644-8D78-490C-9B67-C9627CF36E92
      9. Disk /dev/sde: 2.7 TiB, 3000592982016 bytes, 5860533168 sectors
      10. Disk identifier: 8B2684BE-9621-451C-B25F-BD324FDDD82E
      11. Disk /dev/md126: 8.2 TiB, 9001374842880 bytes, 17580810240 sectors
      12. Disk /dev/sdf: 115.7 GiB, 124218507264 bytes, 242614272 sectors
      13. Disk identifier: 0xbe1d306f
      Display All

      /proc/mdstat

      Source Code

      1. root@omv:~# cat /proc/mdstat
      2. Personalities : [raid6] [raid5] [raid4] [linear] [multipath] [raid0] [raid1] [raid10]
      3. md126 : active raid6 sdd[4] sde[5] sdb[0] sda[6] sdc[1]
      4. 8790405120 blocks super 1.2 level 6, 512k chunk, algorithm 2 [5/5] [UUUUU]
      5. bitmap: 0/22 pages [0KB], 65536KB chunk
      6. unused devices: <none>
      mdadm

      Source Code

      1. root@omv:~# mdadm --detail --scan --verbose
      2. ARRAY /dev/md/omv:OMVStorage level=raid6 num-devices=5 metadata=1.2 name=omv:OMVStorage UUID=192e44a3:750e37c3:10f8b626:eed40748
      3. devices=/dev/sda,/dev/sdb,/dev/sdc,/dev/sdd,/dev/sde
      4. root@omv:~#
    • It looks like you created the array with OMV which means it is not using partitions. So, a corrupt GPT doesn't cause any problems. It just means the drives weren't completely wiped before creating the array.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Users Online 1

      1 Guest