Frustrating install experience and recommendations for improvement, part 1

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Frustrating install experience and recommendations for improvement, part 1

      This will be long, so tl;dr:

      1. I beg you, add non-free firmware to iso.
      2. Add clearer (more alarming!) message on login screen if no network card found.
      3. Add clearer message on login screen if network card found, but not connected to network.
      4. Consider adding more 'common problems' based on below, especially on non-free firmware (I'm sure I'm not the only one with this problem), and on wifi (I would be surprised if I'm the only one), although I don't know if the problems below are 'common' or not...
      5. Add clearer info which Debian 9.x is used for the install iso (9.0, 9.1, ...), not just "Debian 9"

      Now the long story:

      I was looking for NAS OS, narrowed down to OMV and XigmaNAS, I'm sure for the same reasons as many others. Decided to go with OMV, Debian has great reputation, OMV has good reviews, active forum, so let's do it!

      About my experience: I'm a Windows user, I can manage installing OS, I installed different Linux/Solaris/BSD "for fun" to see how they look like. I can fumble my way around CLI if I have some instructions, I don't know details about network beyond that DHCP will magically connect me to the Internet. I'm literate enough to see there is a problem, but not not literate enough to correctly diagnose it.

      So I download install ISO, make bootable USB, boot my old Thinkpad x220, start install, during installation it doesn't find any NIC.

      PROBLEM: No NIC found during install.
      SOLUTION: See later, later later, much later, and much much later...

      I force to continue install anyway to see what it looks like. It completes, I can log in, shell works, obliviously no NIC, so I'm looking what to do.

      Since it is Debian, I look around, I find this:

      wiki.debian.org/InstallingDebianOn/Thinkpad/

      which leads me to this and this:

      wiki.debian.org/InstallingDebianOn/Thinkpad/X220
      wiki.debian.org/InstallingDebianOn/Thinkpad/X220/squeeze

      PROBLEM: One of them says to install firmware-iwlwifi, the other says firmware-realtek, how am I supposed to know which one is correct?
      SOLUTION: I don't know how to confirm which one I need?

      But I find also this:

      debian.org/releases/stretch/amd64/ch06s04.html.en

      PROBLEM: still the same problem: no NIC found during install, don't know which firmware to install.
      SOLUTION: Brilliant, just add all firmware to install USB and don't worry about which one you need! But why OMV haven't done that? Why not just add non-free firmware to install iso, so we don't have to get to this point?

      Non-free firmware leads me to this:

      cdimage.debian.org/cdimage/uno…on-free/firmware/stretch/

      PROBLEM: Right now there are 7 versions of non-free firmware for Debian 9, and I'm pretty sure I have to match OMV is with correct Debian 9.x. How am I supposed to know which Debian 9.x is used by install ISO (OMV 4.1.3), so I can get correct Debian package?
      SOLUTION: OMV 4.x says it is based on Debian 9, but doesn't say which one exactly. Why not say 9.1, 9.2, 9.3, 9.4, 9.5, at least for the installation iso, so we can get correct firmware/package from the Debian repository?

      I decide to continue with the latest (current):

      cdimage.debian.org/cdimage/uno…firmware/stretch/current/

      I unzip, copy all .deb to /firmware on install USB, start fresh install on the same ThinkPad x220, the install detects NIC, connect to my wifi, asks for wifi password, pick repository, it updates form repository, install completes, reboots.

      At this point I though (incorrectly!): full success!

      Login screen doesn't give me hint what to do, so I login as root, and first I try apt-get update/upgrade, everything errors out, login screen says to start with omv-firstaid, I pick first option, it errors out...

      I reboot, repeat everything: apt-get update/upgrade, it errors out, omv-firstaid, option 1, it errors out, with this error:

      error when accessing gui

      I follow instructions, reboot, still the same.

      I get idea that I'm not connected to the Internet, I look around the forum, find this and this:

      No Network Interface on 4.0.10 ?
      Terminal says "No interface available"

      But I do *not* get the message: "No network interface(s) available"

      I follow instructions, reboot, still the same.

      PROBLEM: Some instructions say to use 'ifconfig', which I'm familiar with form Ubuntu, it is it not in OMV?
      SOLUTION: Add ifconfig to OMV?

      PROBLEM: At this point I though NIC detected and connected to Internet during install, but there was no NIC and no Interned after the install.
      SOLUTION: Few hours later, I learned that NIC did work, but I was not connected to the network/Internet. If I knew this at this point, it would have saved many hours...

      At this point, I get an idea to install OMV on a separate computer in VM, to see what 'correct' install should look like.

      PROBLEM: I should not have to install in VM just to see what 'correct' install looks like.
      SOLUTION: I don't know...

      I install OMV in VirtualBox on Windows, install correctly, reboots, and now I see what I should have seen:

      IP address on login screen!!!

      PROBLEM: No IP address for my x220 install!
      SOLUTION: The login screen with IP address could have been highlighted in 'common problems', and if there is no IP, then nothing will work.

      So go back to my x220, and see no IP. I go back to my VM, disable NIC, reboot, and login screen say:

      "No network interface(s) available"

      PROBLEM: No such message on my x220 install.
      SOLUTION: What is going on??? At this point I didn't understand it, but now I know that NIC worked, but not connected to network/Internet.

      So now I'm thinking that during install NIC is detected and connects to the Internet, but no NIC and no Internet after install.

      I go back to this:

      debian.org/releases/stretch/amd64/ch06s04.html.en

      There are is a sentences that peeks my interest:

      "However, if the installed system runs a different kernel version from the installer there is a slight chance that the firmware cannot be loaded due to version skew."

      PROBLEM: So perhaps my firmware is correct during install but not correct for installed system?
      SOLUTION: This is complete madness!!!

      PROBLEM: So if OMV is based on Debian 9.1 (for example), but I got firmware for Debian 9.5, it will not work?
      SOLUTION: Get all versions, and install 'manually'.

      PROBLEM: OMG, so now I have to match installer version, boot version, and Debian version? But what are they? 9.0, 9.1, 9.2, 9.3, 9.4, 9.5?
      SOLUTION: How do I check? Why install iso doesn't specify exact Debian version? How do I know if install and boot are the same or different?

      Fine, I'm way beyond frustrated, but determined to make it work. I get firmware from

      cdimage.debian.org/cdimage/uno…irmware/stretch/20171008/

      and this

      cdimage.debian.org/cdimage/uno…irmware/stretch/20171014/

      and this

      cdimage.debian.org/cdimage/uno…irmware/stretch/20171016/

      and this

      cdimage.debian.org/cdimage/uno…irmware/stretch/20171209/

      and this

      cdimage.debian.org/cdimage/uno…irmware/stretch/20180310/

      and this

      cdimage.debian.org/cdimage/uno…irmware/stretch/20180714/

      and this

      cdimage.debian.org/cdimage/uno…firmware/stretch/current/

      I unzip each, try to copy from USB to OMV installed on ThinkPad x220.

      PROBLEM: No automount, now search how to mount USB manually!
      SOLUTION: Google to the rescue!

      Now, I go back to this:

      wiki.debian.org/InstallingDebianOn/Thinkpad/X220
      wiki.debian.org/InstallingDebianOn/Thinkpad/X220/squeeze

      PROBLEM: see previous PROBLEM(s)
      SOLUTION: I don't know which one I need, firmware-iwlwifi or firmware-realtek, so I install both.

      For each firmware, I extract iwlwifi and realtek, copy to USB, mount manually, install from CLI:

      dpkg -i firmware-iwlwifi_[...].deb
      dpkg -i firmware-realtek_[...].deb

      reboot, login, check NIC, IP, Internet.

      PROBLEM: No IP, no Internet, no message "No network interface(s) available"
      SOLUTION: Re-install both firmware from CLI 7 times, for 7 different versions of Debian 9. Each time the same results: no IP, no internet, no message "No network interface(s) available"

      OK, I'm doing something wrong. I'm thinking: NIC is detected during install, connects to wifi, but after reboot, it seems that there is no NIC, and no Internet.

      So I reinstall OMV, with the 'oldest' firmware (I assume 9.0), instead the 'current' (I assume 9.5):

      cdimage.debian.org/cdimage/uno…irmware/stretch/20171008/

      During the install NIC is detected, connects to wifi, connects to Internet, reboot, and the same results: no IP, no Internet, no message "No network interface(s) available"

      POST TOO LONG, CONTINUE IN PART 2...