OVM 4 on a rpi B+

    • OVM 4 on a rpi B+

      Hello,
      I'm trying to install OVM on a raspberry model B+ and I can't make it works
      I first tried whith an image from here : sourceforge.net/projects/openm…/Raspberry%20Pi%20images/
      and it did'nt boot (kernel panic not syncing error)
      I presumed it was an incompatibility with rpi B+ (model 1.2 - 2014)

      I then tried with a fresh install of raspbian stretch (Install OMV4 on Debian 9 (Stretch))
      and I have some probems with php7 fpm :

      Shell-Script

      1. Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
      2. Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
      3. Hit:3 http://packages.openmediavault.org/public arrakis InRelease
      4. Reading package lists... Done
      5. Reading package lists... Done
      6. Building dependency tree
      7. Reading state information... Done
      8. openmediavault-keyring is already the newest version (1.0).
      9. 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
      10. 3 not fully installed or removed.
      11. After this operation, 0 B of additional disk space will be used.
      12. Do you want to continue? [Y/n] Y
      13. Setting up php7.0-fpm (7.0.30-0+deb9u1) ...
      14. Job for php7.0-fpm.service failed because a fatal signal was delivered to the control process.
      15. See "systemctl status php7.0-fpm.service" and "journalctl -xe" for details.
      16. invoke-rc.d: initscript php7.0-fpm, action "start" failed.
      17. * php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager
      18. Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)
      19. Active: failed (Result: signal) since Fri 2018-11-02 15:20:54 UTC; 224ms ago
      20. Docs: man:php-fpm7.0(8)
      21. Process: 24270 ExecStart=/usr/sbin/php-fpm7.0 --nodaemonize --fpm-config /etc/php/7.0/fpm/php-fpm.conf (code=killed, signal=ILL)
      22. Main PID: 24270 (code=killed, signal=ILL)
      23. Nov 02 15:20:53 raspberrypi systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
      24. Nov 02 15:20:54 raspberrypi systemd[1]: php7.0-fpm.service: Main process exited, code=killed, status=4/ILL
      25. Nov 02 15:20:54 raspberrypi systemd[1]: Failed to start The PHP 7.0 FastCGI Process Manager.
      26. Nov 02 15:20:54 raspberrypi systemd[1]: php7.0-fpm.service: Unit entered failed state.
      27. Nov 02 15:20:54 raspberrypi systemd[1]: php7.0-fpm.service: Failed with result 'signal'.
      28. dpkg: error processing package php7.0-fpm (--configure):
      29. subprocess installed post-installation script returned error exit status 1
      30. dpkg: dependency problems prevent configuration of php-fpm:
      31. php-fpm depends on php7.0-fpm; however:
      32. Package php7.0-fpm is not configured yet.
      33. dpkg: error processing package php-fpm (--configure):
      34. dependency problems - leaving unconfigured
      35. dpkg: dependency problems prevent configuration of openmediavault:
      36. openmediavault depends on php-fpm; however:
      37. Package php-fpm is not configured yet.
      38. Package php7.0-fpm which provides php-fpm is not configured yet.
      39. dpkg: error processing package openmediavault (--configure):
      40. dependency problems - leaving unconfigured
      41. Errors were encountered while processing:
      42. php7.0-fpm
      43. php-fpm
      44. openmediavault
      45. E: Sub-process /usr/bin/dpkg returned an error code (1)
      46. Hit:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease
      47. Hit:2 http://packages.openmediavault.org/public arrakis InRelease
      48. Hit:3 http://archive.raspberrypi.org/debian stretch InRelease
      49. Reading package lists... Done
      50. Reading package lists... Done
      51. Building dependency tree
      52. Reading state information... Done
      53. postfix is already the newest version (3.1.8-0+deb9u1).
      54. openmediavault is already the newest version (4.1.12).
      55. 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
      56. 3 not fully installed or removed.
      57. After this operation, 0 B of additional disk space will be used.
      58. Setting up php7.0-fpm (7.0.30-0+deb9u1) ...
      59. Job for php7.0-fpm.service failed because a fatal signal was delivered to the control process.
      60. See "systemctl status php7.0-fpm.service" and "journalctl -xe" for details.
      61. invoke-rc.d: initscript php7.0-fpm, action "start" failed.
      62. * php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager
      63. Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)
      64. Active: failed (Result: signal) since Fri 2018-11-02 15:22:41 UTC; 225ms ago
      65. Docs: man:php-fpm7.0(8)
      66. Process: 25442 ExecStart=/usr/sbin/php-fpm7.0 --nodaemonize --fpm-config /etc/php/7.0/fpm/php-fpm.conf (code=killed, signal=ILL)
      67. Main PID: 25442 (code=killed, signal=ILL)
      68. Nov 02 15:22:40 raspberrypi systemd[1]: Starting The PHP 7.0 FastCGI Process Manager...
      69. Nov 02 15:22:41 raspberrypi systemd[1]: php7.0-fpm.service: Main process exited, code=killed, status=4/ILL
      70. Nov 02 15:22:41 raspberrypi systemd[1]: Failed to start The PHP 7.0 FastCGI Process Manager.
      71. Nov 02 15:22:41 raspberrypi systemd[1]: php7.0-fpm.service: Unit entered failed state.
      72. Nov 02 15:22:41 raspberrypi systemd[1]: php7.0-fpm.service: Failed with result 'signal'.
      73. dpkg: error processing package php7.0-fpm (--configure):
      74. subprocess installed post-installation script returned error exit status 1
      75. dpkg: dependency problems prevent configuration of php-fpm:
      76. php-fpm depends on php7.0-fpm; however:
      77. Package php7.0-fpm is not configured yet.
      78. dpkg: error processing package php-fpm (--configure):
      79. dependency problems - leaving unconfigured
      80. dpkg: dependency problems prevent configuration of openmediavault:
      81. openmediavault depends on php-fpm; however:
      82. Package php-fpm is not configured yet.
      83. Package php7.0-fpm which provides php-fpm is not configured yet.
      84. dpkg: error processing package openmediavault (--configure):
      85. dependency problems - leaving unconfigured
      86. Errors were encountered while processing:
      87. php7.0-fpm
      88. php-fpm
      89. openmediavault
      90. E: Sub-process /usr/bin/dpkg returned an error code (1)
      91. /usr/sbin/omv-initsystem: 24: .: Can't open /etc/default/openmediavault
      Display All
      Is there is something I miss ? is it possible to install OVM 4 on a rpi B+ ?



      thans for your help !
      Arno
    • arnobaze wrote:

      Is there is something I miss ? is it possible to install OVM 4 on a rpi B+ ?
      ​It says in the readme where you downloaded the image that it only supports the Raspberry Pi 2B, 3B and 3B+​. Not really. You could compile a few packages and maybe make it work but it is so slow, it is pointless.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!