docker installation gives error

    • OMV 4.x
    • docker installation gives error

      I watched and applied the steps but each time the docker installation failed.


      device: raspberry 3b +
      current version: OMV_4_Raspberry_Pi_2_3_3Plus.img

      I couldn't find a solution in the forums. omv updated + ok
      openmediavault-omvextrasorg_latest_all4 I've installed + ok
      docker repo active + okey
      but
      openmediavault-docker-gui 4.0.1 installation is giving an error.
      error picture:
      [IMG:https://image.ibb.co/mu0kSq/omv2.jpg]
      [IMG:https://image.ibb.co/kKGQSq/omv1.jpg] ;(
      please help
    • do you try to install docker plugin or docker ce plugin?
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • raulfg3 wrote:

      do you try to install docker plugin or docker ce plugin?
      [IMG:https://image.ibb.co/mVUzoV/q1.jpg]

      I checked the above checkbox, started the installation and finished with the following report.

      But it is not installed in the list of add-ons. I have to re-install. I'm having the same process again but the result is negative.

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following additional packages will be installed:
      5. etherwake libnet1 libpcap0.8 nast wakeonlan
      6. The following NEW packages will be installed:
      7. etherwake libnet1 libpcap0.8 nast openmediavault-wol wakeonlan
      8. 0 upgraded, 6 newly installed, 0 to remove and 1 not upgraded.
      9. Need to get 279 kB of archives.
      10. After this operation, 784 kB of additional disk space will be used.
      11. Get:1 http://cdn-fastly.deb.debian.org/debian stretch/main armhf libnet1 armhf 1.1.6+dfsg-3 [54.6 kB]
      12. Get:2 http://cdn-fastly.deb.debian.org/debian stretch/main armhf etherwake armhf 1.09-4+b1 [9012 B]
      13. Get:3 http://cdn-fastly.deb.debian.org/debian stretch/main armhf libpcap0.8 armhf 1.8.1-3 [124 kB]
      14. Get:6 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stretch/main armhf openmediavault-wol all 3.4.1 [17.2 kB]
      15. Get:4 http://cdn-fastly.deb.debian.org/debian stretch/main armhf nast armhf 0.2.0-6.1+b1 [62.6 kB]
      16. Get:5 http://cdn-fastly.deb.debian.org/debian stretch/main armhf wakeonlan all 0.41-11 [11.5 kB]
      17. Fetched 279 kB in 1s (269 kB/s)
      18. Selecting previously unselected package libnet1:armhf.
      19. (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 51381 files and directories currently installed.)
      20. Preparing to unpack .../0-libnet1_1.1.6+dfsg-3_armhf.deb ...
      21. Unpacking libnet1:armhf (1.1.6+dfsg-3) ...
      22. Selecting previously unselected package etherwake.
      23. Preparing to unpack .../1-etherwake_1.09-4+b1_armhf.deb ...
      24. Unpacking etherwake (1.09-4+b1) ...
      25. Selecting previously unselected package libpcap0.8:armhf.
      26. Preparing to unpack .../2-libpcap0.8_1.8.1-3_armhf.deb ...
      27. Unpacking libpcap0.8:armhf (1.8.1-3) ...
      28. Selecting previously unselected package nast.
      29. Preparing to unpack .../3-nast_0.2.0-6.1+b1_armhf.deb ...
      30. Unpacking nast (0.2.0-6.1+b1) ...
      31. Selecting previously unselected package wakeonlan.
      32. Preparing to unpack .../4-wakeonlan_0.41-11_all.deb ...
      33. Unpacking wakeonlan (0.41-11) ...
      34. Selecting previously unselected package openmediavault-wol.
      35. Preparing to unpack .../5-openmediavault-wol_3.4.1_all.deb ...
      36. Unpacking openmediavault-wol (3.4.1) ...
      37. Setting up libnet1:armhf (1.1.6+dfsg-3) ...
      38. Setting up etherwake (1.09-4+b1) ...
      39. Processing triggers for libc-bin (2.24-11+deb9u3) ...
      40. Setting up wakeonlan (0.41-11) ...
      41. Processing triggers for man-db (2.7.6.1-2) ...
      42. Processing triggers for openmediavault (4.1.13-1) ...
      43. Restarting engine daemon ...
      44. Setting up libpcap0.8:armhf (1.8.1-3) ...
      45. Setting up nast (0.2.0-6.1+b1) ...
      46. Setting up openmediavault-wol (3.4.1) ...
      47. Updating configuration database ...
      48. Processing triggers for libc-bin (2.24-11+deb9u3) ...
      49. Processing triggers for openmediavault (4.1.13-1) ...
      50. Updating locale files ...
      51. Updating file permissions ...
      52. Purging internal cache ...
      53. Restarting engine daemon ...
      54. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7626c468>
      55. Traceback (most recent call last):
      56. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      57. TypeError: 'NoneType' object is not callable
      58. Exception ignored in: <function WeakValueDictionary.__init__.<locals>.remove at 0x7626c468>
      59. Traceback (most recent call last):
      60. File "/usr/lib/python3.5/weakref.py", line 117, in remove
      61. TypeError: 'NoneType' object is not callable
      62. Tamamlandı...
      Display All
    • you install WOL = Wake on LAN so it's normal that docker do not work, please select the apropiate docker repo and the apropiate plugin:
      Images
      • 2.jpg

        44.3 kB, 779×360, viewed 29 times
      • 1.jpg

        53.19 kB, 702×460, viewed 31 times
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • raulfg3 wrote:

      you install WOL = Wake on LAN so it's normal that docker do not work, please select the apropiate docker repo and the apropiate plugin:
      1) I used "etcher" and installed OMV_4_Raspberry_Pi_2_3_3Plus.img on the sd card.
      2) I logged in using admin/openmediavault.
      3) I turned on the Docker-CE repo from OMV-Extras.
      4) The Docker-gui installation listed in the plug-ins failed.

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following additional packages will be installed:
      5. containerd.io docker-ce docker-ce-cli imagemagick-6-common libfftw3-double3
      6. liblcms2-2 liblqr-1-0 libmagickcore-6.q16-3 libmagickwand-6.q16-3
      7. libopenjp2-7 omvextras-common php-curl php-imagick php-symfony-class-loader
      8. php-symfony-polyfill-apcu php7.0-curl
      9. Suggested packages:
      10. libfftw3-bin libfftw3-dev liblcms2-utils libmagickcore-6.q16-3-extra
      11. Recommended packages:
      12. aufs-tools cgroupfs-mount | cgroup-lite pigz ghostscript gsfonts
      13. ttf-dejavu-core
      14. The following NEW packages will be installed:
      15. containerd.io docker-ce docker-ce-cli imagemagick-6-common libfftw3-double3
      16. liblcms2-2 liblqr-1-0 libmagickcore-6.q16-3 libmagickwand-6.q16-3
      17. libopenjp2-7 omvextras-common openmediavault-docker-gui php-curl php-imagick
      18. php-symfony-class-loader php-symfony-polyfill-apcu php7.0-curl
      19. 0 upgraded, 17 newly installed, 0 to remove and 29 not upgraded.
      20. Need to get 32.6 MB of archives.
      21. After this operation, 157 MB of additional disk space will be used.
      22. Get:1 http://security.debian.org stretch/updates/main armhf liblcms2-2 armhf 2.8-4+deb9u1 [120 kB]
      23. Get:3 http://security.debian.org stretch/updates/main armhf imagemagick-6-common all 8:6.9.7.4+dfsg-11+deb9u6 [184 kB]
      24. Get:10 http://security.debian.org stretch/updates/main armhf libmagickcore-6.q16-3 armhf 8:6.9.7.4+dfsg-11+deb9u6 [1609 kB]
      25. Get:2 http://cdn-fastly.deb.debian.org/debian stretch/main armhf liblqr-1-0 armhf 0.4.2-2+b2 [21.6 kB]
      26. Get:11 https://download.docker.com/linux/debian stretch/stable armhf containerd.io armhf 1.2.0~rc.2-1 [10.7 MB]
      27. Get:4 http://cdn-fastly.deb.debian.org/debian stretch/main armhf libfftw3-double3 armhf 3.3.5-3 [435 kB]
      28. Get:12 http://security.debian.org stretch/updates/main armhf libmagickwand-6.q16-3 armhf 8:6.9.7.4+dfsg-11+deb9u6 [415 kB]
      29. Get:13 http://security.debian.org stretch/updates/main armhf php-symfony-class-loader all 2.8.7+dfsg-1.3+deb9u1 [24.6 kB]
      30. Get:14 https://dl.bintray.com/openmediavault-plugin-developers/arrakis stretch/main armhf omvextras-common all 4.0.1 [6582 B]
      31. Get:5 http://cdn-fastly.deb.debian.org/debian stretch/main armhf libopenjp2-7 armhf 2.1.2-1.1+deb9u2 [110 kB]
      32. Get:15 https://dl.bintray.com/openmediavault-plugin-developers/arrakis-docker stretch/main armhf openmediavault-docker-gui all 4.0.1 [58.4 kB]
      33. Get:6 http://cdn-fastly.deb.debian.org/debian stretch/main armhf php-symfony-polyfill-apcu all 1.2.0-1 [4544 B]
      34. Get:7 http://cdn-fastly.deb.debian.org/debian stretch/main armhf php7.0-curl armhf 7.0.30-0+deb9u1 [24.5 kB]
      35. Get:8 http://cdn-fastly.deb.debian.org/debian stretch/main armhf php-curl all 1:7.0+49 [5048 B]
      36. Get:9 http://cdn-fastly.deb.debian.org/debian stretch/main armhf php-imagick armhf 3.4.3~rc2-2 [82.6 kB]
      37. Get:16 https://download.docker.com/linux/debian stretch/stable armhf docker-ce-cli armhf 5:18.09.0~3-0~debian-stretch [8081 kB]
      38. Get:17 https://download.docker.com/linux/debian stretch/stable armhf docker-ce armhf 5:18.09.0~3-0~debian-stretch [10.8 MB]
      39. Fetched 32.6 MB in 13s (2483 kB/s)
      40. Selecting previously unselected package liblqr-1-0:armhf.
      41. (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 51305 files and directories currently installed.)
      42. Preparing to unpack .../00-liblqr-1-0_0.4.2-2+b2_armhf.deb ...
      43. Unpacking liblqr-1-0:armhf (0.4.2-2+b2) ...
      44. Selecting previously unselected package libfftw3-double3:armhf.
      45. Preparing to unpack .../01-libfftw3-double3_3.3.5-3_armhf.deb ...
      46. Unpacking libfftw3-double3:armhf (3.3.5-3) ...
      47. Selecting previously unselected package liblcms2-2:armhf.
      48. Preparing to unpack .../02-liblcms2-2_2.8-4+deb9u1_armhf.deb ...
      49. Unpacking liblcms2-2:armhf (2.8-4+deb9u1) ...
      50. Selecting previously unselected package libopenjp2-7:armhf.
      51. Preparing to unpack .../03-libopenjp2-7_2.1.2-1.1+deb9u2_armhf.deb ...
      52. Unpacking libopenjp2-7:armhf (2.1.2-1.1+deb9u2) ...
      53. Selecting previously unselected package imagemagick-6-common.
      54. Preparing to unpack .../04-imagemagick-6-common_8%3a6.9.7.4+dfsg-11+deb9u6_all.deb ...
      55. Unpacking imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u6) ...
      56. Selecting previously unselected package libmagickcore-6.q16-3:armhf.
      57. Preparing to unpack .../05-libmagickcore-6.q16-3_8%3a6.9.7.4+dfsg-11+deb9u6_armhf.deb ...
      58. Unpacking libmagickcore-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      59. Selecting previously unselected package libmagickwand-6.q16-3:armhf.
      60. Preparing to unpack .../06-libmagickwand-6.q16-3_8%3a6.9.7.4+dfsg-11+deb9u6_armhf.deb ...
      61. Unpacking libmagickwand-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      62. Selecting previously unselected package containerd.io.
      63. Preparing to unpack .../07-containerd.io_1.2.0~rc.2-1_armhf.deb ...
      64. Unpacking containerd.io (1.2.0~rc.2-1) ...
      65. Selecting previously unselected package docker-ce-cli.
      66. Preparing to unpack .../08-docker-ce-cli_5%3a18.09.0~3-0~debian-stretch_armhf.deb ...
      67. Unpacking docker-ce-cli (5:18.09.0~3-0~debian-stretch) ...
      68. Selecting previously unselected package docker-ce.
      69. Preparing to unpack .../09-docker-ce_5%3a18.09.0~3-0~debian-stretch_armhf.deb ...
      70. Unpacking docker-ce (5:18.09.0~3-0~debian-stretch) ...
      71. Selecting previously unselected package php-symfony-polyfill-apcu.
      72. Preparing to unpack .../10-php-symfony-polyfill-apcu_1.2.0-1_all.deb ...
      73. Unpacking php-symfony-polyfill-apcu (1.2.0-1) ...
      74. Selecting previously unselected package php-symfony-class-loader.
      75. Preparing to unpack .../11-php-symfony-class-loader_2.8.7+dfsg-1.3+deb9u1_all.deb ...
      76. Unpacking php-symfony-class-loader (2.8.7+dfsg-1.3+deb9u1) ...
      77. Selecting previously unselected package omvextras-common.
      78. Preparing to unpack .../12-omvextras-common_4.0.1_all.deb ...
      79. Unpacking omvextras-common (4.0.1) ...
      80. Selecting previously unselected package php7.0-curl.
      81. Preparing to unpack .../13-php7.0-curl_7.0.30-0+deb9u1_armhf.deb ...
      82. Unpacking php7.0-curl (7.0.30-0+deb9u1) ...
      83. Selecting previously unselected package php-curl.
      84. Preparing to unpack .../14-php-curl_1%3a7.0+49_all.deb ...
      85. Unpacking php-curl (1:7.0+49) ...
      86. Selecting previously unselected package php-imagick.
      87. Preparing to unpack .../15-php-imagick_3.4.3~rc2-2_armhf.deb ...
      88. Unpacking php-imagick (3.4.3~rc2-2) ...
      89. Selecting previously unselected package openmediavault-docker-gui.
      90. Preparing to unpack .../16-openmediavault-docker-gui_4.0.1_all.deb ...
      91. Unpacking openmediavault-docker-gui (4.0.1) ...
      92. Setting up imagemagick-6-common (8:6.9.7.4+dfsg-11+deb9u6) ...
      93. Setting up libopenjp2-7:armhf (2.1.2-1.1+deb9u2) ...
      94. Setting up containerd.io (1.2.0~rc.2-1) ...
      95. Created symlink /etc/systemd/system/multi-user.target.wants/containerd.service -> /lib/systemd/system/containerd.service.
      96. Setting up liblcms2-2:armhf (2.8-4+deb9u1) ...
      97. Setting up php7.0-curl (7.0.30-0+deb9u1) ...
      98. Creating config file /etc/php/7.0/mods-available/curl.ini with new version
      99. Setting up libfftw3-double3:armhf (3.3.5-3) ...
      100. >>> *************** Error ***************
      101. Bad Gateway
      102. <<< *************************************
      103. Processing triggers for php7.0-fpm (7.0.30-0+deb9u1) ...
      104. Setting up liblqr-1-0:armhf (0.4.2-2+b2) ...
      105. Processing triggers for libc-bin (2.24-11+deb9u3) ...
      106. Setting up php-symfony-polyfill-apcu (1.2.0-1) ...
      107. Processing triggers for man-db (2.7.6.1-2) ...
      108. Processing triggers for openmediavault (4.1.7) ...
      109. Restarting engine daemon ...
      110. Setting up docker-ce-cli (5:18.09.0~3-0~debian-stretch) ...
      111. Setting up docker-ce (5:18.09.0~3-0~debian-stretch) ...
      112. update-alternatives: using /usr/bin/dockerd-ce to provide /usr/bin/dockerd (dockerd) in auto mode
      113. Created symlink /etc/systemd/system/multi-user.target.wants/docker.service -> /lib/systemd/system/docker.service.
      114. Setting up libmagickcore-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      115. Setting up php-curl (1:7.0+49) ...
      116. Setting up php-symfony-class-loader (2.8.7+dfsg-1.3+deb9u1) ...
      117. Setting up libmagickwand-6.q16-3:armhf (8:6.9.7.4+dfsg-11+deb9u6) ...
      118. Setting up omvextras-common (4.0.1) ...
      119. Setting up php-imagick (3.4.3~rc2-2) ...
      120. Processing triggers for openmediavault (4.1.7) ...
      121. Updating file permissions ...
      122. Purging internal cache ...
      123. Restarting engine daemon ...
      124. Setting up openmediavault-docker-gui (4.0.1) ...
      125. Initialize configuration
      126. sed: can't read /etc/default/docker: No such file or directory
      127. dpkg: error processing package openmediavault-docker-gui (--configure):
      128. subprocess installed post-installation script returned error exit status 2
      129. Processing triggers for libc-bin (2.24-11+deb9u3) ...
      130. Processing triggers for openmediavault (4.1.7) ...
      131. Restarting engine daemon ...
      132. Errors were encountered while processing:
      133. openmediavault-docker-gui
      134. >>> *************** Error ***************
      135. <<< *************************************
      Display All
    • perhaps the same problem that show here??:

      Latest Docker plugin update

      Docker plugin - After the last update it does not start

      but not sure, your error is: can't read /etc/default/docker: No such file or directory

      But I do not know why is not written to SD , perhaps owner problem or you do not have enough right to write to sd?.

      or perhaps your SD is Read-only

      Please revise it.
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife

      The post was edited 1 time, last by raulfg3 ().

    • it didn't work, i don't know what to do. I've been dealing for days but didn't get positive results.
      Samsung 32 gb class 10 I have a sd card, I write with "etcher" program, do I need to make a different setting for write permission?


      raulfg3 wrote:

      perhaps the same problem that show here??:

      Latest Docker plugin update

      Docker plugin - After the last update it does not start

      but not sure, your error is: can't read /etc/default/docker: No such file or directory

      But I do not know why is not written to SD , perhaps owner problem or you do not have enough right to write to sd?.

      or perhaps your SD is Read-only

      Please revise it.
    • revise your SD @TKaiser always say that is really important
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • I also have a brand new, clean install of OMV4 - on an Odroid HC1 (XU4) - and I'm getting the same error message as soon as I try to install Docker.

      I log in, change my admin password, go to Update Management, check all and update.
      Then I go to the OMV-Extras in the sidebar and update there too.
      Then, and only then, do I highlight the Docker CE repo that's already in there, select 'Edit' and Enable, Save etc.
      This all works fine.

      But then I go to Plugins and scroll down to the Docker one - openmediavault-docker-gui 4.1, select it and hit install.

      This is when I get the same error message as outlined in the original post on this thread.

      Am I doing something wrong? I am very new to OMV but thought I'd followed the instructions pretty well (the much-quoted online tutorial videos appear to be for OMV3, in which OMV-Extras needs to be manually installed - it's there from initial boot-up in the OMV4 image for the Odroid HC1/XU4.

      Regards to all,

      Discy
    • Users Online 1

      1 Guest