Plex installation on ARM dedicated serveur

    • OMV 4.x
    • Plex installation on ARM dedicated serveur


      Here are my system information:
      Version: 4.1.13-1 (Arrakis)
      Processor: ARMv7 Processor rev 1 (v7l)
      Kernel: Linux 4.9.124-armada375
      Dedicated server at SoYouStart:

      The server is not a NAS in my local network and is accessible via a public domain, which I will name "".

      I followed the installation and configuration videos of Techno Dad Life:

      I set up a Let's Encrypt SSL certificate and access the admin interface correctly.

      The installation of the OMV-Extras plugin and Docker service went smoothly.

      However, the installation of Plex is more complicated...
      The video uses the amd64 version with "linuxserver/plex", I was careful to use the arm version with "lsioarmhf/plex" and that I will do with all the plugins.

      When the container activates, it executes with a multitude of errors:

      Source Code

      1. Illegal instruction
      2. 6 3000 / config / Library / Application Support
      3. 8192
      and uses the CPU at 100%.
      On the other hand, the plugin is not accessible via the interface:

      with this message: ERR_CONNECTION_REFUSED

      There is no firewall rule defined at first. I will add them later when the services will work.

      Do you have an idea of the problem :?:

      Thank you
    • tkaiser wrote:

      mxr wrote:

      At the moment my best guess is that the problem could be caused by NetworkManager
      Why? Since NM is evil?
      When I did a quick google search for the issue described above the solution seems to be to disable IPv6 in the Docker container.
      Yes, it seems to be related to IPv6. I will try disabling IPv6 in the container as you say. So far I only tried disabling IPv6 in the host.

      I'm not saying that NM is evil. It just takes some time to get used to it and figure out how the configuring works.
    • I tried to disable IPv6 in the container, but without much success. Would it even make a difference if host networking mode is used?

      I went back and tried to disable IPv6 completely in the host, but without much success either. Using "armbian-config" I tried disabling IPv6, but after reboot NM created a new Wired Connection 2 and shows again an inet6 line when running "ip addr show".