Error message when adding a repo

    • OMV 4.x
    • Error message when adding a repo

      I get this error when I try to activate a new repo (e.g. OMV-Extras.org testing)

      Any hints?

      Source Code

      1. Error #0:
      2. OMV\ExecException: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; omv-mkconf apt 2>&1' with exit code '1': Warning: apt-key output should not be parsed (stdout is not a terminal)
      3. Executing: /tmp/apt-key-gpghome.COGedT56Lr/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 9dc858229fc7dd38854ae2d88d81803c0ebfcd88
      4. gpg: cannot open '/dev/tty': No such device or address
      5. run-parts: /usr/share/openmediavault/mkconf/apt.d/15omvextras exited with return code 2 in /usr/share/php/openmediavault/system/process.inc:182
      6. Stack trace:
      7. #0 /usr/share/openmediavault/engined/module/apt.inc(37): OMV\System\Process->execute()
      8. #1 /usr/share/openmediavault/engined/rpc/config.inc(168): OMVModuleApt->applyConfig()
      9. #2 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      10. #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      11. #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      12. #5 /usr/share/openmediavault/engined/rpc/omvextrasorg.inc(96): OMV\Rpc\Rpc::call('Config', 'applyChanges', Array, Array)
      13. #6 [internal function]: OMVRpcServiceOmvExtras->setRepo(Array, Array)
      14. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      15. #8 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('setRepo', Array, Array)
      16. #9 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('OmvExtras', 'setRepo', Array, Array, 1)
      17. #10 {main}
      Display All
    • Nixda wrote:

      Any hints?
      You need to update to the latest omv-extras. I just fixed this in a release a couple days ago.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Nixda wrote:

      You need to update the omv-extras from github
      Why? It is in the repo.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Nixda wrote:

      Not sure. Somehow this way it did not work (instead I updated beforehand).

      Cannot fall back, so I can not check again.
      I don't expect you to test. Just letting you know that the version in the repo is the exact same package that is on github.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!