is plex working in omv4?

    • OMV 4.x
    • richprim wrote:

      Ok about Docker, never used it so this should be a new experience

      Rich Prim
      please have a llok at: Installation and Setup Videos - Beginning, Intermediate and Advanced
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • iNTiGOD wrote:

      You won’t ever look back running plex on docker. Updating plex is so much easier (eg restart plex running in docker) and if you want the latest builds they are available quickly.

      The only thing I believe that isn’t supported is hardware decoding (server side).



      You just need to edit some files to fix that.

      Open shellinabox


      Source Code

      1. nano /etc/openmediavault/config.xml




      Hit F6 to search. At the bottom left look for the search line.

      Type in: mntent

      Hit enter.

      It should look like this.


      Source Code

      1. <mntent>
      2. <uuid>f767ee54-eb3a-44c5-b159-1840a289c84b</uuid>
      3. <fsname>/dev/disk/by-label/VOLUME1</fsname>
      4. <dir>/srv/dev-disk-by-label-VOLUME1</dir>
      5. <type>ext4</type>
      6. <opts>defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
      7. <freq>0</freq>
      8. <passno>2</passno>
      9. <hidden>0</hidden>
      10. </mntent>
      Change the opts line removing the noexec, it should look like this:


      Source Code

      1. <opts>defaults,nofail,user_xattr,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
      Save the file with CTRL+X, then Y, then enter. That saves the file.



      Run in shellinabox.

      Source Code

      1. omv-mkconf fstab
      Reboot the system.



      Check that the noexec flag is no longer present for that particular mount.

      Open shellinabox again.


      Source Code

      1. cat /proc/mounts
      Done. You should be able to transcode and access your Plex outside of your network. :thumbsup:
      Build, Learn, Create.

      How to Videos for OMV

      Post any questions to the forum, so others can benefit from your curiosity. :thumbsup:

      The post was edited 3 times, last by TechnoDadLife ().

    • is plex working in omv4?

      TechnoDadLife wrote:

      iNTiGOD wrote:

      You won’t ever look back running plex on docker. Updating plex is so much easier (eg restart plex running in docker) and if you want the latest builds they are available quickly.

      The only thing I believe that isn’t supported is hardware decoding (server side).



      You just need to edit some files to fix that.

      Open shellinabox


      Source Code

      1. nano /etc/openmediavault/config.xml




      Hit F6 to search. At the bottom left look for the search line.

      Type in: mntent

      Hit enter.

      It should look like this.


      Source Code

      1. <mntent>
      2. <uuid>f767ee54-eb3a-44c5-b159-1840a289c84b</uuid>
      3. <fsname>/dev/disk/by-label/VOLUME1</fsname>
      4. <dir>/srv/dev-disk-by-label-VOLUME1</dir>
      5. <type>ext4</type>
      6. <opts>defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
      7. <freq>0</freq>
      8. <passno>2</passno>
      9. <hidden>0</hidden>
      10. </mntent>
      Change the opts line removing the noexec, it should look like this:


      Source Code

      1. <opts>defaults,nofail,user_xattr,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
      Save the file with CTRL+X, then Y, then enter. That saves the file.



      Run in shellinabox.

      Source Code

      1. omv-mkconf fstab
      Reboot the system.



      Check that the noexec flag is no longer present for that particular mount.

      Open shellinabox again.


      Source Code

      1. cat /proc/mounts
      Done. You should be able to transcode and access your Plex outside of your network. :thumbsup:


      Thanks mate.
      Looking forward to trying this. I’ve always been able to access plex from the outside network but read somewhere hardware decoding isn’t possible. Will try it out (might breath new life into my proliant n40L).