Boot pauses for 'maintenance' RockPro64

    • OMV 4.x
    • Boot pauses for 'maintenance' RockPro64

      I've just installed OMV (4.1.8.2-1) on a RockPro64. I finally got it running and seemingly robust. There are two HDDs attached via SATA running in RAID1 mode. Because everything seemed to be ticking along fine, I screwed everything into the case and... wouldn't boot.

      Well, actually, the network interface came up. I could ping the computer. But I couldn't SSH to it and there was no access via the web interface.

      I tried three or four times with the same result. In the end, I tried with a monitor and keyboard attached and found that there was a message on the console telling me to log in as root for maintenance or press Ctrl-D to continue.

      The problem is that I'm planning to run this headless. Having it pause like that is not useful.

      What causes this? I found that one of the two disks had disappeared from the raid setup and I had to use the recover option. But the system is booting from SD card. Any idea how I can stop this from happening in the future?
    • I booted again and got the same problem. In syslog, it complained about a non-existent drive in fstab. OMV had created the following entries:

      /dev/disk/by-label/media /srv/dev-disk-by-label-media ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2/srv/dev-disk-by-label-media/video /export/video none bind,nofail 0 0

      But it was complaining that the mount point for the second entry doesn't exist. I do have a shared folder called 'video' on the raid and the directory /export/video/ does exist. I tried commenting this line out. On the next boot there were no complaints of any kind in /var/log/syslog but the system still paused and required a Ctrl-D to continue.

      In daemon.log, I get a whole bunch of messages about:
      'mountpoint_srv_dev-disk-by-label-media' status failed (1) -- /srv/dev-disk-by-label-media is not a mountpoint

      The directory /srv/dev-disk-by-label-media certainly exists. And /dev/disk/by-label/media is a symlink to /dev/md0, my raid device. So I'm not sure why this is refusing to mount.

      In brief, I'm getting complaints that both the mount points specified by fstab don't exist when, in fact, they do.

      So the raid is not being mounted on boot - if I mount it manually from within the web interface it starts working normally and is reachable. So I'm thinking fstab is borked in some way, I just can't work out which way.
    • I'm not sure this is a RockPro64 issue. It seems to be an issue with the fstab entries created by OMV which the OS is claiming are not valid mount points.

      When I mount the raid device (/dev/md0) from within the OMV web interface, it's mounted at /srv/dev-disk-by-label-media - exactly the same location that the logs are saying is not a mount point. Huh?
    • Well I ended up re-installing OMV. Not just because of this issue - I've been running the OS from an SD card and I came into possession of an eMMC (and couldn't just copy the image from one to the other - don't ask).

      Anyhoo, on first boot up, everything ran fine, with no pausing or Ctrl-D'ing necessary. Just booted right on up. The hard drives were recognised as a raid configuration, although the raid (/dev/md127) wasn't mounted. Did a bunch of configuration. When I went to reboot - guess what? Yup, had to attach a keyboard and Ctrl-D.

      In syslog there was a message about the mountpoint again, but I'm not convinced this is where it's pausing for the keyboard input. The message was right at the end of syslog. But I've run out of time to mess around with this. I'm resigned to having to attach a keyboard and hitting Ctrl-D, then going in via the web interface and mounting the raid. Selah.