installation rerun? (motherboard; intel i219-v lan issue) partial fix?

    • OMV 4.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • installation rerun? (motherboard; intel i219-v lan issue) partial fix!

      Is it possible to rerun the installation from the usb boot disk, after the installation is complete?

      My installation couldnt see the lan adapter and consequently didn't finish cleanly... using OMV first aid, I have a shell and a working lan adapter! but incomplete file system... (errors when trying to upgrade / update, docker fails etc.)
      rerunning the instalation after a usb boot gives the same error with the LAN card, (intel 219-v, on the motherboard which seems quite widespread..) but running from the "installed" version gives me a shell and I can access via the management console. just dont have enough skills to do this manually as this is my first foray into the dark arts.

      To get the card working; do the instal, ignore the warning about lan card not found get as far as possible and reboot... run omv-firstaid, option 1 lan card. yes to the first option no to the rest. reboot.. it will still fail. rerun omv first aid, this time yes to everything, wake on lan, everything. it will chew on it for a while and then fail. reboot and run a third time, setting everything as you want it... reboot. At this point my lan adapter was recognised and I could run the management console from another PC.

      the install seems to work ok, but there are files missing, disks not mounted / partitioned etc. hence the question, I'm hoping that as the instal can now see the card, a rerun of the installation program will continue to see it!
    • further to this, I fitted a TP netwok card and ran the instal again and all worked cleanly... and then saw the intel card! looks like there may be an issue in the instal routines regarding the intel cards??????? I dont know enough about this to know if that is the case, but intel chips on the motherboard and many flavours of linux dont get on well together during the installation phase.

      Now all I have to find is the way to run the 2 network cards, the motherboard i219-v and the TP in parrallel and I'm a happy bunny. (any pointers greatfully received!)