Windows explorer access to openmediavault-webdav not working?

    • OMV 4.x
    • Windows explorer access to openmediavault-webdav not working?

      Hi,
      I just installed the webdav-plugin 4.0 in my OMV 4.1.14, configured it and wanted to connect to the webdav share with windows explorer. However, this is giving me an error (as usual in Windows, the error message is not very comprehensive). I checked the nginx access log and found the following:

      Source Code

      1. ::ffff:192.168.1.49 - - [02/Dec/2018:00:27:29 +0100] "OPTIONS /webdav HTTP/1.1" 405 166 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
      2. ::ffff:192.168.1.49 - - [02/Dec/2018:00:27:36 +0100] "OPTIONS / HTTP/1.1" 405 166 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
      3. ::ffff:192.168.1.49 - - [02/Dec/2018:00:27:36 +0100] "PROPFIND /webdav HTTP/1.1" 405 166 "-" "Microsoft-WebDAV-MiniRedir/6.1.7601"
      Both, OPTIONS and PROPFIND requests are rejected by nginx with 405 "Method Not Allowed". Is there anything I can do to get this working?
    • Just tried it on my test VM and it is working. What error is windows giving you? Did you add your user to the webdav-users group? Are the permissions on the shared folder open enough for the webdav-users group to access it?
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!