Cannot used authenticated FTP/SMB/NFS

    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Cannot used authenticated FTP/SMB/NFS

      So, I've had this server running with OMV for a couple of months now with no problem at all. It's been working nicely, and I had everything set up as I wanted (it hosts a basic website and stores a bunch of video files which were accessible over SMB shares).

      However, the other day I noticed I couldn't access the SMB shares that require authentication anymore. I did a bit of research and came to the conclusion that it's Microsoft's fault (could be an incorrect assumption) with their newest Windows update. I thought I'd write it off as a loss and set up NFS shares. I didn't have much success with that either but, I could still access my files over SCP so I gave up.

      Then I thought of setting up FTP. And no. Didn't work. I thought maybe it was my password, so I changed it. Still wouldn't log me in (the error message was saying the creds were wrong but, I know they weren't).

      The problem isn't with the protocols themselves, I can still access my files whilst allowing Anonymous connections. But, I don't want Anonymous connections (I don't want my family members to be able to modify the website files, only view the videos). I've even checked the "permit root" login on the FTP service but, I couldn't even authenticate then!

      So, I'm thinking there's a problem with the authentication that these services use somehow. But, even then, there should be a problem with SSH, no?

      I'm honestly at a loss here. I can't think of what the problem could be or why the issues are suddenly a thing (I only noticed it a couple of days ago).
    • Take a look at this How-To. M$ has been up to their usual security shenanigans, where they're trying to secure your local LAN, from you.

      Specifically look at the security policy change near the bottom of the post titled: Update 11/26/18 - SMB Guest access
      (The impact of the policy change M$ pushed out may have had broader impacts than were originally thought.)

      One way or the other, please follow up with whether it worked or not.

      Video Guides :!: New User Guide :!: Docker Guides :!: Pi-hole in Docker
      Good backup takes the "drama" out of computing.
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      OMV 4.1.13, Intel Server SC5650HCBRP, 32GB ECC, 16GB USB boot, UnionFS+SNAPRAID
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
    • So it wasn't necessary to change the policy setting, as outlined at the bottom? -> Update 11/26/18 - SMB Guest access

      Just the items at the top?

      (This is just for clarification, for other forum/Win10 users.)

      Video Guides :!: New User Guide :!: Docker Guides :!: Pi-hole in Docker
      Good backup takes the "drama" out of computing.
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      OMV 4.1.13, Intel Server SC5650HCBRP, 32GB ECC, 16GB USB boot, UnionFS+SNAPRAID
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
    • flmaxey wrote:

      So it wasn't necessary to change the policy setting, as outlined at the bottom? -> Update 11/26/18 - SMB Guest access

      Just the items at the top?

      (This is just for clarification, for other forum/Win10 users.)
      That is correct. I followed the instructions "Set Private Network" (it was previously set as part of a business network), restarted my PC and authenticated access to SMB was working again.

      Personally the workgroup and the advance network sharing options were already in line with the "Set WORKGROUP name" and "Advanced Sharing Settings" parts of the guide so, I didn't have to fiddle with them (others may though).

      And yes, I can still access shares marked as "Only Guests" without following the "Update 11/26/18 - SMB Guest access" part of the guide.